1 Reply Latest reply on Sep 13, 2013 11:28 AM by Diego_Intel

    Unable to update BIOS (DG45ID)

    Mystion

      EDIT; I've been reading around a lot, and now I've got the .ISO image on CD to work (had to adjust some bios settings and disconnect both my hdd and ssd from the mobo).

      I've been able to 'start' the BIOS update but now it hangs at:

      This system is about to be upgraded with BIOS release; id0127.bio
      Press any key to continue... (pressed enter)

      IFLASH2 Version 2.4 - Build 064

      _

      And from here on out it's been unresponsive for over 30 minutes again... I really don't know what to do :S

       

      This happens with ALL BIOS versions I try to update using IFLASH2!!! I've been able to upgrade up to version 0087 so far (still uses IFLASH instead of IFLASH2).

       

      I was now able to update bios to version 0089 using the bootable CD method by using IFLASH (one!!!!) instead of IFLASH2.

      This is 100% definitely an issue with IFLASH2 !!! I am unaware what kind of risk applying updates meant to use iflash2 with iflash (one) but at this point it's either that OR buying a new mobo (which obviously won't be an intel one).

       

       

      Old post below:

      Ok, so I've tried everything.

      I know support is discontinued but there's a lot of smart people on here who might be able to help.

      I've recently installed more RAM (8GB) and a new graphics card in my PC which uses the intel DG45ID motherboard.

      My BIOS version hasn't been updated since I bought the PC (been told I shouldn't update until I run into problems), but there's known compatibility issues with the BIOS version 0077 (which came with the mb). Namely the use of 16x graphics cards and the use of 8gb ram (both slow the BIOS down to a crawl, the POST as well as the navigation for options load very slowly.)

       

      I've tried:

      1) Update directly to the latest version with Iflash (USB). Upon making a bootable USB stick (checked it on laptop and it IS bootable!) and booting the PC with DG45ID, the BIOS boot will NOT advance further than the POST screen with code 50 (enumerating PCI busses). It hangs on this screen for 30+ minutes and the usual additional text (F2 for bios, F10 for boot options, F12 for boot pxe) do NOT show up. I have to manually restart computer. Upon removing the USB stick this problem stops. I've tried 3 different USB sticks on EVERY USB port I have available (front AND back).

       

      2) Update with USB to previous versions. Same as above

       

      3) I looked up the 'latest' previous version which still solved the issues with 8GB RAM and found this version also had an .ISO option. I properly dowloaded and burned the ISO image on a CD. When inserted into reader in PC with DG45ID it runs fine and I can boot from the CD. When I press enter, a lot of text flashes by but then only to stop on errors indicating 'Can't open CD driver CDRCACH'

       

      4) Seeing as this is my last option, I tried RECOVERY. Copying the .BIO file to my USB, I inserted it, then powered off the machine, unplugged it, opened it and removed the jumper, then plugged it back in and started it.

      On this bootup I get NO video, not from onboard graphics nor my brand new graphics card, and my keyboard/mouse/optical drive/USB lights get 'powered' for two seconds, then shut down for two seconds, then power up again for two seconds, then repeat.... This loop does not stop and after 30 minutes my fans (which are powered constantly btw) start speeding up as if my processor turns hot. Another 30 minutes later still no change so I manually powered down the device.

      Replaced jumper, startup, no issues but BIOS is still very slow (5+ minutes just to get to windows starting!!)

       

      5) I then tried RECOVERY using a CD, just copied the .BIO file to a (working, brand new, empty) CD and repeated the recovery steps, EXACTLY the same thing happens as when I tried with USB. I know for sure it's not actually 'working' or doing anything because it powers down the CD reader every 2 seconds before it even reaches full speed!!

       

       

      I'm out of ideas now, there's no other possible way to try updating my BIOS that I know of.

      Is there a fix for the no startup with bootable USB inserted or for the CD driver CDRCACH thing?

      Otherwise I'm going to have to plod along with my insanely slow BIOS for a while I guess...

       

       

       

      PS: current version; 0077 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=16678&lang=eng&OSVersion=%0A%09%09%09%09%09%09%09%09%0A%09%09%09%09%09%09%09&DownloadType=BIOS

      Latest version: 0135 Download Center

        • 1. Re: Unable to update BIOS (DG45ID)
          Diego_Intel

          Please bear in mind that this product has reached its End of Interactive Support so Intel no longer provides interactive support for this product via telephone, chat or e-mail.

           

          During the BIOS recovery and using an USB thumb drive, did you disconnect all peripherals not required for the update, even the mouse, keyboard, hard drives and any other CD/DVD ROM? We have seen in the past that when other peripherals are connected, the BIOS recovery may fail.

           

          One thing you may also try before the update is doing a BIOS recovery. You clear the CMOS removing the CMOS battery and all power cables from the power supply to the motherboard, leaving the system without power for 20 minutes at least

           

          Furthermore, when the BIOS is too out dated, is recommended to do the updates in a progressive way, by using middle versions between what you have and the latest. Specially when the ME firmware has been changed between releases. For this you can test using the next release, BIOS version 0091

           

          To check the firmware versions between BIOS releases, you can check the release notes here:

          http://downloadmirror.intel.com/19845/eng/ID_0135_ReleaseNotes.pdf