11 Replies Latest reply: Jan 7, 2014 7:59 PM by rtaranu RSS

Intel HD Graphics 4000 scaling does not work

smuck Community Member
Currently Being Moderated

How can you remove this scaling nonsense from graphics ?


It does not work in all applications, fx. in "Company of Heroes 2" program it just adds giant black borders instead of the selected resolution in the application´s video options. It is possible to change the desktop resolution first and then run "Company of Heroes 2" with matching resolution, but it´s a nuisance.


You can select to center image of desktop in intel graphics advance settings control panel scaling with a low resolution and then you get a tiny desktop on a large black screen. It obviously effects the default settings for windows that don´t have this useless setting. So how can you get the intel hd graphics driver without this scaling crap, so applications can run normal also in lower resolutions ?

  • 1. Re: Intel HD Graphics 4000 scaling does not work
    Diego_Intel Community Member
    Currently Being Moderated

    Try using the "Scale Full Screen option" in your system rather than the center image or maintain aspect ratio (which adds those black borders).

     

    Keep in mind that these options will depend on the resolution that you are using, whether you are using the native resolution of the display or a "not-native" resolution.

  • 2. Re: Intel HD Graphics 4000 scaling does not work
    smuck Community Member
    Currently Being Moderated

    Obviously you don´t see the problem because who ever developed the intel HD graphics control panel only provided "Scale Full Screen" option for profiles and does not exists for the highest resolution.

     

    Here is a picture of the scaling options for 1280x720. To use it you have to save that profile. But the application doesn´t look for any profile, it just changes resolution as usual.

    Snapshot 1 (05-09-2013 22-40).png

     

    Here´s a picture of the native resolution options and as you can see there is no "Scale Full Screen" option!

    Snapshot 1 (05-09-2013 22-39).png

     

    Here´s the result:

    Snapshot 1 (05-09-2013 22-52).png

     

    Btw. there are two commandline applications for changing resolution that can be used in a batch file.

    1) Display Changer: The result is the same: giant black borders.

    2) QRes: This one can not launch the application, so it´s the same as changing the desktop resolution first, which mean that a) if you alt-tab out of fullscreen the whole desktop is resized... b) when the resolution is changed backto native: all windows have become small.

     

    What´s the point with the "Center Image" option and watching everything with black borders ? How can you remove scaling and get normal behavior ?

  • 3. Re: Intel HD Graphics 4000 scaling does not work
    Diego_Intel Community Member
    Currently Being Moderated

    I checked through COH2 forums and it seems that the problem could be on the game itself.

     

    You may need to check and make sure that Teamviewer is not running in the background.

     

    You can also try using Alt+Enter when being on the game.

     

    Furthermore you can addin -fullscreen -window to the game launch options.

     

    In addition, have you tried changing the resolution on the game setting itself?

  • 4. Re: Intel HD Graphics 4000 scaling does not work
    smuck Community Member
    Currently Being Moderated

    Guess that means that it can´t disable profiles and set graphics to auto fit screen on every resolution then.

     

    COH2 uses Dx10 minimum (while COH which works okay uses Dx9) so it´s probably DirectX if anything.

     

    After testing it appears that the problem only occurs when launching COH2 from native 1920x1080p. Fx. If QRes set resolution to 1600x900p or 800x600p and COH2 is launched and set to run in 1280x720p, then it will run in 1280x720p without black borders. Only when launched from 1920x1080p desktop resolution does it have big black borders.

     

    This computer also has the GeForce GT 750M. And black border results are the same when selecting Nvidia processor or Intel processor to run app.

     

    It has to be the intel driver, when that is what controls the scaling.

     

    Best solution so far: Launch the app from highest (16x9) resolution under native, so the desktop windows won´t be so sized small.

  • 5. Re: Intel HD Graphics 4000 scaling does not work
    Diego_Intel Community Member
    Currently Being Moderated

    What other applications are you having this issue with?

     

    To me if its happening even when using a third party video GPU too, it seems to indicate a problem with the game actually, as Intel(R) video drivers, do not override settings on the third party controllers.

  • 6. Re: Intel HD Graphics 4000 scaling does not work
    smuck Community Member
    Currently Being Moderated

    That the issue occurs in other applications is just an assumption based on other forum posts about black borders and intel graphics.

     

    Maybe COH2 is the only one with the issue. But since it´s possible to workaround by launching from 1600x900p it doesn´t seem so much of a problem anymore.

     

    Else it would have been nice if all scaling options could just be removed from driver, since there doesn´t seem to be any use for the "center image" with black borders option.

     

    Thanks for the support.

  • 7. Re: Intel HD Graphics 4000 scaling does not work
    Diego_Intel Community Member
    Currently Being Moderated

    We appreciate your feedback on this, I will forward it for further consideration regarding scaling options.

  • 8. Re: Intel HD Graphics 4000 scaling does not work
    smuck_ Community Member
    Currently Being Moderated

    Hi, again!

     

    This is another game like, suppose it uses DirectX11 also. (1280x720p)

    Snapshot 1 (07-11-2013 18-38).png

    But fortunately it has a lot of graphics settings and it seems like it can run with nice graphics even in 1920x1080p.

     

    Intel driver used is Win64_153117.exe

     

    Either the scaling fills out the screen without any black borders so older games like Battlefront appears wider or newer games with lower resolution than native appears with black borders around.

     

    The ideal would be that regardless of resolution any fullscreen application´s graphics is filled out except from those older games that should have two black borders on each horizon regardless of resolution to appear with aspect 4:3.

  • 9. Re: Intel HD Graphics 4000 scaling does not work
    Nico884 Community Member
    Currently Being Moderated

    Hi,

     

    I have the exact same problem with crysis 3 and assassin's creed 4.!

    According to microsoft ( Afficher les jeux en plein écran sous Windows 7), the only solution is to modify the screen resolution every time!... Even 10 years ago we didn't need to do this!

     

    I wish intel will come up with a real solving method for this!

  • 10. Re: Intel HD Graphics 4000 scaling does not work
    allan_intel Community Member
    Currently Being Moderated

    The issue has been escalated to our research department; I suggest you keep visiting our website for any updates on this inquiry.

     

    Allan.

  • 11. Re: Intel HD Graphics 4000 scaling does not work
    rtaranu Community Member
    Currently Being Moderated

    Hello, I am also seeing this issue. I can reproduce it reliably on a Dell Inspiron 15" 7537

    Windows 8, Intel 4400, Nvidia 750M, native laptop resolution is 1080p

     

    Nvidia drivers : 331.82-notebook-win8-win7-64bit-international-whql

    Intel drivers : Win64_15338

     

    In the game(s) Bioshock Infinite and Battlefield 4, if I set the resolution in game to 720p, the image will not stretch to fill the screen up, it will be centered with black bars all around.

     

    I have found a work around to force correct stretching of the image: I have to set the desktop resolution to 1600x900, and launch the game. I can then change the in-game resolution to anything and it will fill the screen correctly. Once I revert the desktop resolution to 1080p, games will stop stretching correctly.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points