1 Reply Latest reply on Sep 4, 2013 10:28 AM by sylvia_intel

    Gigabit Ethernet Controller Misidentified - no network connection

    jemptage

      I have an Intel DX58SO motherboard running Windows 7 SP1 (x64) which has a 82567LM-2 Gigabit Ethernet controller on it but in Device Manager it is showing as a 82566DC-2 and under properties I get the message 'The service could not start"  (code10) which results in no network connection. I have tried installing latest drivers Ver. 18.5 (listed for ethernet contollers) and Ver. 17.1 (listed under the motherboard) neither works and both show the controller as 82566DC-2 after install. I have uninstalled and scanned for new hardware and get same result. I have manually set the controler as a 82567LM-2 and get the same "code 10" . The problem occurred after the network controller would not reconnect after sleep mode (which has happened before and reconnected after reboot). Any ideas on getting this setup right again?  I have also tried system restore and a repair reinstall of Windows 7 SP1.

        • 1. Re: Gigabit Ethernet Controller Misidentified - no network connection
          sylvia_intel

          Hello Jemptage,

           

          This is an odd behavior; however please check under the “configuration” tab on BIOS if the Ethernet controller is being recognized.

          Also, please check under “onboard devices” if LAN is still enabled.

           

          Finally, if all the previous steps are correct, what you can try is a clean instillation of Windows.

           

          Which is the current BIOS version of the motherboard? please let me know

           

          Regards.

          1 of 1 people found this helpful