14 Replies Latest reply on Jun 11, 2011 11:25 AM by

    Bios Update D945GTP

    PeterVa

      The bios update fails were it is prompting to upate lan controller during the process. The Process for prepairing the images is complete. As it goes to install the first lan image the process stops. I have performed every version of update possible, ie Ex , floppy, removed the jumper used floppy.

      Any ideas

        • 1. Re: Bios Update D945GTP
          Javed Lodhi

          Hi Peter,

          I am sure you must be doing the right thing but just to make sure, did you refer to the BIOS update instructions that I am posting below:

          http://www.intel.com/support/motherboards/desktop/sb/CS-022312.htm

          The URL specified above contains instruction set for different mechanisms that are available for you to update your BIOS and even recover a corrupted BIOS. However even by trying all these methods, you still don't succeed, kindly post the screenshots of the method you are adopting along with the error prompt so that we are better able to assist you in getting your problem resolved.

          Thank you and have a great day!

          --

          Warm Regards,

          Javed Lodhi

          Intel Go Green, Save The Environment!

          • 2. Re: Bios Update D945GTP
            PeterVa

            Thanks so much for your help

             

            The procees that I am familiar with are the expess as well as IFlash both give same results

             

            The dos box created after reboot

             

            current version            NT94510J.86A.1788.2005.0728.1510

            updating to revision     NT94510J.86A.3996.2006.0908.1329

            prepairing image for Lan  ......     done

            preparing image for etc

            ...

            flashing image for lan ......     at this point the process halts.

             

            We install aprox 20 systems a year with intel purchased boards and do bios updates for these yearly. This is the first sort of rad block. There was a requirment to upgrade to the current version prior to newer ones. That bios upgrade can be reapplied with out failure.

             

            Thanks again

            • 3. Re: Bios Update D945GTP
              Aryan2411

              Hi there,

               

              Actually, there is two other methods to do a bios update on the Intel Desktop Board.

               

              They are the:
              1. ISO Method
              2. Recovery Method

               

              So far, i have always used the Recovery method and it worked fine for me. It never fails recovery through a CD.

               

              Anyway i am going to explain to you how to do a recovery thru a FAT-FORMATTED USB stick.
              Same thing can be done on a CD as well.

               

              Instructions for the BIOS RECOVERY:

              ============================

              1. Copy the recovery file BIO file (*.bio) to a formatted usb disk.
              http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&Inst=Yes&ProductID=2064&DwnldID=17290&strOSs=38&OSFullName=OSIndependent&lang=eng

               

              2. Place the usb disk in the target system.
              3. Shut down the system and unplug AC power.
              4. Open the chassis and remove the BIOS Configuration Jumper. See the Technical Product Specification for details

              including the location of this jumper.
              5. Power the system on.
              6. Wait 2-5 minutes for the update to complete. When the usb drive LED is lit, the system is copying the recovery

              code into the FLASH device.
              7. System will either turn off when the recovery process is completed or it will prompt you to turn off the system.
              8. Remove usb disk
              9. Replace the BIOS Configuration Jumper.
              10. Restart system.

               

              Note: these can be found on:

              Website: http://downloadmirror.intel.com/17197/eng/BIOS%20Update%20Readme.pdf

               

              If this fails as well, try the iso method.

               

              Let us know how it goes.

               

              All the best,

              Regards,
              Aryan

              • 4. Re: Bios Update D945GTP
                jamesutz

                Here's the solution.  It is now posted in the Intel BIOS download page for version 4119.

                 

                Warning: For boards that support Intel® Active Management Technology (D945GTP and D945GCZ), you must first update to BIOS version 1788 and then update from 1788 to the newer BIOS version, otherwise the update will fail.

                 

                You have to down-rev the BIOS to version 1788, then up-rev to version 4119.  Worked when I tried it.  Links to version 1788 are provided on the download page for version 4119.

                • 5. Re: Bios Update D945GTP
                  KernelSoftware

                  Same problem here, but the down rev solution won't work for everyone.  Certain processors require BIOS 3992 or later.  I updated from an earlier version to 1788 and then from 1788 to 3992.  When I try updating from 3992 to 4131, I get the same hang on flashing image for lan as everyone here.  However, due to the processor, I cannot go back to 1788.

                  • 6. Re: Bios Update D945GTP

                    Hello,

                    I have against the same problem, and the solution is very simple. It is necessary to disconnect the cable network!

                    • 7. Re: Bios Update D945GTP
                      KernelSoftware

                      We also found a simple solution: Reset the BIOS to factory defaults.  After that, the update worked fine.

                      • 8. Re: Bios Update D945GTP
                        htw7422

                        After switching off all peripheral things in BIOS the update was successful.

                        • 9. Re: Bios Update D945GTP

                          After 3 years, the BIOS updated successful!!!

                          NT94510J.86A.3996.2006.0908.1329

                          direct updated to

                          NT94510J.86A.4131.2009.1122.2232

                          with "switch off all peripheral things in BIOS" and  "disconnect the LAN cable"

                           

                          Thanks: OliverOne & htw7422

                          • 10. Re: Bios Update D945GTP

                            Just to confirm that with "switch off all peripheral things in BIOS" and  "disconnect the LAN cable" worked for me.

                            Done BIOS update directly from OEM version 3996 to 4131; hopefully it will fix my issue with "White Screen" in Windows 7 64 bit version.

                            • 11. Re: Bios Update D945GTP

                              Sorry for the stupid question but what is meant by "switch off all peripheral things in the BIOS"?  Are these BIOS settings or do you pysically unplug stuff?

                              • 12. Re: Bios Update D945GTP

                                I only changed the settings in BIOS.

                                 

                                htw7422

                                • 13. Re: Bios Update D945GTP

                                  This has been an issue for a long-time. Thanks for the ACTUAL solutiuon!!

                                   

                                  To clarify,

                                   

                                  Go into the BIOS, go to Advanced (Seond option) then Peripheral Configuration, On-Board LAN and disable.

                                   

                                  Then  you should be able to run the update.

                                  • 14. Re: Bios Update D945GTP

                                    I also have the problem of not being able to update the BIOS on a D945GTP Board.  Current version is 3076 and I'm trying to go to 4131. I've tried to disable the "On-Board LAN" but even though I save on exit the settings don't stick.  I suspect this might be part of the problem but still looking for a solution.  Anyideas?