10 Replies Latest reply on Oct 1, 2009 6:50 PM by joebie

    945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94

    Dragon-Master

      Hi,

       

      my new Home-Server works with a Intel 945GCLF2-Board. After installing WHS (incl. all actual drivers and MS-Hotfixes) it works fine for a few hours.

      When I reboot the server the BIOS-Postcodes run down to 00 and then switch to 94 (=enter BIOS). But with this board you can enter BIOS only when switching a jumper

      ==> the boot of the server stops.

       

      First i thought of an defect of the board and changed it to another of the same type ... same error...

       

      Any ideas what to do ?

       

      Thanks

      Christian 

        • 1. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
          jef

          There appears to be a significant flaw in the BIOS or the design of these boards related to detection of bootable devices.

           

          I have three different boards that all exhibit similar problems

          • Boots sucessfully once off non-CD drive (PATA, SATA, USB flash, USB hard drive)
          • On reboot, "never" again able to identify any non-CD drive as bootable

           

          Power down, as well as removing the power supply cable does not seem to resolve this issue.

           

          At first I thought a problem with the GPT drive formatting that I was attempting, but this effects all drives attached to the system and the drives were later confirmed to be bootable on other non-945GCLF2 machines.

           

          Additionally, it appears that kernel memory is being retained across boots, which is very strange indeed.

           

          There are some hints at http://www.ocztechnologyforum.com/forum/showthread.php?t=52969 which I found yesterday. I haven't been able to confirm any of the results there in my situation, but this appears to be a serious issue with the boards that may need Intel resolution. (For example, disabling "restore previous state on power-up" is not acceptable for devices being used as headless servers.)

           

          Intel Atom 330 on Intel D945GCLF2 motherboard, 2 GB RAM,
          BIOS LF94510J.86A.0140.2008.1231.0012, later updated to
          BIOS LF94510J.86A.0182.2008.1231.0012

           

          Wish I had an answer for you. We've been hitting our heads against the wall on this one for a few days now. If I get a meaningful response back from Intel support, I'll post here.

           

          Edit: Possibly related -- http://communities.intel.com/message/11883

          • 2. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
            jef

            http://communities.intel.com/message/11903

             

            Via Google Translate:

             

            I have a Desktop Board D945GCLF with a CD / DVD and an IDE hard drive is also IDE, install Windows XP (SP1, SP2 or SP3 OEM) and ends perfectly, but when I restart it says I have no operating system, and change the IDE cables and replace the hard disk and CD / DVD, and configures the BIOS to boot from the hard drive and not the CD but I get the same error, and delete the bios (according to indications from the intel site), I have performed this procedure about 10 times and always see the same error.

            • 3. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
              unplugged_24

              Hi there,

               

              The postcode: 94 is related to keyboard (Clearing keyboard input buffer). This postcode occurs at different stage during system post before and when you see the Intel logo screen. However since you cannot get to BIOS by pressing the F2 key, I assume that this is occuring at the later stage.

              Moving the Bios jumper to maintenance mode will always force the system to go to bios and since you can get to bios only by this method then there may be something not working properly.

               

              Just to be sure which component is causing this issue, please can you use only basic components during testing.

              With only motherboard, power supply, 1 module of memory, keyboard and monitor. (Out of chassis will be better).

               

              - Clear the CMOS, removing motherboard battery and put it back after 30 minutes.

              - Update the BIOS, twice.

              - Use either recovery method or iflash method: http://downloadmirror.intel.com/17694/eng/BIOS%20Update%20Readme.pdf

              Download bios update: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&Inst=Yes&ProductID=2926&DwnldID=17694&strOSs=38&OSFullName=OS%20Independent&lang=eng

               

              - After bios update, go to BIOS (pressing F2 during post), then load default settings, save and exit.

              - Add you hard disk and dvd drive and re-install the OS and drivers.

              Note: The Windows Home Server is not supported on this board: http://support.intel.com/support/motherboards/desktop/sb/CS-008326.htm

              If you are using Windows XP or 2003, make sure you have at least Service Pack 2 included in the installation.

               

              Also make sure you are using compatible memory: http://support.intel.com/support/motherboards/desktop/d945gclf2/sb/CS-029532.htm

               

              Since you have already changed the board and the problem remains, then there could be something you are doing wrong or some of the components are not compatible. Try with different memory, hard drive and operating system if the problem remains after you have tried all of the above. Remember, clean os installation is recommended if you change motherboard.

               

              Hope this will be helpful to you.

               

              Cheers

              • 4. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
                jef

                I also don't believe this is an OS problem, as it never makes it past the boot, from what I can read from the OP's description, my experience, and the others referenced. (However, that does not mean that once the system boots that there will be driver support for a specific OS version, as unplugged_24 points out).

                 

                "94" appears in the bottom right of the screen during the time I associate with the BIOS finding a bootable drive. It is often remains on the screen for tens of seconds (during which time the CD/DVD can be heard to be spinning up and then later down), then, very briefly, a 0 that almost immediately replaced by the no bootable drive message. The message usually is the "No bootable device -- insert boot disk and press any key" Very occasionaly there has been a different message, indicating lack of a bootable drive and referring to, as I recall, a URL.

                 

                There are rumors that this may be related to the Wake-On-LAN and restore state / power-up at power-applied features for the board.

                 

                I have now had to buy "approved memory" and can confirm that the problem still exists with Corsair VS1GB667D2 memory, which is on the list (as well as seeing the problem with three diffeent Corsair VS2GB667D2 and two different CMX2x2048-6400C).

                 

                I haven't been able to reliably narrow down what gets the BIOS and MB "unhung" but "Default Settings" are how it gets into this mess. It seems that setting the Wake-On-LAN and state after power-applied to <Stay Off> can help. This has not been reliable at all.

                 

                I don't think I've ever seen the "Intel logo screen" on any of the three boards which exhibit this problem (of the three I have opened), if that helps an engineer that may be reading this. The boot process has been a black screen with an occasional pair of characters in the lower right.

                 

                AA E46416-105 with serial numbers AZLS91700FT7, FSK, FF9

                 

                Removing the battery, memory, and power supply cord for 30 minutes does not appear to reliably resolve this issue, though changing from MBR to GPT on the boot device may be related to this.

                 

                After again confirming that the drive boots another vendor's Intel-based computer, it is clear that GPT drive is fine -- actually boots MB in question if LF0182P.ISO CD is allowed to continue through without installing new BIOS. Will not boot directly from BIOS.

                 

                Now, after three successful reboots, this no longer works, the CD is not being seen as bootable any more either. No changes made to BIOS or boot sectors.

                 

                Hard drives have included Seagate ST9500325AS (SATA), Hitachi HTS541616J9AT00 (PATA), also have seen same issue with Corsair 16M flash (USB, and aware of MBR format limitation on USB-attached drives). Power supplies have included Allied AL-8250SFX (250W, ships with Apex MI-100 cases), as well as Antec EA-380.

                 

                Re-flashing the BIOS (yet again) does not resolve the issue.

                 

                After entering and leaving maintenance mode a few times, reverting to defaults, then back to not supporting Wake-On-LAN and alowing USB devices to boot first (external CD/DVD on USB), once again it is booting the GPT drive (internal PATA) through the BIOS CD. This suggests to me that it truly is a BIOS problem, as the kernel running apparently can read the GPT, see it as bootable, and chain load the boot sector from the hard drive.

                 

                Now if we can only teach the MB's BIOS to do the same...

                 

                2009/06/17

                 

                Power outage experienced (longer than UPS would support), unfortunately. After restoring power, MB will not recognize even USB CD drive containing BIOS update disk. F10 allows selection of all expected devices, but will not boot off either USB-attached CD drive or internal PATA drive.

                 

                Board bricked and pretty useless at this time.

                 

                2009/06/18

                 

                Again confirmed that F10 would not boot from either the menu entry for the properly identified internal HD or USD CD drive. Codes went from "94" to "0" (briefly), then to the PXE boot messages. Network boot is lower in priority than all derives. USB boot priority was already enabled.

                 

                After many trips into the BIOS, removing Network and Floppy boot options enabled the BIOS to boot off the USB CD drive, but not the internal hard drive. As before, the BIOS install CD with its ISOLINUX OS seems more than happy to chain load the boot sector off the internal hard drive. The display indicated "E9" then "BA" followed by a brief "0" before booting from the CD. After the CD completed, the boot loader on the hard drive displayed as expected to the video (Samsug SyncMaster 244T connected through the analog VGA input, without any intervening switches or cables.) Keyboard is a venerable Keytronics K288 PS/2 model which has been verified to be functional on a wide range of hardware from use of 5-pin adapters, through Intel SE440BX boards, to a variety Asus/AMD systems, as well as other of the D945GCLF2 boards, in BIOS and running OS.

                • 5. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
                  gustopn

                  I have also problems with that board - see my postings - and I am not able to change the boot device priority in BIOS. I dont know how I was able to get around it, but I think it does always boot from dvd first. And when I want to flash bios and therefore boot from USB, I have to unplug any IDE or SATA cables, to let him the only choice to boot from USB. That board/bios is REALLY broken at all. I think Intel should shame on them and make a new BIOS vers. that solves a few of this problems as soon as possible.

                  • 6. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
                    jef

                    Lars,

                     

                    Your problem is, from the sound of it, a different one. I believe you can easily resolve it by enabling the setting in the boot section of the BIOS to allow USB devices to boot first. It's a little confusing that the setting there seems to interact with the boot order, even in "advanced" mode.

                     

                    My guess is that feature was put in to provide some level of resistance to USB-borne viruses (the idea being that the MB wouldn't boot off an inserted stick unless enabled in the BIOS).

                    • 7. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
                      unplugged_24

                      Sorry this reply was not intended to this specific post. I edited it and sent it to the correct post.

                       

                      Message was edited by: unplugged_24

                      • 8. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
                        Dragon-Master

                        Hi,

                         

                        the Post Code 94 Problem ist solved. My KVM-Switch made the trouble.

                         

                        But next Problem ist that the system crashes with Dump and the reboot stops at Post Code E9 ....

                         

                        f*** .... ;-(

                         

                        Any ideas?

                        Could it be problem with the ACPI-HAL from Windows?

                         

                        Christian

                        • 9. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
                          gurudath

                          In the BIOS under Boot section set the USB mass storage emulation type to All Fixed disks. The default option Auto assumes the large capacity USBs as disks and will not boot through them. It worked for me. Hope this fixes your problem also.

                          • 10. Re: 945GCLF2 (Atom 330) - Windows Home Server - BIOS PostCode 94
                            joebie

                            I'm having the same problem. I had a working installation of Fedora 10 after reinstalling with debian with gpt partitioning it will only boot from usb or lan. Reinstalled and created an msdos partition table, didn't help. Still only bootable from lan or usb. I haven't tried zeroing out the first and last +/- 32256 bytes of the drive it might be helpfull I will let you know after I've tried.