10 Replies Latest reply on Sep 4, 2013 11:43 AM by JRutski

    DC53427HYE - NIC struggles to connect

    JRutski

      I have seen a few threads about this but I am using the i5 based NUC DC53427HYE as a test and am having some issues with the NIC. On boot and wake from sleep, the NIC will connect for half a second then disconnect, then connect for half a second then disconnect.....and repeat this process for sometimes upwards of 5 minutes. While sometimes its not really an issue, it often wreaks havoc with group policy processing at boot time.

       

      I was originally connected via the HDMI port directly adjacent to the NIC, but after reading the other threads, I am now connected to the mini-display port farthest away from the NIC.

       

      Short of RMAing this, is there ANYTHING that can be done? Thanks

        • 1. Re: DC53427HYE - NIC struggles to connect
          lhill

          Hello JRutski,

           

          Can you confirm for me if the connection problem goes away when you plug your display into the mini-displayport (and not into the HDMI port next to the LAN jack)? If that is the case, I will need to escalate this to our engineering team for investigation.

           

          Regards,

          Lois H.

          Intel

          • 2. Re: DC53427HYE - NIC struggles to connect
            JRutski

            Hi Lois-

             

            The connection problem was NOT resolved by switching to the mini-displayport farthest from the NIC. Connecting to either display had the same results - continual disconnect\reconnect for several minutes after power on or wake from S3 sleep.

             

            Thanks for the reply.

            • 3. Re: DC53427HYE - NIC struggles to connect
              lhill

              Hi -

               

              Thank you for the information. This appears to be siomewhat different than the earlier issue where the LAN perfomance itself was the problem (slow connections).

               

              I'll work on reproducing your issue here, so will need some additional information from you to make sure I configure everything to match yours:

               

              - BIOS version currently installed on the NUC

              - SA# of the NUC (on the label on the bottom)

              - Are you configured for both wired and wireless LAN? If both, what wireless LAN card are you using?

              - what LAN driver version do you have installed? (And if wireless is there, which wireless driver version?)

              - what tool/utility are you using to see the connect/disconnect issue?

              - any other configuration info that may be a factor (switch, router, etc)

               

              Thanks,

              Lois

               


              • 4. Re: DC53427HYE - NIC struggles to connect
                JRutski

                Lois-

                I RMA'd the hardware and have received a replacement. Unfortunately, the new hardware exhibits the same symptoms which leads me to believe that this is likely a software driver issue.

                 

                I can get the BIOS version and SA# shortly, but here are some other details:

                - This is wired LAN only, there is not a wireless adapter installed in the unit

                - NIC: 82579LM driver version 18.5

                - The disconnects are visible on the physical adapter status LEDs. Further there are several event logs that point to this issue

                - The adapter is connected directly to a Cisco C2970G (while this looks like a spanning tree issue, it is disabled on the interface). Further any other device connected to this interface do NOT have this issue

                 

                The event logs are riddled with the following:

                Source: e1cexpress

                Event ID: 27

                 

                Intel(R) 82579LM Gigabit Network Connection

                Network link is disconnected.

                 

                Further, I can physically see the link drop then reconnect, then drop then reconnect.

                 

                Per other forum posts around, I have disabled the SIPS feature in the driver. This issue still occurs with either the basic driver set or full ProSET - though the basic drivers don't seem to be as bad.

                 

                I have worked around the issue by doing the following:

                - Not allowing the NIC to sleep to save power

                - Disabling 'energy efficient ethernet'

                - Disabling SIPS

                That being done seems to allow the system to come out of S3 without dropping connection - however a full reboot still has issues.

                • 5. Re: DC53427HYE - NIC struggles to connect
                  lhill

                  Hi again,

                   

                  I currently do not have a switch available that I can use to reproduce the same layout as you have. I'll see about getting one.  In the meantime, I found something interesting on Cisco's website about interoperability with Intel LAN solutions at http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a00800a7af0.shtml#nic_comp

                   

                  Here is their recommendation to workaround connection issues:

                   

                  1. In Device Manager, choose Network Adapters and then the Intel LAN adapter you have. 

                  2. At the Power Management tab, uncheck Allow the computer to turn off this device.

                   

                  Please give this a try and let me know what happens.

                   

                  Our engineering team would definitely need to have a system exhibiting this behavior in order to debug and find a solution. If we are unable to find the right combination here to reproduce the problem, would it be at all possible for you to send us the failing system?

                   

                  Lois

                  • 6. Re: DC53427HYE - NIC struggles to connect
                    JRutski

                    Lois-

                     

                    The note on the Intel site is specific to the PRO100\1000 series chipsets - while I don't know how close the chipsets are. Further, the workaround does not work - as I noted previously, allowing the computer to turn off the NIC worsens the issue.

                     

                    I can connect to a different switch - however I doubt this will make a difference as no other devices on the network have this issue - and again both the old as well as this NUC exhibited this issue.

                     

                    I am not able send the device in currently.

                    • 7. Re: DC53427HYE - NIC struggles to connect
                      ASadani

                      I had the exact same issue with the i5 version of the NUC. The NIC would have difficulties to connect. Unfortunately I didn't have the option to connect via the mini display port as I use it as an HTPC. After days of struggling I returned the unit and purchased another piece from newegg and that has been flawless since. I believe there is an inherent defect on the NUC boards that cause this issue to uncover itself.

                       

                      I tried the RMA process but since the i5 version of the NUC was new and intel didn't have it in stock, I went through the exchange process. One thing to note. the one I purchased on Amazon wasn't sealed in shrink wrap as the one I received from newegg.

                       

                      I've seen this issue on an i3 version of the NUC as well but in that case switching to the furthest hdmi port fixes the issue. But in my opinion all ports if provided should work.

                      • 8. Re: DC53427HYE - NIC struggles to connect
                        lhill

                        Hi,

                         

                        I've been working on various combinations of NUCs, OS versions, with and without a Cisco C2950 switch and have found the following:

                         

                        - I see the Event ID 27 both with and without the switch on Windows 7, but I don't have the long period of connect/disconnect after waking from sleep

                        - I never see Event ID 27 on any of the Windows 8 configurations

                         

                        I have asked my colleagues in the LAN team to take a look at this and will let you know what I find out.

                         

                        Regards,

                        Lois

                        • 9. Re: DC53427HYE - NIC struggles to connect
                          ASadani

                          Hi. This does not seem like an OS issue as the problem persists in windows 8 as well. When I was having this issue I installed windows 8 and the NUC still disconnected. Hope this helps

                          • 10. Re: DC53427HYE - NIC struggles to connect
                            JRutski

                            Lois-

                             

                            I will try connecting the NUC to a separate switch shortly. Additionally, I will upload a video showing the physical NIC leds.