1 Reply Latest reply on Jul 23, 2013 3:36 PM by Dan_O

    I need help.I can not enter BIOS (intel5520sc motherboard)


      I have several problems with my pc.
      I have 5520sc motherboard. I couldn't install windows 7 on my computer. It comes to the end process and just hangs there forever (configuring windows part)...I talked with another pal (who have exactly same system configuration) for a solution. He said  that i have to disable the audio/video devices and turn sata mode to AHCI. I disabled onboard video and audio device . It didn't worked, then i turned sata mode to AHCI(previously ENHANCED). When i reboot it didn't worked too(i mean windows install problem continues). Then i mistakenly changed the "AHCI Option Rom" to DISABLED. After a reboot, first some text showed up but boot worked from cd and i started to install windows. Then windows operated first reboot and entry screen (which you press F2 to enter bios) showed up. It freezed!! I rebooted again and now i can't even enter to BIOS! When i click F2 nothing happens and a click sound comes from board...Now i have a bigger problem i guess Should i have to reset BIOS? What is the solution for both problems?


      I need  any help you can offer. Please help me immediately. I am begging ...Thanks