12 Replies Latest reply on Jul 22, 2013 4:16 AM by Fernando

    Intel RST WHQL - Bug

    Igor Maysky

      After installing Intel RST WHQL, when you try to shut down the computer with the Start -> Shut Down - computer restarts. Rollback to WHQL - solved this problem. Please fix this bug in a future release. (sorry for my english)


      MB: s1156; P55; ASUS P7P55D-E (bios v1601)

      CPU: Intel i5-750 (2.66Ghz)

      Intel ports:

      SATA1: Crucial M4 64Gb

      SATA2: WD 2Tb Green (WD20EARS)

      SATA3: ASUS DRW-20B1LT

      Windows 7 Ultimate SP1 64-bit (Russian)

        • 1. Re: Intel RST WHQL - Bug

          Thank you for your feedback on this matter, we will forward it to the proper team for further consideration. Please keep in mind that this version has not been available in downloadcenter.intel.com for Original Equipment Manufacturer and third party systems

          1 of 1 people found this helpful
          • 2. Re: Intel RST WHQL - Bug

            I have the SAME SHUTDOWN problem with my MB ASUS P8Z77-V DELUXE , official ASUS Bios 2003, iRST V driver, OROM, W7 SP1 64 bits, Intel i7-3770K (3.5 GHz), 2 x SATA 6G Intel grey ports connected to SSD SAMSUNG 840 PRO RAID 0 volume.

            Intel support said iRST V is a customized version for a MB manufacturer and does no technical support !

            Intel support  suggests to come back to the official 12.5 version (as v 12.6 does no longer exist).

            Unfortunatly 12.5 version does not support TRIM RAID volume. ( support TRIM RAID 0 volume)


            Moreover a BIOS 2003 with OROM does not detect any CD/DVD devices which is a severe regression compare to OROM , so i can't boot from any CD/DVD (acronis backup).


            So, at the moment we have to wait bugs fixed.. in iRST software AND in OROM firmware.

            • 3. Re: Intel RST WHQL - Bug

              TRIM on RAID 0 has been supported on Intel(R) Rapid Storage Technology since the 11.x releases while using Intel(R) 7 series chipset based computers (except Intel(R) X79). So, iRST 12.5 supports TRIM on RAID 0.


              In the other hand, the option ROM is provided directly by your computer manufacturer, not Intel. In such case, if you have issues with the option ROM in your computer you need to contact your computer/motherboard manufacturer directly for assistance.

              • 4. Re: Intel RST WHQL - Bug


                No , absolutly no, iRST 12.5 does not support TRIM command on RAID 0.

                1) "trimcheck" tool can help you to test by yourself.

                2) Intel support confirmed me this:


                I am completely aware of this, in fact our Intel® Rapid Storage Technology supports TRIM in Windows 7* in AHCI and RAID mode, but for drives not part of a RAID volume

                Possibly for further versions of the Intel® Rapid Storage Technology we are going to include the TRIM functions in a RAID volume.


                12.6 fixed this, but this version is no longer available. 12.7 is TRIM RAID volume compatible, but there is the shutdown issue.

                About OROM issue i would like only report to Intel a bug and share experience.

                Bugs belongs to the authors not to the users.

                • 5. Re: Intel RST WHQL - Bug

                  100PIER is right. The Intel RST drivers v12.5,0.1066, which are still officially offered by Intel, definitively do not support the TRIM in RAID0 feature for Intel 7-Series Chipset systems.

                  Diego_Intel schrieb:


                  In the other hand, the option ROM is provided directly by your computer manufacturer, not Intel. In such case, if you have issues with the option ROM in your computer you need to contact your computer/motherboard manufacturer directly for assistance.

                  It is not the mainboard manufacturer, but just Intel, which is exclusively responsable for the function of their drivers and OROM modules. The mainboard manufacturers have nothing to do with the development and the release of the AHCI/RAID Drivers and PCI OROM modules, which are needed to get the Intel SATA Controllers properly working.

                  • 6. Re: Intel RST WHQL - Bug

                    Thank you Fernando for weighing in on this.  I have been following your various web posts and your monitoring of this situation, and want to thank you for your advocacy.


                    I can also confirm that TRIM is not functioning as expected under 12.5.  I used the "trimcheck" program to do the verification.  While it could be possible that there is a bug in the program, I find it more likely that there is a bug in the RST driver because trimcheck reports working TRIM under 11.7, which is what I have fallen back on.


                    As an interesting note, under 12.5, the trimcheck program reported that trim WAS working on my non-boot volume.  I have two raid volumes: one for booting to Windows and one for data.  The program reports trim not working on the boot drive (no matter how long I wait to retest it).  I am wondering if for some reason the TRIM is disabled when the volume is marked for boot.


                    I am very disturbed by this, as Intel should be aware of this and should be fixing this ASAP because those of us who have SSDs in RAID (as I do) desperately need trim to work to maintain performance - and there are probably a LOT of us out there who are now doing this (Raid of SSDs).  I upgraded to RST 12.5 because it was available from download center, and, luckily, decided to make sure TRIM was still working and was very very surprised when it was not.  How many unwitting downloaders are now using 12.5 on their SSD RAIDs and not getting the TRIM functionality they expected?  I wonder...


                    To make matters worse the RST install cannot be de-installed when RAID is on your boot drive.  What is up with that!?  The only way to roll back is to use System Restore, and guess what - I didn't have a restore point set up before the RST install so I had to reinstall Windows (6 hours due to all the apps I lost).  I hereby request the following for not only myself but all the unfortunate souls who got screwed by this.  Please use this logic:


                    1) If user has enabled system restore, then please create a restore point as part of RST install.

                    2) If user does not have system restore enabled, then warn them that they might want to abort and turn it on as that is the only way to roll back.


                    Oh, and one more thing...RST 12.5 also interferes with AnyDVD - makes it look like my USB 3.0 DVD player doesn't exist.  Rollback to 11.7 and viola all is well.  There is a post on the AnyDVD forum about this, and the AnyDVD support person pointed to the fact that the RST driver inserts itself into the driver stack for the DVD, even though it probably has no business doing that.  If it does belong there, it is doing something different in 12.5 than 11.7 that breaks AnyDVD, a very popular utility, so this should be addressed.  I don't really care if it's RST or AnyDVD, but Intel and Slysoft should at least be talking to each other about this.


                    I have to say, I am very disappointed with the quality of drivers being posted to download center.  I do NOT have an atypical rig for a power user; atypical, yes, for a consumer, but there are still a LOT of power users out there, and we're not in a good place with regard to RST or, for that matter, Intel HD graphics...but I digress.


                    Could we at least get an RST on download center that properly supports TRIM (within a reasonable timeframe)?






                    I forgot to specify my system specs when I posted.

                    Here they are.


                    AsRock Z77 Pro4M Motherboard

                    Intel ICH8

                    Intel OROM

                    Windows 8 Pro 64 bit


                    2 OCZ Vertex SSDs on Intel SATA3 ports 0-1 (boot raid 0 volume)

                    4 OCZ Agility SSDs on Intel SATA2 ports 2-5 (data raid 0 volume)


                    Nothing is attached to the other 3rd party SATA controller and there are no cards in any of the PCI slots.


                    One USB 3.0 DVD drive is attached.

                    • 7. Re: Intel RST WHQL - Bug

                      Merwinsson schrieb:


                      I forgot to specify my system specs when I posted.

                      Here they are.


                      AsRock Z77 Pro4M Motherboard

                      Intel ICH8.

                      That must be a typo. A Z77 mainboard doesn't have an Intel ICH8 Southbridge.

                      • 8. Re: Intel RST WHQL - Bug

                        Indeed I thought that was strange, yet that is what Sandra reports.  See below.


                        I also looked at my Device Manager, but there is nothing there that indicates ICH level.


                        Then I looked the board up at Newegg, nothing there.


                        Then AsRock, nothing there.



                        • 9. Re: Intel RST WHQL - Bug



                          I agree with you, and 12.5 is not a reliable and stable version and has sufficient basic bugs (such as TRIM bug) for me to not use it.

                          So, I am in "wait and see the next release" mode to get my PC to run basically in "RAID" mode using a pair of SSDs and to have the CD/DVD booting working ... (the minima features of a 'modern' technology).


                          For ICH identification what say HWINFO64 and SIV64X ? for me these 2 tools give lot of details on the chipset used.

                          • 10. Re: Intel RST WHQL - Bug

                            Forgot about HWINFO64.  Good proggy, but it reports the same.


                            Intel 82801HB ICH8 - SATA RAID 0/1/5 Controller [B2]




                            Actually, I'm doing okay with RST 11.7.  It seems to be stable, supports TRIM, doesn't mess up AnyDVD or my DVD in general, and doesn't crash or do bizzare things during online capacity expansion.  I have read some reports of other people having issues with it, but not me.


                            I tried to install 12.5 because I wanted any bug fixes, and liked the new performance tab and the fact that you could change some of the disk write cache policies directly from the RST UI rather than burrowing into Windows Device Manager.  Big mistake though.  I'll take the stability of 11.7 over a few handy UI improvements and MORE bugs.

                            • 11. Re: Intel RST WHQL - Bug

                              Maybe I found another bug with


                              When I power on my PC -> boot to OS -> start SpeedFan then I got BSOD or OS freezes.

                              DRIVER_IRQL_NOT_LESS_OR_EQUAL, STOP 0x000000D1, iaStorA.sys


                              More details you can find here.



                              When I rollback to ( then all is OK.


                              Can someone confirm it?

                              And it will be fixed?

                              • 12. Re: Intel RST WHQL - Bug

                                Merwinsson schrieb:


                                Indeed I thought that was strange, yet that is what Sandra reports.  See below.


                                I suspect, that the tool Sandra has detected your Disk Controller as "ASRock ICH8R (ICH8) SATA RAID Controller", because all Intel Desktop SATA RAID Controllers from ICH8R up (except X79) have exactly the same common HardwareID 2822.