2 Replies Latest reply on Jul 15, 2013 7:20 PM by EQuipped2000

    i7 3770k HD4000 drivers won't install, monitor not recognised, gfx control panel wont load

    EQuipped2000

      I recently removed my 7970 from my work PC.

      I have enabled the HD4000 in the motherobards BIOS.

      Gave it memory allocation (tried all settings from 64Mb - 1GB), set the bios to auto and force igpu modes.

       

      I used ATI and DiverSweeper apps to remove all legacy drivers/software and checked registry keys have been removed too. All OK there.

      I then rebooted, installed intels HD4000 driver Win64_15319.exe ( I also tried the ZIP version just in case )

       

      I have attached 1 monitor, a 27" Dell u2711 (2560x1440) to the Display Port connector on the motherboard. (GIGABYTE Z77X-UD3H).

       

       

      The problem in Windows 7-64 Pro:

      It works fine, as in I can see windows, see my BIOS and use my PC in a basic mode.


      BUT.

       

      I have no intel control panel for the HD4000.
      I have no aero.
      I have very laggy window movement.
      I can't longer see my monitor in settings, it now defaults to "default monitor". It was working fine before. Fully callibrated and custom ICC set up.

      I have no recognised video card installed as far as "desktop display settings" are concerned, but it shows in device manager.

      If I turn off my monitor, thats it, gone **pomf** I have no monitor, it does not resume, same if windows suspends the display or sleeps. (I have had to disable these, but they were set to 4 hours anyway because this screen is colour calibrated and needs to stay on for consistency).

      I get no error messages or issued with installing the driver software, reboot, and back to square one.

       

      So, essentially, I can see the screen working but I have no drivers installed and no hardware support on this system.

      I have tried several versions of intel drives, nothing seems to work.  I can't get the drivers to install and work.

       

      I only purchased this "intel" based board/cpu for this very reason, to not have the gaming card in my work machine.

       

      Now I can't work, trying anything basic on this without the drivers is painful.  My "work" is graphics(2d) based so I need at least some sort of video card support to render photographic works in photoshop/lightroom and other programs.

       

      See screenshots below:

       

      (1) HD400 does not even register as here.

      MonitorProperties.png

      (2) Monitor now shows as default, it was always working perfectly fine before.

      cpanel.png

      (3) HD4000 shows in device manager OK

      devman.png

       

      If you have any suggestions?
      Is there anything this installation relies on that may be causing the issue? (as far as I can tell all my .net and other stuff is all up to date).

       

      I'm at the point where I want to put my foot through the screen.

        • 1. Re: i7 3770k HD4000 drivers won't install, monitor not recognised, gfx control panel wont load
          Diego_Intel

          It seems that the operating system is not loading the driver even though it has been already installed.

           

          Have you tried updating the system BIOS on that system?

          Have you tried with the video drivers provided directly by Gigabyte?

          http://www.gigabyte.com/products/product-page.aspx?pid=4153#dl

          Have you tested manually launching the video driver services? For this just double click on igfxpers, igfxtray and igfxsrvc

          Additionally you can try an operating system repair or restore.

          Further than this, you may need to test a fresh operating system installation, possibly using another hard drive or partition, just to check that this is not a hardware related issue.

          • 2. Re: i7 3770k HD4000 drivers won't install, monitor not recognised, gfx control panel wont load
            EQuipped2000

            BIOS was irrelevant as it had been working in the past with no issue, but it is the latest version.

             

            The board is generic, you should know that its your chipset. Gigabyte driver is an intel driver,  just the one they packaged at release, it is 9 months old.  It tried 4 versions including that one.

             

            Manually launching does nothing.

             

            I have now resolved this, I did a system "upgrade repair" rather than a normal repair.  This creates a new windows installation and copies all files and programs across whilst fixing any system file issues.  This also gives you the option of rolling back to your prior installation.

             

            I was putting off doing this in the hope some bright spark would have an idea I had missed. While I have no idea about intels software, microsoft is something (Ex I.T. Pro) I know a lot about.

             

            Fortunately I didn't get any major problems fixing the OS, which I think was the core problem here, something was seriously borked when I removed the 7970 and installed the intel drivers again.  Not blaming you intel, it is most likely .NET or something else Microsoft related (Borked registry settings even)...

             

            If you have OS issues like this in Win7 it is always an option to do what I did when repair fails to fix, rather than reinstalling.

             

            Just run your Setup disk or mount the ISO *in windows not at boot* and run setup, and run the process as an *upgrade* which is the alt way of creating a fresh installation and repairing together with F.A.S.T.