5 Replies Latest reply on Jun 29, 2013 11:04 AM by YH_Chung

    RST: After Toshiba replaced HDD, the Accelerate "break" and now option not available

    YH_Chung

      Hi everyone,

       

      I hope to get this resolved quicker.. I've wrote to Toshiba, but I believe they will ask me to send it down to their service center again.

      After I got back my U840W recently after Toshiba replaced the failing hard disk, I noticed the system is slow and found that the RST isn't caching the new hard disk. (sadly I found this after I got home, not while I'm at the service center. Toshiba Singapore don't provide onsite notebook service, like Dell in Singapore). I believe Toshiba replaced the hard disk and set it back (the hard disk) to default factory, but forgot to configure the RST back.

       

      Spec; Toshiba U840W, i5 3317U, 10GB RAM, 500GB HDD, 32 SDD RST cache, Windows 7 Home Premium.

      With Windows 8 Pro upgrade DVD from Toshiba (which I spend time upgrading to before the issue appear..  and I've to do this again, after I settle this issue)  Intel Rapid Storage Technology version 12.5.0.1066 (should be the latest)

       

      I tried to re-enable it back, but there is only one option.. Sorry, I can't recall. After I enable it, the accelerate button is not longer available.

      I might have made it worse.

       

      From the Windows' disk management now, 2 partitions on the SSD; 11.2GB for the hibernation and another 18.6GB unallocated.

       

      RST.pngRST1.png

      The only option is Mark as spare

       

      RST2.png

      RST3.png

      Option is to enable rebuild..

       

      I 'googled', but don't since to find article matching this scenario.

       

      Thanks for reading..  and suggestion, pointer..

        • 1. Re: RST: After Toshiba replaced HDD, the Accelerate "break" and now option not available
          parsec

          If Toshiba replaced the HDD, did they install Windows 7 again? If the HDD was failing, were they able to use a back up image?

           

          Regardless, looking at your IRST UI screen shots, are you sure your SATA mode is set to RAID? Usually when in RAID mode, the IRST UI will have a Create button between Status and Manage. That might not be the case with just the two disks you have now, but you should check that Toshiba did not reset the SATA mode to AHCI in the BIOS when they replaced the HDD. The SATA mode must be set to RAID in order to use acceleration. If Windows was installed with the SATA mode set to AHCI, you cannot simply change it to RAID. If you do, the PC won't boot or will BSOD when it starts.

           

          Some other things that may keep you from accelerating your HDD:

           

          The SSD used for caching must not have any partitions on it when you configure the accelerated system. You've already created two partitions on the SSD, which would not allow it to be used as a caching drive.

           

          Is there a Recovery volume on the HDD? If so, acceleration is not possible.

           

          Acceleration is not possible if the storage system has more than four volumes. Since you now have two on the SSD and if the HDD has two or more, you can't accelerate that system.

           

          On the IRST UI screen, have you ever clicked on the Help button? If not, that will open a new window with detailed instructions for accelerating the storage system, and other instructions about managing RAID volumes.

          • 2. Re: RST: After Toshiba replaced HDD, the Accelerate "break" and now option not available
            YH_Chung

            Thanks parsec for your reply.

             

            FYI Toshiba did called me back on Yesterday, but I busy and request they just send the instructions over.

            As for you questions;

            1. Toshiba replaced the hard disk and it boot to the same Windows 7 OS which I got it new. As I just got it and upgraded it to Windows 8 pro from the DVD provided by Toshiba, there isn't much data backup or restoration I request.

            2. I never change the BIOS setting and no idea did service centre change it. When I upgrade to Windows 8 using Toshiba Windows 8 upgrade assistance, I also used Toshiba update tool to upgrade the BIOS.

            3. I just check the BIOS again, there isn't a setting for AHCI or RAID.. I recall I did notice control-i option to got into Rapid storage feature, but it is not available anymore.

            4. I did not configure the RST or create any partition, the SSD cache and the creation of the 11.2GB SSD partition for hibernation is what all default setup by Toshiba.

             

            I believe I need to send it back to Toshiba again. If I screw thing up.. the warranty might be voided.. B(

             

            Thanks!

            Regards.

            • 3. Re: RST: After Toshiba replaced HDD, the Accelerate "break" and now option not available
              YH_Chung

              Hi, I just go back from Toshiba service center and they reconfigured the cache back.

               

              These are the overview of what he did;

              1. using diskpart to remove ssd

              2. reinstall the RST software.. but now it is version 11.1.0.1006 (not the newer version, when I got the notebook back from servicing)

              3.using diskpart to create a partition for the volume cache

              4. then using diskpart again create a partition for Hibernation, then using the command "set id=84 override" to make it into a hibernation partition. Google this and found this is also recorded in the Intel RST user guide.pdf, page2.

               

              Below are the screenshots..

              Look OK here, like before.. only the volume names were changed (compared when I first got it new)

               

              New setting1.png

               

              This is the Hibernation partition

               

               

               

              This is the partition for disk cache.New setting2.png

              New setting3.png

               

              Now this is the part which I don't understand.. Accelerated device is = none. ???

              The service man said, this is normal and correct..

              New setting5.png

               

              I believe other also reported this..

              Guess I will upgrade to Win8 again, backup and update all the software.. then check again.

               

              Regards.

              • 4. Re: RST: After Toshiba replaced HDD, the Accelerate "break" and now option not available

                Hello YH_Chung,


                As a piece of advice, I would recommend you doing a low level format on the SSD using the Intel® Tool box or any other 3rd party software. We have seen cases where doing this step the acceleration tab is restored.

                 

                Also, I recommend you contacting the system manufacturer first before doing this steps so you can confirm with them if by doing this, the warranty will not be voided.

                • 5. Re: RST: After Toshiba replaced HDD, the Accelerate "break" and now option not available
                  YH_Chung

                  Thanks Kevin,

                   

                  I would like very much not to resolve it myself as I've no experience with iRST and concern the warranty will be voided.

                  The problem is, Toshiba engineer said this is normal after I said this don't look right. How to proof what he said is wrong and Toshiba need to resolve it?   I have wrote to them (local Toshiba support), but there is no reply yet.

                   

                  Now I can't proceed to upgrade to Win8 Pro (DVD provided by Toshiba).. they can deem, my action cause this issue..

                   

                  Regards.