6 Replies Latest reply on Jun 4, 2009 8:51 PM by August717

    DG45ID BIOS - Updating from 0079 (bricked my motherboard)

    August717

      I have been using my DG45ID for a few months now with no problems.  I recently attempted to upgrade the BIOS from 0079 to the most recent BIOS upgrade.  The power went out (at just the wrong moment) and interrupted the BIOS installation.  Restarting the computer, there was no response from the mother board.  There are power lights and the fans spin, but no beeps and no video display.

       

      I have attempted to use the recovery method using a CD-ROM, as the .BIO is too large for a floppy disc.  Unfortunately, I still get no response from the motherboard.  I have disconnected everything except the processor, memory, and CD-ROM drive.  I have an Intel Core 2 Duo E8400 processor, 4x Crucial 2 GB DDR2 800 RAM, LG Blu-Ray / HD-DVD GGC-H20L Drive, and an Antec ATX12V v2.2 500W Power Supply.  As I said before, this system worked before the attempted BIOS update.

       

      I followed the instructions (listed below) for recovery with a CD-ROM, and copied the .BIO file to a CD.  When I power the system back on (step 6), rather then go through a normal BIOS recovery, the screen stays black (as far as I can tell, there is no signal output).  When it is sitting here, the drive does spin up and stay spinning for the duration that it is on.  I have let it sit on this screen for an hour to make sure it wasn't attempting a BIOS recovery without video, and on reboot there is no change.  I have also attempted to remove the battery for 24 hours.  I reinstalled the battery, powered the system on, and attempted the recovery again without success.

       

      I have never had a problem like this before on an Intel board.   Can anyone recommend something for me to try?  Maybe a more detailed step-by-step on how to use the recovery .BIO?  Maybe I am doing something wrong, and I just don't know it.

       

       

       

      Recovery with CD-ROM

      Use this method if the recovery file (*.BIO) is too large to fit on a floppy disk or if the desktop

      board does not include floppy drive support.

      *Other names and brands may be claimed as the property of others.

      1. Copy the recovery file (*.bio) to a CD.

      2. Place the CD in the CD-ROM drive of the target system.

      3. Shut down the system and unplug AC power.

      4. Open the chassis and remove the BIOS Configuration Jumper. See the Technical

      Product Specification for details including the location of this jumper.

      5. Power the system on.

      6. Wait 2-5 minutes for the update to complete.

      7. System will either turn off when the recovery process is completed or it will prompt you to

      turn off the system.

      8. Replace the BIOS Configuration Jumper.

      9. Restart system.

        • 1. Re: DG45ID BIOS - Updating from 0079 (bricked my motherboard)
          alexshim

          The latest BIOS version for the DG45ID is 0101. I use a USB key to flash the BIOS as Intel Motherboards now permit updates within the software itself by pressing "F7" at the Intel Splash screen. This method doesn't require any boot files such as DOS or a bootable CD.

           

          I've never tried the recovery method so I can't help you there.

          1 of 1 people found this helpful
          • 2. Re: DG45ID BIOS - Updating from 0079 (bricked my motherboard)
            unplugged_24

            Hi August717,

             

            Actually if you have followed the steps of how to do the BIOS recovery and have done it as told, I dont think it has not worked. May be the bios itself is corrupted and can't even read or do a bios update now.

             

            Bios recovery is simple. If it has not worked by using the cd, you could also try doing it using a usb stick.

            But before you proceed, can you do a basic test, can you check if you get 3 beeps if you have the system with only the cpu and fan and the power supply (nothing else).

            Remove the battery and put it back after about half an hour then start the system.

            If you get 3 beeps, then add 1 module of memory only, monitor and keyboard.

            Separately, download the .bio file from the following link: http://downloadcenter.intel.com/license_agr.aspx?url=/17428/eng/ID0091.BIO&ProductID=2931&agr=Y&sType=&PrdMap=&DwnldId=17428&strOSs=38&OSFullName=OS%20Independent&lang=eng

            Put the file on an EMPTY usb stick (non-bootable). Note: the .bio file should be the only file on the disk.

            Remove the bios configuration jumper completely.

            Insert the usb stick in any one usb port and start the system.

            The bios flash will start and you would be able to see the activity light from the usb blinking while it is reading.

            It may take some time...at a later stage if the activity light has stopped blinking, you may shut down the system.

            Put the jumper back in the normal position and start the system.

            If it worked you should get back the video and system should be working fine.

             

            If still it does not work, then can you do the same procedure but with the bio file downloaded from this link: http://downloadcenter.intel.com/license_agr.aspx?url=/17610/eng/ID0097.BIO&ProductID=2931&agr=Y&sType=&PrdMap=&DwnldId=17610&strOSs=38&OSFullName=OS%20Independent&lang=eng

             

            Also try with different usb stick if you have spare ones.

             

            If all of the above have not work, then I don't know what else to advise you than to replace the motherboard from the place where you have bought it.

             

            Cheers

            • 3. Re: DG45ID BIOS - Updating from 0079 (bricked my motherboard)
              August717

              I followed the instructions to recover BIOS using a USB drive, and it kind of worked.  I have run into a LOT of problems, so I will list each one individually, and hopefully someone can explain to me what steps I can take to avoid this in the future, and hopefully to fix my current problems.

              One thing I forgot to mention (and from my readings elsewhere might be significant) is that I am building a RAID 1 array wih two 500 GB hard drives.  I have set the BIOS appropriately for RAID configuration and not IDE.

               

              • I found that if I am using an HDMI connection, the motherboard will not load the BIOS.  I switched monitors to one that uses DVI, and suddenly the recovery BIOS started working.  I loaded 0091, and restarted the computer.  If I leave the DVI in, I see the BIOS screen, followed by the RAID management screen, then the BIOS screen again during start up.  If I use an HDMI cable (which wil lock up the computer if I try to use it during BIOS recovery), I will not see a BIOS screen, and the computer will freeze after the RAID managment screen loads.  I cannot use the HDMI, either onboard, or with a video card.  The computer will lock up upon reboot.  If I connect it while the computer is on, windows does not recognize it.  It has worked before, and as I said will display some things on booting, but freeze the computer.
              • Once the BIOS was loaded, it gave me a Boot Failure.  I set the order of the boot devices to CD-ROM then Hard Drive then the rest and it still failed even with a bootable CD.  If I hit F10 to choose the Boot Menu, I can manually choose CD-ROM or the Hard Drive.  It would then load up.  If I go to the BIOS and disable the 'Generic' devices for boot up (forgive me as I am doing this from memory so that is not the exact name) then the computer will boot fine.
              • Once I was able to load Vista 32-bit and set the BIOS appropriately (the only two changes I made was to set RAID configuration and disable Generic Boot devices), Windows now takes a considerable amount of time to boot.  When I had 0079 running, it took less then a quarter of the time it takes now.  Not only this, but the drives (set in a RAID 1) took a long time to initialize (it took until this morning for them to finish, over 8 hours!).  I have not seen if windows will boot faster now that the drives have initialized.
              • I attempted to update the BIOS to 0101 using the express BIOS (.EXE).  Both times I attempted this, it failed.  The drives were still initializing, so maybe that had something to do with it.  As the drives just finished this morning, I will not be able to check it until later.  I have only attempted the Express BIOS, nothing else as of yet.

               

              Currently my problms are the lack of HDMI, slow boot time, and inability to upgrade my BIOS.  Any ideas or further help?  I will post again tonight when I have had some time to try things out.

              • 4. Re: DG45ID BIOS - Updating from 0079 (bricked my motherboard)
                alexshim

                I don't use the express BIOS method for Windows because it never worked for me to begin with. Just download the raw ID0101.BIO file from the download page into the USB drive, make sure a monitor is connected to DVI, reboot, press "F7" at the Intel splash screen, a menu appears to select the USB Drive, select the .BIO to flash and the m/b is off flashing the BIOS.

                 

                You don't even need a hard drive or a boot CD/floppy connected to the DG45ID to flash the BIOS.

                 

                Will try Raid 5 once I get 3 identical drives attached.

                • 5. Re: DG45ID BIOS - Updating from 0079 (bricked my motherboard)
                  August717

                  After reading Alex's suggestion, I attempted an "F7" BIOS install.  Unfortunately, it doesn't work.  I have no screen, or ability to enter any BIOS screen on an F7 press.  I did try spamming the button to see if it would work anyways, but it did not.

                   

                  I then attempted to update the BIOS to 0101 using the recovery mode, seeing that the Express mode fails.  Again things went horribly wrong.  I followed the step I took before to do a recovery using USB.  I pulled the battery for 30 minutes, followed the normals steps, and then nothing worked.  I got no beeps at start up regardless of what hardware I had.  I had removed everything but the power, then power and memory, and nothing.  So I walked away for an hour, came back and tried it again.  With NO changes, it started to work again.  Now when I start the computer, it takes me immediately to the BIOS screen.

                   

                  Now it automatically boots into the BIOS, and upon exiting, I have the message asking me to install the jumper and restart the computer.  Now, obviously it seems like the jumper is just in the wrong spot or not in place.  It is not.  I have tried multiple jumpers, and I still get this message.  I have never pulled the jumper while there was ANY power to the motherboard.  I always make sure that it is all dissapated before pulling or reinserting the jumper.  Any suggestions on this problem?  Any ideas as to why this board is giving me so many fits?  Any ideas why I cannot upgrade my BIOS without major issues?  (It is now running 0091)

                   

                  On a side note:

                  I purchase hundreds of Intel boards a year building custom computers, and up to this point, I have never had this many issues (save an MSI board we tried once to 'save' a few dollars.  Since then my boss has let me buy whatever I see fit).  I have worked primarily with the 965WH series and earlier without a problem.  RAID, BIOS, and production harsh enviornments have never given me this many headaches.  I am hoping these problems are not indicitive of the quality of the new Intel boards, or I will have to start reconsidering what I buy.  It definately will NOT be another DG45ID.

                  • 6. Re: DG45ID BIOS - Updating from 0079 (bricked my motherboard)
                    August717

                    As this question has been answered, and I have new questions, I am marking the appropiate posts as 'answers'.

                     

                    Using the USB stick did successfully recovery my BIOS from an unusable state.  I upgraded from 0079 to 0091.  BIOS 0079 does not have the ability to use the 'F7' method of BIOS recovery, though.  I used the recovery .BIO on an empty USB stick.  I also found that my biggest problem was the jumper.  The jumper was bad, and needed to be replaced.

                     

                    (Also, the technical documentation I had was old, and the errata from March 2009 corrected the jumper position on the motherboard.)

                     

                    Thank you!