1 Reply Latest reply on May 28, 2013 1:48 PM by Freddy Gonzalez

    Intel 520 SSD poor performance on 2010 MacBook Pro 13"

    danielpo123

      Hi,

       

      I recently bought an Intel 520 SSD, 480GB,

      and installed it easily on a 2010 MacBook Pro 13".

       

      Unfortunately the drive doesn't reach it's designated speed – it is performing on a only at SATA1 speed, instead of SATA2 that this Macbook supports.

      At the moment it says link speed is 3GBit/sec but Negotiation speed is only 1.5GBit/sec (this MacBook has a MCP89 SATA controller).

       

      I tried resetting the SMC on the Mac but it didn't solve the problem.

      in addition, EFI and SMC are updated to the latest revision on this macbook model.

       

      is there a solution to this??

      Isn't the SSD drive compatible with the mac? Doesn't it have backward compatibility to SATA2 speed?

       

      PLEASE HELP!

      Thanks,

      Daniel.

        • 1. Re: Intel 520 SSD poor performance on 2010 MacBook Pro 13"
          Freddy Gonzalez

          Hello danielpo123,

           

          Based on the SSD specifications we can confirm that is capable to work in either a SATA 2 or SATA 3 interface due to the fact that is backwards compatible.

           

          Now, the issues being reported seems to be a compatibility issues between the SATA controllers integrated in your MacBook Pro not letting the SSD to run as if it were a SATA 2 device.

           

          Our recommendation is contact Apple* to see if there is a firmware update for your unit and check if the issue is resolved. Also, we would encourage you to have this SSD tested into another unit that fully supports SATA2 or SATA3 devices to check the SSD functionality.

           

          Regards,