3 Replies Latest reply on May 24, 2009 2:53 PM by Aryan2411

    DG45ID MB won't turn on?

      I purchased the mother board about six months ago and has been working fine with Linux installed. Wife got tired of trying to use Linux and wanted Windows back (oh well) wont ever use Vista (piece of *!@#) so I tried to install Windows XP. XP blue screens while trying to install the drivers after the initial reboot, so I thought I would set all of the bois settings from automatic to manual thinking maybe XP had a problem with automatic. Now it just turns on then off and doesn't even get to the BIOS screen any more. I've replaced the power supply thinking (man I wish I'd stop thinking) may just a freak of timing that the power supply went at the same time (not to be). Did a Bios recovery which should have set everything back to default still nothing. I can't believe I just  screwed up my mother board please somebody help!

        • 1. Re: DG45ID MB won't turn on?
          Aryan2411

          Hi there,

           

             Assuming that you are using all compatible hardware from the tested list on the support page of the board.

             http://support.intel.com/support/motherboards/desktop/dg45id/

           

          1. Remove the memory
              Does the board issue any beeps? If yes, how many?

           

          2. Try the system with minimum configuration

              Do a CMOS clear

              Only mainboard + PSU + CPU + 1 memory module connected.

              Switch the bios jumper to Maintenance/Configuration Mode.

              Switch on the system

              If it works fine, try to recover the BIOS using the BIOS Recovery Method

           

          Note: these can be found on:
          Website: http://downloadmirror.intel.com/17197/eng/BIOS%20Update%20Readme.pdf
          Page 3

           

          If nothing goes positive with the above test, may be it is time to place an RMA for the board.

           

          All the best,

           

          Regards,

          Aryan

          • 2. Re: DG45ID MB won't turn on?

            Thanks Aryan2411 for responding. Yes I have pulled the memory and I do get 3 beeps. Would this be an indication that maybe I have fried my memory, because this PC has been working for about 6 months now. Which now that I'm looking at is two Crucial Ballistix 1GB 800MHz 4-4-4-12.2.0v and I don't see these on the hardware compatibility list. Which that's what I get for letting the store tech suggest my memory and not researching it my self. I have tried to reset my CMOS settings back to default by the procedure suggested and leaving the cmos battery out for an hour but can never get back to the bios screen.

             

            Should I get a stick of compatible memory to see if this works?

            • 3. Re: DG45ID MB won't turn on?
              Aryan2411

              Hi Retrograde,

               

              If you are getting 3 beeps, this indicates that either the cpu or the board is fine. I dont think that it is worth of getting another compatible memory, as if it used to work fine for six months, i think that it is okay.

               

              As long as the memory is operating as per the requirement below:

              http://support.intel.com/support/motherboards/desktop/dg45id/sb/CS-029147.htm

              It should be alright in theory.

               

              Did you check if the CPU is on the compatible list:

              http://processormatch.intel.com/CompDB/SearchResult.aspx?Boardname=DG45ID

              Make sure to check if the SL number of the CPU (found on the CPU metal) is on the list.

               

              Did you try to switch the bios jumper on the maintenance mode? What was the result?

               

              I will advise you to do this steps again.

              Do a CMOS clear

              Remove the CPU and re-integrate it again

               

              If all this fails, possibly the board or the cpu became faulty.

               

              I think it is best to cross test your system hardware with other compatible hardware rather than buying some other hardware.

              Note: the recommended power supply is at least an ATX Version 2.2

               

              All the best,

               

              Regards,

              Aryan