2 Replies Latest reply on Jul 14, 2011 1:04 PM by ykirill

    Boot from compact flash on DG31

    ykirill

      Good Day

      I bought several DG31PR(B) motherboards to run a program from a flash drive. BIOS is updated to PRG3110H.86A.0065.2009.0421.1559 version.

      I can't start os from a bootable compact flash card using cf to ide adapter. BIOS is able to see this disk as Transcend 4Gb (i tried two type 133x and 266x). To make it visible in BIOS i used the following settings in Drive Configuration

      - Use Automatic Mode - Disable

      - Use Serial ATA - Disable

      - ATA/IDE Mode - Native

      - SMART - Disable

      - Hard Disk Pre-Delay - 0 (i tried 5 and 10 also)

      At boot time after some timeout BIOS says no disks found. I checked both adapter and compact flash card on another motherboard and everything is working. Not long time ago i tried the same on Intel Atom ITX motherboard and managed to run OS from compact flash after BIOS update to the most recent version. I suspect this motherboard can't start disk in PIO mode but trying to use UDMA which fails in my case.

       

      I tried two types of cf to ide adapters. One with udma support and one without. When i tried to use udma capable adapter system hangs. I'm not sure my cf cards support udma.

       

      I appreciate any thoughts or ideas on this subject

       

      Thank You and Best Regards

        • 1. Re: Boot from compact flash on DG31
          jonhd

          Ykirill,

               appreciate this was a long time ago, but you may be interested to read my post on a similar subject (booting from CF)... http://communities.intel.com/message/88409#88409

               I was lucky to have tried a non-UDMA CF card first...

          • 2. Re: Boot from compact flash on DG31
            ykirill

            jonhd,

             

            Thanx for your post! Actually i forgot to post here that i managed to boot, and this project was a success, and it is closed already. Several dozen of small www servers running from CF. I slightly reroute CF adapter so it became dma enabled. This is the only way this motherboard bios can find ata disk.

             

            For bootloader i disabled packet mode and i disabled update mode

             

            setdrv,nopacket,noupdate

             

            And then for the OS itself i switched to PIO back.

            Fow OS (FreeBSD) i setup in /boot/loader.conf

            hw.ata.wc="0"
            hw.ata.atapi_dma="0"
            hw.ata.ata_dma_check_80pin="0"
            hw.ata.ata_dma="0"