4 Replies Latest reply on Apr 14, 2013 5:17 PM by flybelowtheradar

    Data Mismatch on different SSD's

    Charles Taylor

      I purchased an Intel 330SSD 240GB for my Gigabyte GA-Z77X-UD4h motherboard.  I also installed 16 GB of Ballistix DDR3 1600 RAM.  When I started getting errors, I ran a diagnostic scan on the SSD Toolbox and it reported "Data Mismatch Detected" in my SSD.  After trying to troubleshoot the problem, I discovered that everything runs fine as long as I install no more than 8 GB of RAM.  It doesn't matter which RAM sticks I use or in which slot I install them.  If I install more than 8 GB of RAM, I start getting errors and a "Data Mismatch" result on the diagnostic test.  I ran a memory test for eight hours on all 16 GB of RAM while installed in the Gigabyte motherboard and it reported no errors in the RAM.  At Gigabyte's suggestion, I upgraded the BIOS on my motherboard, but that didn't help.  Finally, assuming that I had a bad SSD, I purchased and installed another new Intel SSD, but the result was the same.  With 8 GB of RAM installed, everything works fine, but when I go to more RAM, both SSD's start having problems and give me a "Data Mismatch."  Any suggestions?  Thanks.

        • 1. Re: Data Mismatch on different SSD's
          flybelowtheradar

          Then Gigabyte told you to post here?  Dunno, really sounds like a hardware error related to the board.  Switch, jumper, setting.  You sure the memory sticks are identical?  Does the memory have to be installed in any order?

           

          If everything runs fine with 16 GB in, maybe you should try uninstalling the toolbox.   You've run the system file checker and check disk, with nothing unusual found with 16 GB, right?

           

          Set BIOS to defaults, save that, reboot.  You've done that, right, and then made whatever tweaks you run?  Really sounds like a setting.  I dunno, just shoving ideas at you.

          • 2. Re: Data Mismatch on different SSD's
            flybelowtheradar

            I forgot to mention that you might have to should reset registry starts start-ups for the drivers back to zero when reverting to defaults on the board so that the right drivers get loaded in Windows.  In particular, msahci, and whatever RAID controller driver you have.

             

            However, after a briefly looking around the Internet, seems like a your error does suggest bad drives.  Funny that would clear up with reducing RAM.  Per other related items I've seen, contact Intel support.

             

            I'm quoting MBV2000@intel.com here:

             

            "You can contact the Intel(R) technical support to replace the unit at the following phone number 916 377 7000, option 7, please provide the ISN and SA from the Solid State Drive. if you have less than 30 days with the Solid State Drive please contact the place of purchase first since it will be faster to replace the unit with them."

             

            Here's the thread:

            http://communities.intel.com/thread/37313

            • 3. Re: Data Mismatch on different SSD's
              Charles Taylor

              Thanks for the help, but I was able to resolve the issue.  Even though I have a 750 watt power supply, I decided that, since everything worked with 8 GB, but not with 16 GB, then it must be a power problem.  I went into the BIOS and changed the voltage going to my RAM from 1.35 volts (which is normal voltage) to 1.5 volts, and now everything works great.  I can use my full 16 GB without any errors occurring on the SSD.  I'm not sure why this was a problem in the first place since Gigabyte claimed the motherboard could support 32 GB of memory, but, apparently, 16 GB was dragging it down and it needed a boost of voltage in order to perform as advertised.

               

              Charles

              • 4. Re: Data Mismatch on different SSD's
                flybelowtheradar

                Cool.  So it was a setting.  A memory setting.  I bought some OCZ memory for my current machine.  I wasn't reading and had to post to them.  Came to find out my memory *needs* to run at 2.20 volts or OCZ wouldn't guarantee the sticks.  Funny how one learns about stuff.

                At any rate, congratulations ; )