4 Replies Latest reply: Jun 1, 2009 1:41 AM by frr RSS

bios upgrade problem with dg35ec

dragonken Community Member
Currently Being Moderated

My board come with bios 0072 and upgrade to 0113 at the first day of setup. I remember that after upgrade to 0113, all bios settings was cleared.

 

I have sata problem with CentOS and google from net found that many ppls has sata problem with this board. Someone said rollback to bios 107 can solve the problem.

http://www.webhostingtalk.com/showthread.php?t=859621

 

So I downgrade bios to 0107. This time, bios settings didn't cleared!!! Why? and this downgrade didn't solve my sata problem.

 

I got no luck that the problem didn't be solved and sometime the board can't boot up but sometime can. If I turn off the machine by power button(long press the button till power off), the board cannot be boot up in the next power up (board +5v LED is on but monitor got no signal with orange light). At this moment, if power off it and power on again. The board can boot up successfully.

 

I am not comfortable with the behaviour above, so I try to use BIOS Recovery method. I remove the bios configuration jumper and connect a usb floppy but the board can't boot up, onboard +5v led is ON and green in color but no signal and nothing can see in monitor.

 

Please advise.

 

My config:

 

Q9550S

DG35EC

ADATA DDR2 800

WD 640G harddisk x 2

 

Please help.

  • 1. Re: bios upgrade problem with dg35ec
    isit Community Member
    Currently Being Moderated

    Hi Dragonken,

     

    I would try the following -

    clear cmos (remove battery for 15 mins)

    try bios upgrade using the recovery method with just the .bio file on a usb pendrive, remove jumper, put pendrive in usb on the backpanel and power on system. If you don't have a pen drive then burn the .bio file on to a cd, check boot order and try the recovery same way (clear cmos, remove jumper, etc)

    This board only has limited linux support so as far as centos goes - not sure

    As far as boot up issue - check chassis power connectors and power supply needs to be atx 2.2 minimum

    try different chassis / psu if possible as a test.

    It is usual that if the bios is flashed(updated) it will be at default settings as it is a new bios

     

    good luck

     

    isit

  • 2. Re: bios upgrade problem with dg35ec
    frr Community Member
    Currently Being Moderated

    Most Intel ICH's support two or three modes on the integrated SATA channels, typically some of:

    legacy IDE emulation, native SATA, AHCI and RAID.

    Legacy IDE emulation used to be slow and CPU-hungry (including ICH7 and ICH9),

    but e.g. on ICH8 it's as fast as real IDE and the CPU hungriness is not all that bad.

    You can get less CPU load spent in interrupts if you can switch to AHCI, but the difference

    with IDE is not very significant (say 3% on IDE vs. 0% on AHCI).

    But, legacy IDE emulation is 100% compatible with all Linux distroes

    and all Windows without an F6 floppy.

    Native SATA is generally faster and more efficient than the IDE emulation

    (if native SATA is available at all for selection in the BIOS setup).

    AHCI is good and flexible, but driver is only available in recent

    versions of Linux (kernels and distroes) and cannot be used to

    boot XP I guess...

    RAID is a bad choice for Linux. Use Linux native software RAID instead.

     

    For compatibility with various distroes, try several options. The descriptions in the BIOS

    tend to be confusing or missing at all... Usually you should choose "enhanced mode"

    (all disk ports visible individually) rather than "combined mode"

    (some disk ports masking each other) and then the desired mode for the SATA ports.

    I don't recall ever having a problem with an Intel ICH integrated SATA HBA,

    on any chipset, except for the driver missing in some older Linux distroes.

    With a modern distro, you'll need the ata_piix.ko (newly a part of libata

    and serving both PATA and SATA modes) or ahci.ko driver.

     

    RedHat (including Fedora, Centos) has always been at the forefront

    of driver compatibility and stability... I don't see a problem here :-)

  • 3. Re: bios upgrade problem with dg35ec
    dragonken Community Member
    Currently Being Moderated

    I follow your step and tried many many time, I still cannot update bios by using the recovery method. The machine cannot be booted up. No signal at monitor -_-!

     

    I believe my board is not stable as sometime the board cannot boot up, sometime I have to unplug and plug the power cable to make it boot.

     

    I tried replace with other PSU, chasis, RAM, Heat Sink but it's not work either

     

    other findings:

    i can use iflash to upgrade bios, when I upgrade from 107 to 113, the bios setting will be reset. but if I downgard from 113 to 107 or upgrade from 106 to 107. The bios settings didn't reset.

  • 4. Re: bios upgrade problem with dg35ec
    frr Community Member
    Currently Being Moderated

    I myself used to swear on Intel mobos as the reference implementation of a PC motherboard - as bulletproof as it gets. That was until we sold some number of the DG35EC. While dealing the the DG35EC, I've already noticed that

    1) intel does have bugs/glitches/pitfalls in its BIOS and the accompanying tools (iflash, itoolkit et al) and relevant tech support is hard to get

    2) the board does hang in the way you describe specifically around BIOS flashing occasions. It doesn't matter as long as it can boot in normal production deployment.

    3) if you add some custom changes of DMI data to the mix, it's hard to tell what the BIOS can stumble over at boot, especially after some version changes to the main executable BIOS image (.BIO)

    4) the recovery method using a SATA CD-ROM drive has always worked for me so far,

       but then again I haven't tried as many different versions as you have

    5) the available documentation refers rather mystically to the flash chip partitioning in place. You don't seem to have a chance to flash the whole image en bloc 1:1. The Phoenix BIOS with Intel mods alone is highly mystical. Makes you long for the good old Award 6 series.

    6) As far as CMOS resets go, your best bet is to remove the backup battery from its seat, wait a while and plug it back. The software-invoked CMOS resets are not reliable, at least not with Intel, as you have already found out :-)

     

    Overall, fiddling with BIOS upgrades, CMOS NVRAM resets and especially combined with Itoolkit mods can be a nasty can of worms.

More Like This

  • Retrieving data ...