6 Replies Latest reply on Jun 14, 2013 7:57 AM by kevin_intel

    WDM.exe crashes during and after updating Intel Graphics HD 4000 drivers (to Version 9.18.10.3071)

    jesss

      Well...i found a curious behaviour when i update my Intel graphics 4000 on my notebook. I'll list my setup:

      - Manufacturer: ASUS N46VM (R401V for Latin America)

      - CPU: Intel Core i5 3210m

      - GPU: Intel HD 4000 + nvidia GT3630m (Intel as main GPU)

      - RAM: 8GB

      - Wireless: (Intel® Centrino® Wireless-N 2230)

      -OS: Windows 7 x64

      -Drivers version: Intel HD 4000 15.28.12.64.2932(9.17.10.2932) [Before installing new troublesome driver] + Nvidia 314.22 (Current)

       

      Well...the thing is that today i decided to take a look for updates for my Intel components via Intel Driver Update Utility. I found Updates for the GPU (Version 9.18.10.3071) and Wireless networking , i downloaded them and proceed to update. Wireless Connections installation were successful. Then i proceed to install the Intel HD drivers. Everything goes apparently normal but before finishing, the screen goes black for a while, then cursor appears and everything goess back normally, except the Aero functionality...it has gone and an error window appears, saying the following:


      DWM part 1.png

      Translation: Desktop Window Manager stopped working...Windows is searching a solution for the problem.


      and This:

      dwm part 2.png

      Translation: Desktop Window Manager stopped working and closed.

      A problem caused the application stopped working. Windows will notify you if a solution is available.


      I thought that was normal...so i decided to restart my computer...well...it started slower, took some time to appear the desktop and the problem appeared, popping up the second window error.


      I was curious, i went to the Event viewer and i find some error logs related to DWM.exe...this is the latest report (copied from "details" tab and "descriptive" format, since "general" tab shows everything in localized language...in my case, Spanish)


      -System

       

      -Provider
      [ Name]Application Error

       

      -EventID1000

       

      [ Qualifiers]0
      Level2
      Task100
      Keywords0x80000000000000
      -TimeCreated

       

      [ SystemTime]2013-04-08T03:55:33.000000000Z
      EventRecordID6949
      ChannelApplication
      ComputerJesssNote-PC
      Security
      -EventData

       

      Dwm.exe
      6.1.7600.16385
      4a5bc541
      unknown
      0.0.0.0
      00000000
      c0000005
      0000000000000000
      ec4
      01ce340ceb26b83e
      C:\Windows\system32\Dwm.exe
      unknown
      290a6926-a000-11e2-8f5e-9b3a6b71ce80

       


      - Notes:

      - The previous driver i was using was the version [15.28.12.64.2932(9.17.10.2932)].

      - Tried to manually stop and restart the Desktop Window Manager service from "Services.msc"...FAILED...error appears, no Aero.

      - Restored the system to a healthy point...everything went back normally.

      - Once started in safe mode, i proceed to Uninstall the previous Driver via Device Manager...system asked me to restart, i did it, entering again into safe mode to install the newer driver...then i restart to normal...same error.

       

      - I've been using the generic drivers from this website and i haven't gotten problems except today.

       

      My question would be:

      What am i doing wrong?



       

      Message edited by: Jesss Update: Thread title changed for better comprehension.

       

      P.S.: Added Driver version information (specially nvidia one)