8 Replies Latest reply on May 3, 2013 10:18 AM by sylvia_intel

    Flaky USB ports

    marschw

      My DC3217IYE seems to lose connectivity with some or all of its USB devices every so often.  Sometimes it happens right from boot, sometimes while its running.  Some devices seem more prone to it than others (e.g. it happens very frequently to one of those flexible silicone-encased keyboards), but it's happened to a lot of different devices.  Do I have a defective unit, or is this a design flaw other people are seeing?

        • 1. Re: Flaky USB ports
          Freddy Gonzalez

          Hello marschw,

           

          Please provide more details about when and how the problem occurs.

           

          In the mean time, our suggestions will be updating your system BIOS for troubleshooting purposes. Also, besides the keyboard what other devices have you used when the results were the same?

           

          Regards,

          • 2. Re: Flaky USB ports
            marschw

            Thanks for taking a look at this.

             

            It's intermittent, and I haven't seen any pattern or potential causes.  I've used the following USB devices with it:

             

            1. The aforementioned USB silicone keyboard.
            2. A wireless Logitech keyboard and mouse combination that's about 10 years old.
            3. A newer wireless Logitech mouse.
            4. An unbranded wired mouse.
            5. An Asus CD/DVD drive.
            6. A Seagate hard drive.
            7. An unbranded 4-port hub.

             

            To be clear, the wireless devices above use USB radios to communicate with the peripherals.  I'm not talking about Bluetooth keyboards/mice.  (Though, incidentally, Bluetooth would've been a fantastic feature for this NUC).

             

            All of the above USB devices are bus-powered.  I can get model numbers and USB VID/PID values if necessary, but this NUC is my grandmother's, and I'll need to go to her apartment to gather that data.  This is also part of the reason why unplugging/replugging affected devices is not an acceptable solution -- my grandmother doesn't have the finger strength to easily do that.  Aside from that, it doesn't always work.  And aside from that, it really shouldn't be necessary.

             

            Retrospectively, it's possible that this issue only affects keyboards and mice.  When I don't have a working keyboard or mouse, it's hard to tell whether the other peripherals are working.

             

            I've been using BIOS 39, I don't know if it affects other BIOSes.

            • 3. Re: Flaky USB ports
              lhill

              Hi marschw,

               

              The issue you've described with your USB devices has not been seen by others, as far as I can tell.  The USB port(s) could indeed be flaky on your unit.  Is this happening with all the ports on the box or just a particular one?

               

              What is the make/model of the flexible silicone keyboard? I can try tracking one of those down here to test.

               

              You may wish to update to BIOS v0040 and see how that affects the USB connectivity. If updating to v0040 does not fix this issue, please send an email to Intel Customer Support at http://www.intel.com/support/mailform/desktop/nuc/emailsupport.htm and request a warranty replacement.

               

              Regards,

              Lois H.

              Intel

              • 4. Re: Flaky USB ports
                cascada

                Hi,

                 

                I have the same problem with my DC3217BY.

                 

                At first, with default (stock) BIOS version it was working, after upgrading BIOS to the latest (0040) version, USB mouse become unusable. I am using wireless Logitech Touch Mouse M600.

                It just stops for a second and then jumps on a screen (in Windows 8), this occurs even in BIOS (so it's not Windows related).

                 

                What can I do, how to fix it, is there a batch I can try?

                 

                Best Regards

                • 5. Re: Flaky USB ports
                  lhill

                  Hi cascada,

                   

                  Did this problem only start AFTER you updated to BIOS version 0040? It does not appear that any changes were included that should have caused this, but you never know.  I'll need to try tracking down this mouse model and testing it here.

                   

                  Regards,

                  Lois H.

                  Intel

                  • 6. Re: Flaky USB ports
                    cascada

                    Yes, this problem started right after BIOS update.

                     

                    We also use Logitech Wireless Solar Keyboard K750 and both (keyboard and the mice) are plugged into two USB's in back.

                    SSD is Intel SSDMCEAC180B301928175 and WiFi slot is empty.

                     

                    I did this update because with the stock BIOS the CPU went so hot almost 80c and SSD stopped working.

                    • 7. Re: Flaky USB ports
                      marschw

                      I tried updating to BIOS 0040, and it didn't fix the problem.  However, I'm beginning to think that I've been seeing issues caused by two separate faulty USB devices.  The first is the aforementioned silicone keyboard.  The second is a Justcom-branded hub (model JC-4U2H, PID:VID is 04cc:1520 rev 0200).  I'm not using the silicone keyboard any more, and I swapped out the hub for another, and I haven't seen it happen again yet.  But, I only tried rebooting a few times, so we'll see.

                       

                      Here are the PID:VID values for some other USB devices that I've had attached when this behavior occurred:

                      1. Asus CD/DVD burner, 0e8d:1806 rev 0
                      2. Logitech wireless keyboard (this is not the silicone keyboard), 046d:c503 rev 10;7
                      3. Logitech wireless mouse, 046d:c50e rev 2510
                      4. Logitech wireless mouse (a different one), 046d:c501 rev 0910

                       

                      And, perhaps worth noting, my SSD is an Intel SSDMCEAC120B3 -- close to cascada's.

                      • 8. Re: Flaky USB ports
                        sylvia_intel

                         

                        Since it looks the BIOS updated did not fixed the issue, please contact your local support group for assistance: http://www.intel.com/p/en_US/support/contactsupport?group=processor and request a warranty replacement.

                         

                        regards,