1 Reply Latest reply on Mar 29, 2013 11:04 AM by Patrick_Kutch

    82599 NIC use VF got DMAR 0 error

    Jiangh.LI

      I'm using an OS reserverd memory as DMA mapping memory, and then map it to Guest OS. at the same time, the VT-d is enabled.

       

      As the VT-D spec indicated, I set up an identiry mapping for reserverd memory , it works well in PF, but after I change to VF, the following error log are outputted :

      [   95.030756] DRHD: handling fault status reg 2

      [   95.030764] DMAR:[DMA Write] Request device [03:10.0] fault addr 0

      [   95.030766] DMAR:[fault reason 05] PTE Write access is not set

      [   95.030772] DMAR:[DMA Write] Request device [03:10.0] fault addr 0

      [   95.030773] DMAR:[fault reason 05] PTE Write access is not set

      [   95.030779] DMAR:[DMA Write] Request device [03:10.0] fault addr 0

      [   95.030780] DMAR:[fault reason 05] PTE Write access is not set

      [   95.030787] DMAR:[DMA Write] Request device [03:10.0] fault addr 0

      [   95.030788] DMAR:[fault reason 05] PTE Write access is not set

       

      Did anybody encount this kind of issue?

       

      my enviroment:

      Kernel: 3.0.4

      Guest OS: kernel 2.6.34
      CPU : Intel xeon
      Hypervisor : qemu 1.0.1

        • 1. Re: 82599 NIC use VF got DMAR 0 error
          Patrick_Kutch

          If you can provide me with more details, I might be able to help you.

           

          What controller (NIC) are you using?  What version of the driver?  What specific OS are you using?

           

          Also you need to make sure your server supporst SR-IOV.  Supporting VT-d is only one part of the necessary components that the platform needs to support SR-IOV.

           

          thanx,

           

          Patrick