11 Replies Latest reply on Apr 6, 2013 2:35 AM by atbs

    S1200BTS: RAID Option ROM does not show on boot

    atbs

      Hi all,

       

      i bought a machine with an Intel Server Board S1200BTS and I want to configure a disk array using the chipset's features. I selected "RAID" as SATA mode and "RST" as RAID mode in the mass storage controller section of the BIOS setup. But how do i create the RAID array? No option ROM is displayed on boot, i tried hitting Ctrl+E or Ctrl+I anyway but nothing happens. Additionally, no SATA device is available for boot (i suppose because they are now handled by the RAID BIOS that i cannot access). Changing the RAID option to ESRT does not change this behaviour (just tried this for debugging purposes). I also checked the BIOS boot configuration because i think that a seperate boot option should be visible there but it only shows the two NICs and the EFI shell option. I updated the BIOS to the latest version 41 but that did not resolve the problem. Does anyone have a clue what i might be doing wrong here? Quiet boot is disabled by the way. Clearing the CMOS did not help either. If i change the controller mode back to AHCI my disks show up and i can boot from a single disk but this is not what i intend to do.

       

      Any help is appreciated because the system was ordered without on-site support and therefore i would have to return it to the dealer (he insists that this feature should be available out of the box).

       

      Alex

        • 1. Re: S1200BTS: RAID Option ROM does not show on boot
          john_s@intel

          atbs,

           

          The S1200BTS has support for six 3Gb/s Serial ATA II hard drives through six onboard SATA II connectors with SW RAID 0, 1, 5, and 10.

           

          You can use Intel® Embedded Server RAID Technology II or Intel® Rapid Storage Technology for RAID.

           

          ESRT2 through onboard SATA connectors provides SATA RAID 0, 1, and 10 and optional RAID 5 support provided by the Intel ® RAID Activation Key AXXRAKSW5.

           

          RST RAID through onboard SATA connectors provides SATA RAID 0, 1, 5, and 10.

           

          See page 71 of the S1200BT Technical Product Specification for details of configuring RAID options in the BIOS.

           

          Regards,

          John

          • 2. Re: S1200BTS: RAID Option ROM does not show on boot
            atbs

            Hi John,

             

            thanks for your answer but that does not help me at all because i read the specification and i know those features. I configured the SATA controller to RAID mode but i cannot enter a RAID BIOS / utility / whatever to create a raid array.

             

            Regards,

            Alex

            • 3. Re: S1200BTS: RAID Option ROM does not show on boot
              john_s@intel

              So you have the AHCI Capable SATA Controller is set to Enabled, SATA Mode is set to RAID Mode and RAID Mode is set to Intel ® ESRT2 (LSI(TM))  or Intel ® RST (Matrix), correct?

               

              If a RAID Volume has not previously been created, it's necessary to Save and Exit and reboot in order to create a RAID Volume.

               

              Are the SATA HDDs direct connected, or are you using a hot swap backplane, or expander backplane?

               

              If using a backplane, can you try direct connecting the HDDs?

               

              John

              • 4. Re: S1200BTS: RAID Option ROM does not show on boot
                atbs

                1) Correct

                2) I saved and rebooted multiple times

                3) The HDDs are connected to a hot swap backplane (Chenbro rack chassis)

                4) I can try to connect a disk directly. Do you think that the connected backplane prevents the RAID BIOS from working?

                • 5. Re: S1200BTS: RAID Option ROM does not show on boot
                  john_s@intel

                  I think not seeing HDDs maybe causing the system not to enable access to the RAID BIOS. Why would you need to use the RAID BIOS if there's no HDDs and nothing to configure?

                   

                  Is there a firmware update available for the Chenbro rack chassis hot swap backplane? Is is an expander, or non-expander backplane?

                   

                  John

                  • 6. Re: S1200BTS: RAID Option ROM does not show on boot
                    atbs

                    Yeah, connecting the disks directly is definitely worth a try. The backplane does not have an expander. The chassis is a Chenbro RM21706. I found a picture of the 6-disk backplane on the web:dsc0046bkb.jpg

                    In my system each of the connectors on the right is connected to the mainboard with an SFF8087-SATA cable (2x4 SATA connectors total, 2 of them are not connected to the mainboard)

                    • 7. Re: S1200BTS: RAID Option ROM does not show on boot
                      john_s@intel

                      I was looking at the Chenbro RM21706 support site to get some information on their backplanes, but found the three options they list all have six standard 7-pin SATA2 connectors for the HDD data.

                       

                      Am I looking in the right place?

                       

                      John

                      • 8. Re: S1200BTS: RAID Option ROM does not show on boot
                        atbs

                        Close but this is my link to the support downloads page for the RM21706: Chenbro Micom Co., Ltd.

                        Weird because the only difference in the URL is "www" instead of "usa". But anyways, the first backplane in the list (6G(SAS2) 6-Port Mini-SAS Backplane) is the one.

                        Couldn't get my hands on the system yet to try it without the backplane. I'm curious if it will work because the backplane itself does not make any trouble when i switch the SATA controller mode to AHCI (Windows boots, all drives are accessable).

                         

                        Happy Easter!

                        • 9. Re: S1200BTS: RAID Option ROM does not show on boot
                          john_s@intel

                          Thanks for the correct link.

                           

                          At this point we're trying to eliminate possibilities. Taking the backplane out is one of those "optional" things we can test.

                           

                          For this if you have a couple HDDs and an SATA octopus cable you could use is all you need.

                           

                          John

                          • 10. Re: S1200BTS: RAID Option ROM does not show on boot
                            atbs

                            Hi John,

                             

                            i tried it without the backplane but nothing changed (I connected a single disk directly). Then i gave the "reset to default values" option a try. I did not change many BIOS options though (only date/time, enabled C3 state). When the system rebooted, i entered the setup again and only changed the SATA controller to RAID and the RAID mode to Intel RST and then i disabled the silent boot option. After another quit & save the system came up with the RAID BIOS ("press Ctrl+I ...") and i was able to configure volumes and stuff (the one drive that i connected also showed up). I switched it off and reconnected the backplane. The system booted just as before and i configured a RAID 5 array on 4 of my drives.

                             

                            Apparently the solution was to reset the BIOS setup values to default. When i updated the BIOS to the latest version i was surprised that the settings had not changed. In my experience (from motherboards from other manufacturers) those settings are deleted when upgrading the BIOS.

                             

                            I could not test the RAID array yet because i have to reinstall windows first (won't boot with the controller switched to RAID mode). Then i'll give a last update on that issue.

                             

                            Thank you!

                            Alex

                            • 11. Re: S1200BTS: RAID Option ROM does not show on boot
                              atbs

                              OK the system is now up and running. I configured a RAID 5 array of four Seagate ST3000DM001 hard disks.

                              I installed the RST driver and was able to access the RAID volume. One thing still bothers me: While read speed is awesome (>430 MB/s) the write performance is very low (~30 MB/s) and I did not manage to enable write-back caching for the volume. The RST help says that i just have to click on "enable" in the management options of the volume but the RST GUI does not show the appropriate button. Could you also help me with this issue please?

                              Alex