6 Replies Latest reply on May 8, 2013 7:21 PM by scyphe

    iaStorF.sys BSOD at boot using WPK trace in Windows 7 SP1

    scyphe

      This is 100% reproducible and seems to have been around since forever.

       

      I install the WPK (Windows Performance Tools Kit) from the latest Windows SDK, follow the instructions on how to do a complete boot trace file that I can open with xperfview to analyse what happens during boot, how much time drivers and boot tasks take etc... And during boot I get a BSOD. The only way to get back into Windows is to select "last known good configuration" to clear the trace flag. I run an OCZ Vertex 4 128GB (latest firmware) in one of the Intel SATA 6Gbit ports, AHCI mode, as my boot/OS drive.

       

      The command I use to enable

      xbootmgr -trace boot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP


      irst bsod.JPG


      However, if I remove +DRIVERS from the xbootmgr command I successfully boot into windows and can open the trace log, but obviously it's not much use since I want the driver boot times as well.


      I've tried several different versions of iRST but same result (using latest available for my ASUS Sabertooth P67, iRST11.7). I will keep the minidumps if the developers want to look at them. It is the ONLY driver that cause this boot-BSOD.


      There's an old discussion on MSFN.org that mentions this issue in 2009i (albeit not iaStorF.sys specifically): http://www.msfn.org/board/topic/140247-trace-windows-7-bootshutdownhibernatestandbyresume-issues/

        • 1. Re: iaStorF.sys BSOD at boot using WPK trace in Windows 7 SP1
          kevin_intel

          Hello Scyphe,

           

          I understand you are getting BSOD's when using the Intel® Rapid Storage Technology version 11.7.

           

          Please note that we have received reports of certain issues when using Intel® Rapid Storage Technology version 11.7. Our Engineering department is aware of this and they are working hard to solve these issues with the next driver release.

           

          At the moment, I suggest you testing another Intel® Rapid Storage Technology version since the latest one we have is affecting your system. You can download version 11.2 from the following link:

           

          http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21407&lang=eng&OSVersion=Windows%207%20%2864-bit%29*&DownloadType=Drivers

           

          It is also important to mention that the drivers that provide are generic drivers for your system. This is because we provide the hardware to the system manufacturer and they will design and create custom drivers specifically for their systems. So in the case our driver does not work properly in your system, I suggest you installing the latest drivers for your computer from the system manufacturer side or testing as well a previous driver version from their download website.

           

          Thanks.

          1 of 1 people found this helpful
          • 2. Re: iaStorF.sys BSOD at boot using WPK trace in Windows 7 SP1
            scyphe

            I've now tried drivers from 11.2 (with original OROM in Bios, 10.5.x.x) up to 12.6.0.1028 and updated the AHCI/RAID OROM in the stock bios with 12.6.0.1867, installed only the drivers, not the entire RST package etc... I've tried everything and Windows Performance Toolkit boot performance tool will always crash at iaStorF.sys.

             

            Command used:

            xbootmgr -trace boot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP


            It's always the same adress where it crashes:
            iaStorF.sys+791c

             

            iaStorF.sys or one of it's dependencies simply have a bug that makes it impossible to make a proper boot-time performance analysis with drivers enabled.

             

            I noticed the .sys file has finally been updated (the last version was from early/mid 2012) but unfortunately it seems it was some minor changes since the BSOD happens at the exact same adress in IaStorF.sys.

             

            лю4 VS_VERSION_INFO 040904b0 Comments -x64

            CompanyName  Intel

            Filedescription Intel Rapid Storage Technology Filter Driver x64

            File Version 12.6.0.1028   InternalName IaStorF.sys

            etc..

             

            But that didn't make one bit of difference, it crashes Windows SDK Performance Tool Kit (boot performance recorder) exactly when it loads iaStorF.sys at the same adress.

             

            The system works as it should with the RST drivers installed in Windows so that's not the question but it really shouldn't crash a tool that is part of the Windows SDK. I'm running a totally legal copy of Windows 7 SP1 x64 with following hardware:


            ASUS Sabertooth P67.B3 motherboard

            Intel Core i5 2500K

            8B G.Skill Ares CL9 RAM

            MSI  Radeon 7950/OC


            Drives in system:

            OCZ Vertex 4 128GB as the system disk: SCSI\DiskOCZ-VERTOCZ-VERTEX4_____1.5_

            OCZ Vertex 2E 90GB: SCSI\DiskOCZ-VERTOCZ-VERTEX2_____1.37

            Western Digital Black 1TB drive: SCSI\DiskWDC_____WD1002FAEX-00Y9A1D05

            Seagate 250GB: SCSI\DiskST325082ST3250823AS_____3.06

            Seagate 320GB: SCSI\DiskST332062ST3320620AS_____K___

             

            Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller (Series 6/C200 chipset)

            Driver version (this time): 12.6.0.1028

             

            Intel(R) 6 Series/C200 Series Chipset Family SMBus Controller - 1C22

            Driver version: 9.2.0.1033

             

            Latest Windows Update always.

             

            Link to minidump (guaranteed virus free) file that you can send to the developer team in case they actually want to look into it:


            http://www.bahnhof.se/wb800827/042113-10062-01.dmp

             

            I really hope this is something that will get fixed after years of crashinh Windows Performance Toolkits boot-performance tracer and analyser since it's a necessary tool to find drivers and issues with boot performance.

             

            bsod_minidump_analysis.jpg

             

            I did hear rumours that your company would change the driver model and stop using the legacy model of IaStor/A/F/V.sys as well as stop treating AHCI/RAID devices as SCSI devices.

             

            Anyway, I hope this information might be used for something constructive by the Chipset/RST-driver team. I know I'm not alone in experience this particular issue (it's a common one on systems with RST drivewrs on different chipsets. I also hope my excellent military grade P67-board isn't treated as legacy and ignored just because the 7-series has been around for a while and the haswell is coming soon and new chipsets are on the horizon.

             

            Btw, this is how far the xbootmgr (part of Windows Performance Toolkit) logs:

             

            [2013/04/21-11:35:12.588] Detected Win7RTM physical (ReadyBoot) prefetcher; the SysMain service is auto-started.

            [2013/04/21-11:35:12.588] Registering for auto-run with a 120000 msec delay...

            [2013/04/21-11:35:12.588] Completed auto-run change.

            [2013/04/21-11:35:12.598] Starting trace...

            [2013/04/21-11:35:12.798] Enabled boot logging to 'C:\TEMP\boot_BASE+CSWITCH+DRIVERS+POWER_1_km_premerge.etl'

             

            Obviously it doesn't log any .etl file since it crashes just when it's about to start logging.

             

            As I wrote before that command works if I remove '+DRIVERS' from the command line but that defeats the purpose of the tool.

             

            Just for general information: device manager.JPG

             

            I really hope this is something that will be looked at/fixed since Intel WHQL drivers ought to be compatible with Windows SDK Performance tools.

             

            Regards,

            Daniel Nilsen

             

            ps. as for the manufacturer (ASUS), they just provide stone age versions of your drivers and haven't updated on their site since june 2011. Instead they refer to intel.com in the forums:

             

            Intel(R) Rapid Storage Technology Driver Software V10.5.0.1026 for Windows XP 32bit & 64bit.
            Intel(R) Rapid Storage Technology Driver Software V10.5.0.1026 for Windows Vista/7 32bit & 64bit.(WHQL)
            • 3. Re: iaStorF.sys BSOD at boot using WPK trace in Windows 7 SP1
              Fernando

              Just for your information:

              Users, who "downgraded" their Intel RST drivers from

              • any v11.5.x.xxxx or higher (using the iaStorA.sys and the additional SCSI filter driver iaStorF.sys)

              to

              • any "classical" Intel RST driver using just the iaStor.sys (latest version: 11.2.0.1006)

              and run into problems after having done that, should read this statement and a workaround layed down by Squall Leonhart: http://forums.pcsx2.net/Thread-Rapid-Storage-11-5a-Bugs-and-removal-notes

              1 of 1 people found this helpful
              • 4. Re: iaStorF.sys BSOD at boot using WPK trace in Windows 7 SP1
                scyphe

                We keep bumping into each other.

                 

                I'll check out that link of yours and see if it works with a pre-SCSI-filter driver.

                 

                Can you run the xbootmgr tool (can be selected as only component from latest Windows SDK) with:

                 

                xbootmgr -trace boot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP


                without BSOD?


                I'll check out that link of yours anyway but the fact that the bug is present even in the brand new generation (well.......) 12.6.0.1028 drivers is a concern. Makes it impossible to view driver stalls/issues in xperfview during boot since no log is created due to the 0x7E BSOD.


                Info about 0x7E:

                http://msdn.microsoft.com/en-us/library/windows/hardware/ff559239%28v=vs.85%29.aspx


                I don't have any information on which systems show this behavior, ie. if it's platform independent and totally driver-dependent (ie. doesn't matter if it's 5-, 6-, 7-series chipsets as long as the drivers used are the SCSI-filter ones using IaStorF.sys).


                EDIT: Cleaned the system according to that guide, running solely on MSAHCI, every trace of IaStorA and IaStorF is completely gone from registry and any windows folder. Will try xbootmgr trace and see if it is still crashing.

                • 5. Re: iaStorF.sys BSOD at boot using WPK trace in Windows 7 SP1
                  Fernando

                  scyphe schrieb:

                   

                  Can you run the xbootmgr tool (can be selected as only component from latest Windows SDK) with:

                  xbootmgr -trace boot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

                  without BSOD?

                  Yes, I get no BSOD, but this message, which means "The path is not available" (the Win8 Performance Toolkit has been properly installed on my system):

                  Windows SDK message.png

                  • 6. Re: iaStorF.sys BSOD at boot using WPK trace in Windows 7 SP1
                    scyphe

                    I can now, with red cheeks, say that it had nothing to do with the Intel drivers. I uninstalled them and tried MSAHCI as well as using IDE with the same crash, just not with the IaStorF/A files listed. Now I've installed Win7 SP1 in UEFI mode and done a number of traces, always crashing. But since then I have seen other drivers being the culprit as well as finding dozens and dozens of posts from people with completely different systems that simply cannot run the command with +DRIVERS in it, they get 0x7E. It seems to be (afaik) a problem with the trace behaviour with Windows Performance Tool Kit when using the +DRIVERS flag in the command.