1 2 3 Previous Next 38 Replies Latest reply on Oct 24, 2013 3:00 PM by John Richeson

    Ongoing Centrino N2230 connection at boot up issues

    challengerdude

      Well I have a brand new HP DV7 and I thought I had this WPA2 problem whipped but I don't. When I start the computer is does not connect automatically and I have to do it manually 2 times out of 10 start ups. Some days are better than others. Sometimes normal start ups are fine and it will only do it when I select restart on the computer instead of shut down.

       

      I did figure out the last Router had to be set a certain way to connect to this machine and it was odd because any other laptop connects fine here and always have.

       

      Now, I bought a new Linksys E1200 router the other day and this machine with the N2230 just does not like WPA2 but the other machines are fine. Once this connects it never drops but I am weary of having to connect manually at times.

       

      I am wondering if another adapter might work in place of the N2230 ? My HP manual does not even list the 2230 for this machine.

       

      I have done every adjustment I can think of plus I have the 15.6.0.19 driver.

       

      If I have to get another N2230 what exactly would be the part number I need? 

       

      I need to do something to fix this.

       

      Thanks

        • 1. Re: Ongoing Centrino N2230 connection at boot up issues
          joe_intel

          Hello! You may want to verify your router has the latest firmware and is set up to WPA2 AES encryption only, not TKIP+AES. The same settings will apply for the wireless profile in your computer.


          The latest driver for your wireless adapter is 15.6.1 available here: http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Wireless+Networking&ProductLine=Intel%C2%AE+Centrino%C2%AE+Wi-Fi+Products&ProductProduct=Intel%C2%AE+Centrino%C2%AE+Wireless-N+2230&ProdId=3507&LineId=1784&FamilyId=1783


          Regarding the replacement of the Intel® Centrino® Wireless-N 2230 adapter; note that this adapter is meant to be professionally installed by Original Equipment Manufacturer (OEM) technicians on certified systems only.

           

          Please note that these adapters are not meant to be sold separately, your system must be compliant with the required FCC certifications in compliance with the International Special Committee for Radio Interference standards for radiated and conducted electromagnetic interference.

           

          In this case what we recommend and encourage you to first contact the Original Equipment Manufacturer (OEM) to determine if the product is approved for use in your computer.

           

          If the issue persists please indicate if you are trying to connect with Intel® Proset or with Windows and if there is an error message.

           

          • 2. Re: Ongoing Centrino N2230 connection at boot up issues
            challengerdude

            Thanks for the reply Joe.

             

            I have the WPA2 Personal  AES in the laptop and same WPA2 in the router except I cannot find anything in the Linksys E1200 that says if it is WPA2 Personal AES or TKIP+AES. It connects most of the time these days and if it doesn't, it will in exactly 1 minute.   BUT, it should always connect like the other machines do. It never drops and has full signal.

             

            Windows 8 runs well and does not report any errors and the Centrino 2230 was OEM for this machine is why I wanted to try replacing it with the exact same thing. That is about the only thing left to try. I removed it and re-seated the connectors but that did not help.

            I will call the router folks and see if they can give me a clue about the AES-TKIP to make sure I am not there.

             

            I have the 15.6 driver in there and it does not make any difference from the factory installed driver.. I let the Intel program control the wi-fi and now switched back to Windows and that didn't make any difference either.

            Thanks.

            • 3. Re: Ongoing Centrino N2230 connection at boot up issues
              challengerdude

              I contacted the Linksys router tech and she said that I have WPA2-AES+TKIS in the router. I explained that I was trying to get rid of the WPA2 AES-TKIS and just use WPA2-AES like my machine is set for and this is the response :

               

              "Actually, the router's WPA2 security is set to TKIP/AES by default. It can't be changed on the router, Sir."

              • 4. Re: Ongoing Centrino N2230 connection at boot up issues
                joe_intel

                It seems to be that response is probably correct as I was not able to find any reference of TKIP or AES in the Linksys E1200 user guide. It appears to be the router does not offer such setting in order to select the specific encryption protocol like other previous Linksys routers offered.

                 

                Therefore, it is also possible the computer is taking longer to complete the handshake with the router as it needs to decide whether to use TKIP or AES. One way to figure this out is if you have the chance to test with the connection as opened or unsecured.

                 

                I hope this suggestion helps.

                • 5. Re: Ongoing Centrino N2230 connection at boot up issues
                  PudgyOne

                  TKIP should be WPA-PSK(TKIP) Security(Personal

                   

                  AES should be WPA-AES or business.

                   

                  You can run Network Interface and it will tell you, under cipher, TKIP or show up as CCMP

                   

                   

                  Rick

                  • 6. Re: Ongoing Centrino N2230 connection at boot up issues
                    challengerdude

                    Here is what it shows.....thanks.

                     

                    There is 1 interface on the system:

                     

                        Name                   : xxxxxxxxxxxx

                        Description            : Intel(R) Centrino(R) Wireless-N 2230

                        GUID                     : xxxxxxxxxxxx

                        Physical address   : xxxxxxxxxxxx

                        State                     : connected

                        SSID                     : xxxxxxxxxxxx

                        BSSID                    :c0:c1:c0:ec:47:eb

                       Network type           : Infrastructure

                        Radio type             : 802.11n

                        Authentication         : WPA2-Personal

                        Cipher                     : CCMP

                        Connection mode       : Auto Connect

                         Channel                    : 1

                        Receive rate (Mbps)    : 144

                        Transmit rate (Mbps)   : 144

                        Signal                        : 96%

                        Profile                       : xxxxxxxxxxxx

                     

                        Hosted network status  : Not available

                    • 7. Re: Ongoing Centrino N2230 connection at boot up issues
                      PudgyOne

                      The WPA2-Personal is showing in cipher as AES, that's what the CCMP is.

                       

                      Try WPA-Personal and it should turn back to TKIP but the recieve and transmit rate will drop to 54Mbps)

                       

                      Try these tweaks....

                      Start, control panel, device manager. Click on Network and then right click on your wireless adapter, left click properties, power management. Uncheck the box, allow computer to turn off this device to save power.


                      Go to the power options, and changed the Wireless Adapter Setting, from Maximum Power Setting to Maximum Performance.

                      maxiumperformanceonbattery.jpg

                      I have heard to try...(but I cannot confirm this)

                      Disable Bluetooth on the Centrino 2230 and also set Bluetooth(R) AMP: Disabled.

                       

                       

                       

                       

                      Rick

                      • 8. Re: Ongoing Centrino N2230 connection at boot up issues
                        challengerdude

                        I had everything to maximum power already so I just went and disabled blue tooth.

                        Strange that with the older Netgear I had the same thing happen with WPA-2 but WEP connected every time as long as I set it to "up to 150mbs"  It wouldn't connect every time with WEP set "up to 54 mbs"

                        I'll see how this goes for a while then try WPA.

                         

                        Thanks.

                        • 9. Re: Ongoing Centrino N2230 connection at boot up issues
                          challengerdude

                          It connected 8 times in a row since I disabled blue tooth but I need to watch it for a while. Some days are better than others. I have no clue as to why. This has been a good day so far, it only screwed up a couple of times.

                          • 10. Re: Ongoing Centrino N2230 connection at boot up issues
                            challengerdude

                            Well blue tooth didn't solve it. Worth a try tho. Darn.

                            • 11. Re: Ongoing Centrino N2230 connection at boot up issues
                              PudgyOne

                              Joe,

                               

                              Another thing I heard was to

                               

                              start, control panel, network and sharing center, click on your connection properties.

                               

                              Uncheck the TCP/IPv6 box and see what happens.

                               

                              tcpipv6.jpg

                               

                               

                              Rick

                              • 12. Re: Ongoing Centrino N2230 connection at boot up issues
                                challengerdude

                                I went to WPA TKIS and it really slowed it down but connected ok. I want to make it work with WPA2 so I am back to that and unchecked the box you suggested.

                                We know it works with WEP and it will probably work ok with no security as well that Joe wants me to try and I will get to that. 

                                Thanks.

                                • 13. Re: Ongoing Centrino N2230 connection at boot up issues
                                  PudgyOne

                                  Joe,

                                   

                                  That should give Joe_Intel somewhere to have the technicians look to correct this issue.

                                   

                                   

                                  Rick

                                  • 14. Re: Ongoing Centrino N2230 connection at boot up issues
                                    challengerdude

                                    It is interesting to me that's fer sure. I love the notebook and it is incredibly fast with the 3740 i7 and 840 Pro SSD. I cannot hardly believe that it only takes a few minutes to do a virus scan. My other machine with the 2630 i7 and 520 Intel SSD is pretty quick as well.

                                    I will report back after I run it for a while with the iPv6 unchecked.

                                     

                                    It just does not like the WPA2.  Oh well, that's the way it goes, first your money and then your clothes !

                                    1 2 3 Previous Next