13 Replies Latest reply on Mar 4, 2015 8:57 PM by ZzyzxOh

    DH61AG BIOS update disaster.

    Andy Davidson

      Folks,

       

      I am...well, was, a very happy DH61AG user.  I've got three of them here, and had no problems at all.  Until this evening.

       

      Decided I was going to upgrade one of the machines to Windows 8, so checked out the BIOS versions.  My board was running 0023.  I wanted to be running 104.

       

      Things went as follows:


      • Tried to update to 0039.  I couldn't, I was told by the F7 BIOS flash that my existing BIOS was too old. 
      • F7 upgrade to 0031, worked OK
      • F7 upgrade to 0039 failed
      • Booted in to Windows 7 (existing install of Pro x32 off mSATA SSD) and ran the Express Update within Windows to 0039
      • Rebooted OK, all OK so far
      • Express Update to 0099 - failed in Windows
      • F7 upgrade to 0099 - seemed successful
      • Rebooted, now machine won't boot off mSATA drive, reboots constantly at BIOS screen
      • Tried booting off USB stick, BIOS locks up solid
      • Trying to flash 0104 I get flash failure with "FwUpdateBufferFull" followed by 0x80000....00015 (I think, it doesn't stay on screen long)

       

      So, now my machine won't boot, is stuck on a broken 0099, I obviously can't flash up to 0104, or flash down to something less broken. 

       

      Specs:

      DH61AG

      2x2GB Micron PC3-10600S-9-11-B1 DIMMs

      Intel Centrino Wireless-N 1030 wifi card (tried removing this, no change)

      Crucial M4 64GB mSATA SSD

      Celeron G530

      DVI monitor

      Dell 90W PSU

       

       

       

      Any suggestions?

        • 1. Re: DH61AG BIOS update disaster.
          Andy Davidson

          0x80000...0015, 1560 is the error message.  It happens when trying to flash the Intel Management Engine Firmware.

           

          Currently the BIOS shows the Engine Firmware to be 0.0.0.0.

          • 2. Re: DH61AG BIOS update disaster.
            jiten23bisht

            Hi Andy,

                         

                           I don't know if tried to do BIOS recovery or not. So here its is please do the recovery process as mentioned below ..

            http://www.intel.com/support/motherboards/desktop/sb/CS-023360.htm

             

            After this check if your machine is booting properly or not.. if its working then flash 104 BIOS with iflash method

             

            1. Make a bootable USB flash drive using any software for instance you can use HP USB Disk Storage Format Tool - v2.1.8

             

            2. Download zip file http://downloadmirror.intel.com/22523/eng/AGH6110H.86A.0104.BI.ZIP (contains BIOS & iflash2)

             

            3. Copy iflash2.exe & AG0104.BIO file in  USB flash drive

             

            4. Boot through  USB flash drive.

            Command: iflash2.exe /pf AG0104.BIO


            5. Restart the machine ..


            Let me know if its works .


            Regards,

            J.Bisht

            • 3. Re: DH61AG BIOS update disaster.
              Andy Davidson

              Recovery F7 flash taking the jumper off worked a treat, thank you.

               

              Installing Windows8 as I type...

              • 4. Re: DH61AG BIOS update disaster.
                jiten23bisht

                Glad to hear it works Andy .. now enjoy

                • 5. Re: DH61AG BIOS update disaster.
                  minder

                  Hi,

                  same problem here. With recovery jumper the bios is now on 0104.

                   

                  But the pcie port does not work anymore.

                  Bios says "Not Populated"

                   

                  Also the CIR. It's enabled and the device shows up in OS.

                  But no events are received.

                   

                  Any suggestions?

                   

                  I tried to reapply 0104 with suggested iflash method. But no success.

                   

                  IFLASH2 Version 2.6J - Build 066

                  BIOSID's do not match

                  Currently Installed BIOS ID: AGH6110H.86A.0104.2013.0227.1805

                  Attempting to install BIOS ID: ^M!!dw(@-     (and some other ascii characters with smileys etc)

                  • 6. Re: DH61AG BIOS update disaster.
                    CharlieCL

                    "Recovery F7 flash taking the jumper off worked a treat"

                     

                    How do you make it work? When I removed the jumper there was no any display on screen.

                    • 7. Re: DH61AG BIOS update disaster.
                      kevin_intel

                      Hi minder and CharlieCL,

                       

                      I will try to replicate your issue and I will be back with more information.

                      • 8. Re: DH61AG BIOS update disaster.
                        kevin_intel

                        Hi,

                        I have tested the DH61AG and I was not able to replicate this issue from my side. I followed the instructions to update the bios based on the document for Bios updates and I had no problems with it.

                        My best recommendation is doing a bios recovery to a previous version and then trying updating to the next one and so on.  Before doing this updates, you can try clearing the cmos on the unit by removing the battery and disconnecting all other components from the motherboard for about 10-20 minutes.

                         

                        In case that the updates fail, you can contact your local support so they can help you out with an RMA if necessary.

                        • 9. Re: DH61AG BIOS update disaster.
                          CharlieCL

                          I have sent it back to repair.

                           

                          It may be my BIOS is old 0023. After upgraded to 0099 I could not recovery it back to 0023 but was always 0099.

                          • 10. Re: DH61AG BIOS update disaster.
                            Gauge

                            I would just like to chime in on this forum having just spent 8 hours battling with my motherboard and very nearly reaching the point of having to send it back.

                             

                            Similar to the OP, I was on BIOS 040 and wanted to get to the latest 108 firmware by way of transition version 099.  Here is what I experienced:

                             

                            • Successfully flashed to 099 using the F7 Express and got exactly the same symptoms as the OP.  Saw the version of the Intel Management Engine in the BIOS listed as v0.0.0.0.
                            • Attempts to then F7 flash 106 and 108 resulted in the "FwUpdateBufferFull" error message and failure.
                            • Following the support article on removing the motherboard jumper and using emergency bios recovery (Recovery BIOS update), re-flashing 099 on a USB stick resulted in continuous reboots with no screen activity.
                            • Flashing 108 in emergency recovery yielded an apparently successful flash but compared to the support screenshots I saw only half of the firmware 'categories' get updated.  The motherboard remained inoperative with similar symptoms but the BIOS showed version 108.  IME still listed as v0.0.0.0.
                            • Exactly the same behaviour emergency flashing with 106.
                            • Finally, as a last resort, I emergency flash 104 and bingo, firmware succeeds exactly as the support screenshots suggest and the motherboard is fully operational.
                            • Ordinary flash to 108 from here succeeds and finally motherboard is fully up to date and operational.

                             

                            As far as I can tell there is a very important step missing from the readme that accompanies these firmwares.  It says:

                             

                            If your system's current BIOS version is 0039 through 0045:

                            1. Update to the transition version 0099.

                            2. Then update to 0104 or later.


                            This is incorrect.  It should read:


                            2.  First update to 0104 and then later.


                            It was essential for me to flash directly from 099 to 104 before flashing to later versions, a critical step that could have saved me hours of frustration had I known.

                             

                            Hope this helps someone having similar problems.

                            • 11. Re: DH61AG BIOS update disaster.
                              kevin_intel

                              Hi Gauge,

                               

                              I am sorry to hear that and I apologize for the inconvenience. We appreciate your feedback on this and I am sure It will very helpful for other users.

                              • 12. Re: DH61AG BIOS update disaster.
                                rantanlan

                                I can confirm Gauges findings, same issue, same way to solve it. Thanks for saving me time!

                                1 of 1 people found this helpful
                                • 13. Re: DH61AG BIOS update disaster.
                                  ZzyzxOh

                                  I know this is an old thread, but it is coming up in search a lot.  I wanted to add that those who have been successful in getting to 0099 will see a blank screen if they try the F7 Express Update method but do NOT have a FAT-formatted USB thumb-drive with the AG1040.BIO in the root directory of that thumb-drive.  This is critical to understand that 0099 is not a usable BIOS for anything but completing this step, since it simply prepares the BIOS for the next flash step.

                                   

                                  For me this meant removing the jumper, since it took quite some time to figure out that it wasn't going to give me the menu that I'd expected to use to navigate to the directory and BIO file that I wanted to select.

                                   

                                  I would also suggest you disconnect any SATA drives during this process, especially any SSD, since they seem to get corrupted if you tend to power off the machine while you try to get the process correct the first time.  I have more than one SSD on the bench waiting for me to clean them up.