1 Reply Latest reply on Mar 19, 2013 4:24 PM by Fred_Intel

    Windows shows Intel RAID1 array as uninitialized after rebuild

    ashi

      ok, so i'll start at the top.

      i got a new pc wit the following:

      Gigabyte Z77X-D3H board

      2x WD Red 3TB drives

      Corsair 126GB SSD drive

      (let me know if i'm missing any essential info here).

       

       

      the techs in the store have set the 3TB drives to RAID1 (to my request), via the onboard Z77 SATA controllers.

      before installing the O/S on the SSD drive, a friend of mine moved the 3TB drives to the onboard Marvell 88SE9172 controller instead of the Intel one (SATA3 instead of SATA2). then i installed my O/S (Windows 7).

      everything worked fine for about a week.

      after a week i moved to a new place. after connecting my PC, i noticed that the array has disappeared. after some deliberations, i went into the BIOS and re-created the array, without wiping any data.

      again, everything worked fine for 3-4 days, when suddenly my system was reset and when it came back, the array was gone again, so i did the same, but this time, even after re-creating the array, i didn't see the drives in windows (in the BIOS the drives were shown as "Assigned" and that the Array is OK).

      after reading online forums, i saw that many people have problems with the Marvell controller, so i just moved the SATA cables back to the Intel controller instead of the Marvell one, in the exact same order they were (i don't know if this was a stupid idea or not, but i was desperate and rather annoyed at this point).

      after doing that (and making the needed change in the main BIOS), i could see during the system's loading that the array was discovered right away and was due to start rebuilding, once the O/S has loaded.

      in the O/S it has worked on rebuilding for about 7 hours.

      this morning i woke up to a rebuilt drive and a working array (according to Intel Rapid Storage). however, on windows, i now see 1 drive (as expected) but it's uninitialized.

      i see no drives on "My Computer", and in Disk Management, i see 1 uninitialized disk.

       

       

      can anyone help?

      in the time since i got the array to work i have loaded it with at least 1.5TB of data, which i really don't want to lose.

      have i already lost the data? if not, what do i do in order to not lose it? if so, can i recover?

       

       

      any help would be greatly appreciated!

      thanks!

        • 1. Re: Windows shows Intel RAID1 array as uninitialized after rebuild
          Fred_Intel

          Hi ashi,

           

          What happens is that if you moved the RAID 1 volume from the Marvel SATA controller to the Intel SATA controller then RAID structure will not be properly recognized by the Intel controller.  The metadata of the RAID volume is not going to be the same due to both are different SATA controllers.

           

          Since what you have is a RAID 1 volume then the best option is to set both hard drives to non RAID in the RAID BIOS, after that you can restart the computer into Windows, open the Intel RST and create the RAID 1 volume again.  The information will not be deleted due to the same information will be on both hard drives.  When you create the RAID 1 volume again from the Intel RST you should be able to keep the information that is in one of the hard drives.

           

          This is the link to the Intel RST user guide. This user guide will help you to create the RAID 1 volume from the Intel RST http://download.intel.com/support/chipsets/imsm/sb/irst_user_guide.pdf

           

          Thanks!