4 Replies Latest reply on May 6, 2009 12:45 PM by

    965 core i7 processor running slower than expected

      I have just received a new computer with the Extreme Edition core i7 965 processor, and windows vista, intel processor id program and futuremark's vantage program all list it as running at 2.65 GHz.  Why isn't it running at 3.2 GHz... is this the Power on Demand feature?  How do i determine if there is a problem?

       

      Thanks!

        • 1. Re: 965 core i7 processor running slower than expected

          I even ran cpu-z while the processor was stressed with orthos and the clock speed didn't really change hovering right at 2.65Ghz....Any thoughts?

           

          Thanks

          • 2. Re: 965 core i7 processor running slower than expected
            herbert_intel

            which motherboard are you using? bios updates?

            perhaps the board has an option to disable Speed step (what could cause it to reduce the speed). does it ever go below 2.66ghz?

            At what speed does the board report the QPI is running at? i find it a strange coincidence that its runnint at the speed of a Core i7 920.

             

            OJ

            • 3. Re: 965 core i7 processor running slower than expected

              The motherboard is an evga x58.  I've figured out that for whatever reason, cyberpower reduced the multiplier to 20.  Now that I've set the multiplier to 24 its running at 3.2GHz.  CPU-Z reports the QPI link at 3.2GHz and the Intel ID program lists the expected QPI at 6.4 GT/s and the reported QPI at 7.31 GT/s.  The IMC speed expected is 1066 Mhz and reported is 1219 Mhz with the 24 multiplier.  I don't understand what those are and if thats a problem that they are higher than what intel expects for 965 processor.  I wish i knew how to post pictures here of the screen shots of these programs for people to see.  My pic button is grayed out and doesn't do anything.  Every program identifies the processor as a 965 @3.2GHz but until I set the multiplier to 24 it never reported running at that speed.  What do you think?

               

              Thanks!

              • 4. Re: 965 core i7 processor running slower than expected

                You will have to manually set your memory to run at its manufactured speed in the bios.  Your questions are best addressed on the EVGA forums.  They have fast replies and a few good guides for setting up your memory in the bios.