10 Replies Latest reply on Jan 14, 2014 1:58 AM by DavidDionne

    X520-DA2 issues with HP2910al / J9008A 10GB

    Phil Stiller

      We're trying to get our X520-DA2 NICs to talk with our HP2910al switch with NO luck.   Perhaps someone has some suggestions.

       

      Switch has the J9008A 10GB uplink.

       

      HP direct SFP+ cable (1M) won't show a link light & no connectivity  NIC just disables.  HP insists we need to use HP cables

      Intel direct SFP+ cable (1M) will show a link light, but we cannot ping anything.  Intel insists we need to use Intel cables.

       

      Installed latest drivers from Intel (v18 - Jan11/2013)... still no luck

       

      so... now have HP and Intel pointing fingers at each other.   Suggestions ?

       

      Phil / Intraworks

        • 1. Re: X520-DA2 issues with HP2910al / J9008A 10GB
          aslloyd

          Thanks for the post Phil.

           

          This following link provides some detail in what this adapter is looking for in a cable.  There is no requirement for a particular brand when using DA cables.

           

          http://www.intel.com/support/network/adapter/pro100/sb/CS-030612.htm

           

          That said, an interesting test would be to remove the switch from the equation completely and see what that gets you.  Connect the ports of your adapter to one another using a single cable, restart the interface, and notice whether you get link.  You should also be checking the event log (assuming Windows* here), as our driver will provide some feedback there if it has an issue.

           

          Armed with the outcome of this test, you can either come back to us for assistance with the adapter, or start gathering information from your link partner.

          • 2. Re: X520-DA2 issues with HP2910al / J9008A 10GB
            Phil Stiller

            Performed this test this morning.  Here is what we learned.

             

            1) connecting the Intel cable between the 2 nics worked as expected and we could ping between.

            2) connecting the HP cable between the 2 nics, showed a link light, but no traffic.

             

            So I assume then the the HP switch WON'T identify the Intel cable... and the Intel nic WON'T identify the the HP cable.

             

            HP Cable we're using is the J9281B (SFP+ 1m)   I have 2, both result in the same issue. 

            • 3. Re: X520-DA2 issues with HP2910al / J9008A 10GB
              Phil Stiller

              Oh, and the Event log as follows :

               

              Intel(R) Ethernet Server Adapter X520-2 #2

              PROBLEM: The driver was unable to load due to an unsupported SFP+ module installed in the adapter.

              ACTION: Replace the module.

              ACTION: Install the latest driver from "http://www.intel.com/support/go/network/adapter/home.htm".

               

              DETAILS :

              + System

               

                - Provider

               

                 [ Name]  ixgbn

               

                - EventID 49

               

                 [ Qualifiers]  57348

               

                 Level 2

               

                 Task 0

               

                 Keywords 0x80000000000000

               

                - TimeCreated

               

                 [ SystemTime]  2013-02-19T19:43:58.260427400Z

               

                 EventRecordID 5093

               

                 Channel System

               

                 Computer DC-SAN2

               

                 Security

               

               

              - EventData

               

                 

                 Intel(R) Ethernet Server Adapter X520-2 #2

                 000004000200300000000000310004E0000000000000000000000000000000000000000000000000310004E0

               

               

              --------------------------------------------------------------------------------

               

              Binary data:

               

               

              In Words

               

              0000: 00040000 00300002 00000000 E0040031

              0008: 00000000 00000000 00000000 00000000

              0010: 00000000 00000000 E0040031 

               

               

              In Bytes

               

              0000: 00 00 04 00 02 00 30 00   ......0.

              0008: 00 00 00 00 31 00 04 E0   ....1..à

              0010: 00 00 00 00 00 00 00 00   ........

              0018: 00 00 00 00 00 00 00 00   ........

              0020: 00 00 00 00 00 00 00 00   ........

              0028: 31 00 04 E0               1..à

              • 4. Re: X520-DA2 issues with HP2910al / J9008A 10GB
                mark_h_@intel

                Hi Phil,

                South is correct when he says that the Intel adapters do not require any specific brand of direct attach cable. However, the Intel adapters do check to make sure that the attached cable identifies itself as either a passive SFP+ or an active SFP+ cable as specified in SFF-8472 Specification for Diagnostic Monitoring Interface for Optical Transceivers. For many SFP+ cables, this identification is present as expected and the cable works fine.

                 

                You can see the specification at ftp://ftp.seagate.com/sff/SFF-8432.PDF.

                 

                I have run into previous instances where some cables (including some HP cables) sometimes do not provide the identification the Intel device is expecting. My understanding is that cable vendors can supply you with an HP cable that does identify itself as an SFP+ cable and will work with Intel(R) Ethernet adapters. Because your switch requires an HP cable, you will need to get an HP cable that identifies itself as an SFP+ cable. You will not be able to use the Intel cable or any other vendor's cable.

                 

                Technical Details

                Intel Ethernet adapters require the SFP+/ SFP identification bit (Address A0h, value of 03h) from the SFF 8472 identifier table. Intel Ethernet adapters accept active and passive cables identifying as 8,3 and 8,2 from the transceiver codes table.

                 

                Mark H

                • 5. Re: X520-DA2 issues with HP2910al / J9008A 10GB
                  Phil Stiller

                  Thanks guys.  I'll go back to HP and we'll see what they say.

                   

                  Will keep you posted.

                   

                  Phil

                  • 6. Re: X520-DA2 issues with HP2910al / J9008A 10GB
                    Phil Stiller

                    Well... here is a tour around the block for you.

                     

                    1) on the phone with HP for over 2 hours.  They FINALLY confirmed that the cable is "incompatible" and that this is a known issue.   "Apparently" they are working on it... but looks like I'm SOL for now.

                     

                    2) UN-Officially, they recommended I talk with with Add-On Cables.   Add-On engineers indicated they've been trying to solve this since Oct-2012 with no solution as of yet.

                     

                    How about I send you guys my HP cables ?   Perhaps the Intel Engineers can figure this ?

                     

                    Right now, I can't connect my Intel Servers to the HP switch, so I'm guessing I'll have to send back the Intel 10G cards and get HP ones ?

                     

                    Suggestions ?

                     

                    Sigh...

                     

                    Phil

                    • 7. Re: X520-DA2 issues with HP2910al / J9008A 10GB
                      mark_h_@intel

                      Hi Phil,

                      Intel has already tested HP cables like you have, and those cables will not work with our adapters because of the identification issues that I wrote about in my previous post. However, my understanding is that some HP-branded cables will work with the Intel(R) Ethernet adapters. If you go to one of the places that sells cables, they might be able to sell you an HP cable that will work with the Intel Ethernet adapters.If you want to use the Intel adapters, you will definitely need different cables.

                       

                      Mark H

                      • 8. Re: X520-DA2 issues with HP2910al / J9008A 10GB
                        Phil Stiller

                        Is it possible to use a LC-Fiber Transceiver SFP+  and fiber patch cable ?   ie. HP transceiver on the HP switch and Intel transceiver on the NIC.

                         

                        Also, Addon Cables couldn't supply a solution, so I'm open to any suggestions on who in the US might be an alternative.

                         

                        Phil

                        • 9. Re: X520-DA2 issues with HP2910al / J9008A 10GB
                          mark_h_@intel

                          Yes, you could go with fiber. The Direct Attach NIC you have is the same NIC you get when you buy the opical module versions. The only difference is that the Direct Attach NIC did not come with an optical module installed.

                           

                          On the Intel end you need Intel® Ethernet SFP+ Optics. I assume you can put in a matching HP module on your switch.Then all you need is an MMF cable rated for 10 GHz. You will need an LC connector on the Intel end of the cable.

                           

                          Mark H

                          • 10. Re: X520-DA2 issues with HP2910al / J9008A 10GB
                            DavidDionne

                            Hey guys, sorry to **** in but I have a DA2 with supported intel SR optics and I haven't been able to resolve the following error...and i've given it both barrels.  Any words of wisdom or encouragement?

                             

                            ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 2.0.44-k2

                            ixgbe: Copyright (c) 1999-2010 Intel Corporation.

                            ixgbe 0000:0e:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17

                            ixgbe 0000:0e:00.0: setting latency timer to 64

                            ixgbe 0000:0e:00.0: failed to initialize because an unsupported SFP+ module type was detected.

                            Reload the driver after installing a supported module.

                            ixgbe 0000:0e:00.0: PCI INT A disabled

                            ixgbe 0000:0e:00.1: PCI INT B -> GSI 18 (level, low) -> IRQ 18

                            ixgbe 0000:0e:00.1: setting latency timer to 64

                            ixgbe 0000:0e:00.1: failed to initialize because an unsupported SFP+ module type was detected.

                            Reload the driver after installing a supported module.

                            ixgbe 0000:0e:00.1: PCI INT B disabled

                            ixgbe 0000:17:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19

                            ixgbe 0000:17:00.0: setting latency timer to 64

                            ixgbe 0000:17:00.0: failed to initialize because an unsupported SFP+ module type was detected.

                            Reload the driver after installing a supported module.

                            ixgbe 0000:17:00.0: PCI INT A disabled

                            ixgbe 0000:17:00.1: PCI INT B -> GSI 16 (level, low) -> IRQ 16

                            ixgbe 0000:17:00.1: setting latency timer to 64

                            ixgbe 0000:17:00.1: failed to initialize because an unsupported SFP+ module type was detected.

                            Reload the driver after installing a supported module.

                            ixgbe 0000:17:00.1: PCI INT B disabled

                            ixgbe: Unknown parameter `allow_unsupported_sfp'

                            -bash-4.1#