1 Reply Latest reply on Feb 18, 2013 11:33 PM by parsec

    Solid State Drive Toolbox  Issue

    Rick Baragar

      I recently installed an intel 330 SSD, yes i am having some issues more on that later.

       

      I downloaded and installed the Intel Solid State Drive Toolbox, no issues on installation.  However when i start the application it looks at the drive and comes back with certain information, Drive Size, make and model and the serial number along with drive usage information.  Then promptl throws  this pop-up  Selected drive Disconnected with this message "The Intel SSD Toolbox is having trouble communicating with the selected drive. The Intel SSD Toolbox is now rescanning the system to get an updated drive list."   Click OK to continue.  When I click ok It terminates the application.  What's up with that??  What do i need to do to fix thisthing?

       

      I have an EVGA 780i SLI mainboard

      8 gigs ram

      twin 9800 gtx sli cards

       

      If there is any other information I need to send in please let me know.  Really want to get this fixed.

       

      I do have the drive Freeze issue as well but working on one issue at at time here.

        • 1. Re: Solid State Drive Toolbox  Issue
          parsec

          Your problem is fairly well known, but very little to nothing can be done about it. The issue is the Nvidia SATA chipset used on your board. Nvidia tried to enter the CPU support chipset business, but failed and quit that side of the PC business. They also ended all support for those products, as in no new drivers, not even fixes. The mother board manufactures that used these chips also provide little to no support for them.

           

          Nvidia SATA chipsets (SATA II support at most) and the Nvidia drivers are known to set the SATA interface speed of SATA III SSDs, to SATA I speeds. The driver apparently cannot recognize a SATA III drive, so sets it to SATA I speed. That happens will all SATA III SSDs. The drivers also don't support the AHCI SATA mode, which is necessary for the best performance from any SSD, as well providing modern drive features and the latest SATA protocols. Using a SSD on your board basically cripples its performance.

           

          The bottom line is, the SSD Toolbox will most likely not work with your mother board. If you are using Windows 7, you can try to use the native msahci driver, but that requires you can set the SATA mode to AHCI in the BIOS. Most boards using your chipset cannot do that. Frankly, the Nvidia SATA chipsets are considered obsolete due to the lack of manufacture support, and all the problems they have.

           

          The only true fix is a new mother board, sorry to say.