10 Replies Latest reply on Apr 7, 2013 10:41 AM by Bzzz

    Error 10 @ Wifi Link 5300 and 6300

    Bzzz

      Hi,

       

      I'm a little fed up with the Windows (XP/2003/7) drivers for the current Wifilinks. I get an yellow marking and error 10 in the device management, so the cards won't do anything. Well, it could be faulty cards or a faulty adapter/slot, but everything works well (and out of the box!) in an Ubuntu 12.10 Live-CD or normal Ubuntu installation. So the problem is the crappy Windows driver that somehow disables the card because it was told to do so. I have no idea why, but maybe Intel likes to offend people that don't just buy a rig and never modify it until they throw it away.

       

      System build 1:

      Asrock 970 Extreme3 board, 1x8GB Kingston DDR3-1333, AMD AM3 Dualcore, PCIe x1 2.0 slot for the card

      mPCIe-to-PCIe adapter from eBay, includes three wifi antennas

       

      System build 2:

      Lenovo Thinkpad T400, 4+2 GB Adata+Samsung, everything else stock, except for the whitelist removal a few months ago

      * Slot 1 is for WLAN and was not affected by the whitelist problem at all. Both cards worked fine even before hacking the device

      * Slot 2 is for WUSB and never worked with the Wifilinks before or after

      * same for Slot 3, WWAN

       

      Affected cards:

      Wifilink 5300 (not Lenovo-branded, no FRU, no engineering sample or the like) from my Thinkpad

      Wifilink 6300 from eBay, also not branded, no FRU, no eng sample

       

      Before you need to ask:

      * No, newer or older drivers do not fix the problem

      * No, disabling/enabling or uninstall/reinstall doesn't help

      * No, Microsoft Fixit from the page for error 10 doesn't help

      * No, I don't know if Fixit really does re-install the driver, as Intel drivers use some awful MSI container format that I cannot open and extract the necessary files for Windows to pick up or to modify myself

      * No, the Intel diagnosis tool from the extended driver package doesn't help, it stops at the first section (hardware test) and states that the wireless hardware isn't connected to the transport driver

      * No, the driver-only package doesn't even install, it shows the oh-so-nice symbol with green dots flashing around, and stops after two minutes doing so. The full package installs everything except BT drivers and the Enterprise features, both lead to "not found" messages and installer termination

      * No, the pin 20 trick doesn't work. But even if it did, that cannot be a serious answer

       

      * Yes, installing the latest 15.x drivers (that are called 14.x when running the automated driver search from this website) also totally crashed my current solution of a Netgear WGR111v2 wifi adapter. Thanks for that

      * Yes, Linux works out-of-the-box for all configurations and rfkill doesn't show hardblock or softblock. It just works as it should

       

       

      So, any suggestions how to make standard hardware work in standard systems? Any advice or patched installer is appreciated.

        • 1. Re: Error 10 @ Wifi Link 5300 and 6300
          joe_intel

          Thank you very much for your post,

          On regards to your question, please note that the Intel® wireless adapters are meant to be professionally installed by Original Equipment Manufacturer (OEM) technicians on certified systems only.

          Please also note that these adapters are not meant to be sold separately, your system must be compliant with the required FCC certifications in compliance with the International Special Committee for Radio Interference standards for radiated and conducted electromagnetic interference.

          In this case what we recommend and encourage you to first contact the Original Equipment Manufacturer (OEM) to determine if the product is approved for use in your computer.

          For additional information you may refer to:

          Intel® WiFi Products - Upgrade or exchange Intel® wireless adapter hardware

          http://www.intel.com/support/wireless/wlan/sb/CS-006006

           

          Intel® WiFi Products - Why doesn't my laptop recognize my new Intel wireless adapter?

          http://www.intel.com/support/wireless/wlan/sb/CS-031167.htm

           

          Regards,

           

          Joe H.

          • 2. Re: Error 10 @ Wifi Link 5300 and 6300
            Bzzz

            So, you're telling us that Intel Wifi cards are not to be changed by the end-user. How come some Lenovo-branded Intel Wifi cards carry a FRU? "A service part Field Replacement Unit (FRU) is used to replace a defective part installed or attached to your computer." Why does Lenovo even provide detailed instructions how to replace those cards? And why does Lenovo actually sell those cards, if these are "not meant so be sold separately", as you mentioned?

             

            Could you please confirm that this driver issues are because Intel wants it that way for whatever reason, and not because there is an actual problem with the card and/or some compatibility issue or the like?

            • 3. Re: Error 10 @ Wifi Link 5300 and 6300
              joe_intel

              We do not have any control about what the computer manufacturer decides to do regarding the installation of the modules. If the manufacturer does not have the necessary approvals, the party installing the device is responsible for those approvals since the systems (with the specific wireless adapter) need to be compliant with the required FCC certifications as mentioned above.

               

              The computer manufacturer may reserve the use of some wireless adapter models in their systems due to such certifications. We recommend you again to contact the Original Equipment Manufacturer (OEM) to determine if the product is approved to be used in your computer.

               

              Regulatory information regarding hardware installation or upgrade

              http://www.intel.com/support/wireless/wlan/sb/CS-011644.htm

              • 4. Re: Error 10 @ Wifi Link 5300 and 6300
                Bzzz

                Thanks for answering a question I didn't ask.

                I'm still wondering why the cards work out-of-the-box in Linux, but refuse to work in Windows, no matter which driver is installed.

                The computer manufacturer don't block anything, because

                a) the Lenovo system is whitelist-free

                b) no desktop board manufacturer blocks any type of compatible card. I even may test this on my new Asus M597LE R.20, but I bet $10 that there will be a yellow and error 10. But, if that leads to a better driver, I may even ask Asrock and Asus for confirmation that their boards do not block Wifi cards when used with Windows...

                 

                Joe_Intel wrote:

                 

                If the manufacturer does not have the necessary approvals, the party installing the device is responsible for those approvals since the systems (with the specific wireless adapter) need to be compliant with the required FCC certifications as mentioned above.

                I'm pretty sure switching slots in my Lenovo doesn't ruin the FCC label. If I personally guarantee you that the device is FCC-compliant afterwards, will you give me a working driver?

                • 5. Re: Error 10 @ Wifi Link 5300 and 6300
                  joe_intel

                  As part of the WiFi Alliance Intel® is precluded to provide recommendations on unsupported integrations that may not meet the FCC regulations. Keep in mind the system as a whole must be certified WiFi for the specific wireless adapter in use (antennas included).

                   

                  In order to get a driver for the wireless adapter you want to use you will need to contact the computer manufacturer.

                  • 6. Re: Error 10 @ Wifi Link 5300 and 6300
                    Bzzz

                    But I'm contacting the Wifi card manufacturer, as OEMs will get their drivers from there AND tend to cripple adapt them to their proprietary builds. For rig #1, I'm using all generic hardware around this piece of hardware (which has no company name except INTEL printed on it!), so why aren't there any generic drivers?

                     

                    FCC? Thanks for your recommendation, but I don't care. I'm not based in the US, so that does't affect me at all. Maybe CE does. But that is like FCC only required for commercial devices, not for experimental machines or other DIY stuff.

                    • 7. Re: Error 10 @ Wifi Link 5300 and 6300
                      joe_intel

                      For a desktop system the only recommended products are Intel® Centrino® Wireless-N 2200 for Desktop and the Intel® Centrino® Advanced-N 6205 for Desktop. Both for PCI Express (x1) interface.

                      • 8. Re: Error 10 @ Wifi Link 5300 and 6300
                        Bzzz

                        Well, the 6205 isn't available at all, and the 2200 only supports 300 MBit/s (2x2?) and uses some quite ugly external antenna (one might change that for additional cost) Besides that, it is at least 25€ more expensive than a card that is already here, just waiting for re-use. Well, 20€, if one also considers the PCIe-mPCIe adaptor that was also here before that, because of some other testing (which did fine, btw)

                         

                        I understand that Intel wants to sell new stuff, but I have a fully-working card here that is just disabled by some Windows driver madness.

                        • 9. Re: Error 10 @ Wifi Link 5300 and 6300
                          joe_intel

                          I am sorry you feel that way. The two wireless adapters I mentioned above are the only certified adapters to be used with desktop systems.

                          • 10. Re: Error 10 @ Wifi Link 5300 and 6300
                            Bzzz

                            I don't know how to respond. I have a fully working card + adapter, but the whole system is disabled by the driver. What's the Intel way of feeling about this? Yaaay, buy new mid-range hardware and throw the working high-end crap away?