4 Replies Latest reply on Mar 18, 2013 4:35 PM by Fred_Intel

    RSTe Issues on Windows 7- random BSOD (storport.sys, iaStorA.sys)

    Riaan Lourens

      Someone, please help!  I built a new desktop PC (Windows 7 x64) about a two months ago, and for the life of me, I cannot identify the issue with these BSODs.  In total, there has been 16 BSOD occurrences since 12/02/2012.

       

      They box is supposed to a be a 24/7 box, and most of the time its unattended with a VMWare player (ubuntu) instance running on it.  The build itself is:

      - Intel i7 3820

      - Sabertooth x79

      - SeaSonic X750 Gold 750W ATX12V V2.3/EPS

      - G.SKILL Ripjaws Z Series 32GB (4 x 8GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900)

      - 2 x GIGABYTE GV-N670OC-2GD GeForce GTX 670 2GB (SLI'd)

      - Main HDD: Intel 330 SSDSC2CT180A3K5 180GB Solid State Drive

      - Secondary HDD1: Kingston SSD SH103S3

      - 2x Samsung HD204UI

       

      My Asus motherboard drivers are up to date, and the system is not overclocked.  After about a month, I decided to completely re install Windows 7 on a completely separate SSD, and the issue still remains.  I have tried the RSTe drivers listed on the ASUS downloads page, as well as the latest Windows 7 drivers from Intel.  I have talked to Asus support various times with very little success.  They are blaming the "Windows 7 installation", but considering I have installed windows twice of two different hard drives, I disagree.

       

      I have all the dump files if thats needed.  The following is the WinDBG output from the latest BSOD dump, which occurred this morning:

       

      Loading Dump File [C:\Windows\Minidump\020713-35131-01.dmp]

      Mini Kernel Dump File: Only registers and stack trace are available

       

       

      Symbol search path is: SRV*C:\Symbols*http://msdl.microsoft.com/download/symbols

      Executable search path is:

      Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64

      Product: WinNt, suite: TerminalServer SingleUserTS

      Built by: 7601.17944.amd64fre.win7sp1_gdr.120830-0333

      Machine Name:

      Kernel base = 0xfffff800`03015000 PsLoadedModuleList = 0xfffff800`03259670

      Debug session time: Thu Feb  7 06:47:40.953 2013 (UTC - 5:00)

      System Uptime: 2 days 16:21:04.781

      Loading Kernel Symbols

      ...............................................................

      ................................................................

      .................................................

      Loading User Symbols

      Loading unloaded module list

      .....

      *******************************************************************************

      *                                                                             *

      *                        Bugcheck Analysis                                    *

      *                                                                             *

      *******************************************************************************

       

       

      Use !analyze -v to get detailed debugging information.

       

       

      BugCheck D1, {0, 2, 0, fffff88001ef70d2}

       

       

      *** WARNING: Unable to verify timestamp for iaStorA.sys

      *** ERROR: Module load completed but symbols could not be loaded for iaStorA.sys

      Probably caused by : storport.sys ( storport!StorPortNotification+22 )

       

       

      Followup: MachineOwner

      ---------

       

       

      5: kd> !analyze -v

      *******************************************************************************

      *                                                                             *

      *                        Bugcheck Analysis                                    *

      *                                                                             *

      *******************************************************************************

       

       

      DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)

      An attempt was made to access a pageable (or completely invalid) address at an

      interrupt request level (IRQL) that is too high.  This is usually

      caused by drivers using improper addresses.

      If kernel debugger is available get stack backtrace.

      Arguments:

      Arg1: 0000000000000000, memory referenced

      Arg2: 0000000000000002, IRQL

      Arg3: 0000000000000000, value 0 = read operation, 1 = write operation

      Arg4: fffff88001ef70d2, address which referenced memory

       

       

      Debugging Details:

      ------------------

       

       

       

       

      READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800032c3100

      0000000000000000

       

       

      CURRENT_IRQL:  2

       

       

      FAULTING_IP:

      storport!StorPortNotification+22

      fffff880`01ef70d2 488b18          mov     rbx,qword ptr [rax]

       

       

      CUSTOMER_CRASH_COUNT:  1

       

       

      DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

       

       

      BUGCHECK_STR:  0xD1

       

       

      PROCESS_NAME:  System

       

       

      TRAP_FRAME:  fffff880040b18b0 -- (.trap 0xfffff880040b18b0)

      NOTE: The trap frame does not contain all registers.

      Some register values may be zeroed or incorrect.

      rax=0000000000000000 rbx=0000000000000000 rcx=0000000000001003

      rdx=fffffa80336f0000 rsi=0000000000000000 rdi=0000000000000000

      rip=fffff88001ef70d2 rsp=fffff880040b1a40 rbp=fffffa80194ac710

      r8=0000000000000002  r9=0000000000000000 r10=fffffa80336f0000

      r11=fffff880040b1b80 r12=0000000000000000 r13=0000000000000000

      r14=0000000000000000 r15=0000000000000000

      iopl=0         nv up ei ng nz na po nc

      storport!StorPortNotification+0x22:

      fffff880`01ef70d2 488b18          mov     rbx,qword ptr [rax] ds:00000000`00000000=????????????????

      Resetting default scope

       

       

      LAST_CONTROL_TRANSFER:  from fffff80003093569 to fffff80003093fc0

       

       

      STACK_TEXT: 

      fffff880`040b1768 fffff800`03093569 : 00000000`0000000a 00000000`00000000 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx

      fffff880`040b1770 fffff800`030921e0 : fffffa80`21286000 fffff880`063b3c57 00000000`00000000 00000000`00000000 : nt!KiBugCheckDispatch+0x69

      fffff880`040b18b0 fffff880`01ef70d2 : 00000000`00000000 fffffa80`2011f000 fffff880`040b1af0 fffff880`07534172 : nt!KiPageFault+0x260

      fffff880`040b1a40 fffff880`018d3aa8 : 00000000`00000000 fffffa80`336f0000 00000000`00000002 00000000`00000000 : storport!StorPortNotification+0x22

      fffff880`040b1ac0 00000000`00000000 : fffffa80`336f0000 00000000`00000002 00000000`00000000 fffff880`040b1b38 : iaStorA+0x63aa8

       

       

       

       

      STACK_COMMAND:  kb

       

       

      FOLLOWUP_IP:

      storport!StorPortNotification+22

      fffff880`01ef70d2 488b18          mov     rbx,qword ptr [rax]

       

       

      SYMBOL_STACK_INDEX:  3

       

       

      SYMBOL_NAME:  storport!StorPortNotification+22

       

       

      FOLLOWUP_NAME:  MachineOwner

       

       

      MODULE_NAME: storport

       

       

      IMAGE_NAME:  storport.sys

       

       

      DEBUG_FLR_IMAGE_TIMESTAMP:  4d79a55f

       

       

      FAILURE_BUCKET_ID:  X64_0xD1_storport!StorPortNotification+22

       

       

      BUCKET_ID:  X64_0xD1_storport!StorPortNotification+22

       

       

      Followup: MachineOwner

       

      I would be extremely grateful if someone could point me in the direction of a solution to this issue.  If there is additional information that I could provide, please let me know

        • 1. Re: RSTe Issues on Windows 7- random BSOD (storport.sys, iaStorA.sys)
          Latif K

          I have the same issue with an intel DX79SR using samsung SSD's. Random BSOD's with iAstore and storport. Usually takes a day or two for it to happen. I run my system 24/7 as well.

           

          I was able to stop the BSOD's by using the server version of the RAID drivers. This driver does not support TRIM so your SSD's will slow down after a while if you do frequent write/erase cycles. But stability trumps speed at this point while we wait for Intel to fix the RSTe driver.

           

          The version of the driver i am using is: 11.7.0.1013  from 11/19/2012

          and it should show up in DM as "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller"

           

          You will need to force the driver install in DM.

          • 2. Re: RSTe Issues on Windows 7- random BSOD (storport.sys, iaStorA.sys)
            windkarma

            Hello Riaan Lourens,

             

            I also had been suffering from a similar problem to yours, though I use not a Asus's motherboard,

            but GA-X79-UD5.

            I could resolve this problem by version down from v 3.5 to v 3.0 of IRSTe.

            Though I don't know your IRSTe's version, try version down, if  you please.

            • 3. Re: RSTe Issues on Windows 7- random BSOD (storport.sys, iaStorA.sys)
              Philip

              Plz fix this issue Intel! I have the DX79SR aswell and run the config under ahci mode in bios! If i install the irst-e driver 3.5.1.1009 i get bsod in between 2-6h "storport.sys". what i found out is that alot of people have this issue! and i can confirm its not only related to Samsung ssd`s! i have one Intel 520 and one Corsair GT disk and have the same issue. i did a clean install of Windows, ran prime95, memtest86 atc.... no issue with my hardware!

              • 4. Re: RSTe Issues on Windows 7- random BSOD (storport.sys, iaStorA.sys)
                odie bugs

                I suggest you don't install any RST-E drivers, win 7 has a generic AHCI driver,  if you are not running a RAID array then you should be pointing the x79 AHCI to the chipset INF files when in devise MGR under  IDE/ATA/.

                 

                Some people get better performance from the MS driver, some from the Intel Chipset, and some using the RST driver.

                 

                I have extracted the x79 chipset setup.exe, this will then show the drivers/INF flile, I have pointed the controller to this folder and the driver went from a MS to a Intel.

                 

                If this is A RAID array Then the same, leave the iastorV.sys, (MS driver ) or try the RST which will use the iastorA.sys and the iastorF,sys.

                 

                I am guessing you're not running RAID because you would have two drivers installed for the x79 RAID controller.

                 

                 

                If you don't want to use the MS generic then try the - 11.6.1.1001 WHQL, or the
                11.7.1.1001 WHQL.  They contain both AHCI  and RAID drivers/ INF . 


                ***** The part I missed, Asus for the most part is behind,  posting old drivers, they have always done this, some of their top of the line boards have newer ones posted. But what else can you expect from a company that is still using the Marvell 9128, which they know is absolute garbage. 


                You will not find the RST drivers under your board listing on Asus, so here is a link, you can either look at hardware, or can can look at your board which has all its drivers.


                http://www.station-drivers.com/page/intel%20raid.htm


                This is the Intel driver page, just click on drivers on left top to see all hardware or look at Asus then your model.


                If you go to devise MGR and update the MS driver you are not forcing it, because if none of the devise ID's match, it will not update.


                This does not men that if you install one you won't get a BSOD, because windows might not be able to use it.  But as soon as you update, if windows can't, you should get a BSOD right then and not boot.


                If you end up updating to a 11 series driver, then do a fresh install and update once to the driver, and always run windows experience index after all the drivers are installed, important when using a SSD.


                I have the ASRock X79 extreme 7, and have tested every driver there is for the best performance.  This was a while back, not I only run RAID and have the 12 series ROM in my BIOS, using the 12.0.0.1082 driver. But my BIOS has ROM switch so I can use either the RST or RST-E ROM.

                • 5. Re: RSTe Issues on Windows 7- random BSOD (storport.sys, iaStorA.sys)
                  Fernando

                  odie bugs schrieb:

                   

                  I have extracted the x79 chipset setup.exe, this will then show the drivers/INF flile, I have pointed the controller to this folder and the driver went from a MS to a Intel.

                  You are wrong regarding this point.

                  INF files are just information text files and no real drivers. None of the INF files, which are within the Intel(R) INF Update Utility (commonly named Intel Chipset "Drivers"), is able to replace the generic MS AHCI driver. The only thing which may happen is, that the Intel SATA AHCI Controller will be renamed by the INF file. You can easily verify that by opening the "Driver Details" of the Intel SATA Controller.

                  Only a real Intel AHCI driver named iaStor.sys or iaStorA.sys is able to replace the generic MS AHCI driver named msahci.sys (Win7) or storahci.sys (Win8).

                  • 6. Re: RSTe Issues on Windows 7- random BSOD (storport.sys, iaStorA.sys)
                    Fred_Intel

                    Hi all,

                     

                    You can try using this other driver which is the Intel Rapid Storage Technology Software version 11.6.0.1030.  This is the link to the driver http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21860&lang=eng&OSVersion=Windows%207%20%2864-bit%29*&DownloadType=%0A%09%09%09%09%09%09%09Drivers%0A%09%09%09%09%09%09

                     

                    I recommend you uninstall the Intel RSTe from Programs and Features in Control  Panel first and then run the STOR_Win7_8_11.6.0.1030_PV.exe that is in the website.

                     

                    Thanks!