1 Reply Latest reply on Feb 7, 2013 2:47 AM by mwbreur

    Raid problems with DX79TO.

    mwbreur

      Hello,

       

      Recently i have build a system :

       

      Intel DX79TO bios 0460 (will update to 0553) 2/6/13 updated to 0553. (Raid bios 3.5.x...)

      Intel i7-3820

      32GB DDR3

      2 x Patriot Pyro 240GB @ raid1

      2 x WDEARX 2TB @ raid1 <- problems...

      Radeon 7770

      Windows 7 X64, Ultimate fully updated.

       

      The problem keeps coming back, the 2 x WD EARX raid1 setup keeps failing. I already replaced the disk that keeps failing 4 times, replaced the Sata cables and even replaced both disks (Had 40 in stock) but the problem keeps coming back. When i boot up it tells me that the raid is degraded, when i click 'reset to normal' it gives me an error, when i reboot and click 'reset to normal' again it will start rebuilding and sometimes completes but eventually tells me the raid is degraded again, this all can happen on the same day.

      Also tried creating the raid in the raid bios and in windows using Intel Rapid storage technology enterprise tool.

       

      Also tried different ports, using different power cables and a different power supply (Antec earthwatts 650 and Tagan 1000 watts, spare psu for Xeon system) etc.

       

      Also shutting down windows doesn't work, i have to press the power button to make it shut down. When the WD2TB raid config is deleted the system shuts down normally.

      Already reinstalled windows several times to no avail.

       

      The 2 Patriot Pyro drives show no problems at all, they are both connected to the blue sata ports not once has this raid1 setup failed.

       

      To test the systems stability i've used:

      passmark Burnin test 7.?

      3dmark11

      PCmark7

      Superpi

       

      AS SSD and Crystalmark purely for SSD testing.

       

      Since i've seen an issue before with WD disks and problems with raid controllers before i checked if there were any known issues but there aren't.

       

      I use a Supermicro X7DAE system myself, also using Intels raid controller and i've never had any issues with this system whatsoever.

      The DX79TO system would replace this 6 year old Dual Xeon X5450 machine.. but i think i'll stick this old beast for now.

       

       

      If anyone has any suggestions i'm open for ideas.

        • 1. Re: Raid problems with DX79TO.
          Victor_Intel

          Hello Michiel,

           

          Usually those hard drives work fine with our controllers but you may get in to a compatibility problem and have random crashes of the RAID like yours.

           

          Please go in to BIOS and under the SATA configuration set a hard drive delay, this will allow the hard drives a larger amount of time to initialize and spin up.


          If the problem keep occurring then I would suggest to test with different hard drives and test the motherboard out of the chassis to confirm that this is not related to a short or grounding.


          Regards.

          • 2. Re: Raid problems with DX79TO.
            mwbreur

            Hello Victor,

             

             

            I already tested the board with only the cpu/memory/vga/psu and the SSD/HD's with different power supplies (Antec 650 Earthpower Platinum and a Tagan 1000 watts which is the spare for my X7DAE system).

             

            Even then the problem still occurs, i will try the harddrive delay tonight, however i thought that was only for booting the system. If i use the drives without raid1 there's no problem whatsoever with the drives, but when a raid1 config is cerated it's always the second drive that keeps failing.

            When the raid is degraded and i click 'reset drive to normal' it gives me an error and i have to restart to make that option work. When it does work it goes into 'rebuild mode' and eventually tells me the drive has failed again.

             

            The 2 WD 2TB drives are connected on Sata Port 2 and 3 (Black ports). The Patriot Pyro SE 240GB x 2 @ raid1 on Sata Port 0 and 1 (blue ports) work perfectly.

             

            I use the exact same drives in my Supermicro X7DAE (Socket 771/DDR2FBdimm - Dual Xeon X5450) setup which also has an older raid controller and they work perfectly there. I believe this is a X5000 chipset that also has the Intel raid (raid bios looks exactly the same).

             

            I also had contact with Intel Tech support, he told me i probably should send the board back for checking, but i'd like to make sure it's not a user error.

             

            Secondly i've tried installing Windows 7 X64 Ultimate when i created a raid1 config in the raid bios and tried it afterwards when in windows using the RTSE tool. This didn't make any difference.

             

            Since i had problems with WD drives and a Highpoint controller before i was thinking this could be an incompatibility issue between the drives and the 'raid controller', however i couldn't find anything similar on the web nor Intel communities.


            Service Ticket (8000614093) for reference


            Once i tried the Hard drive delay i will post my findins.


            Kind regards,


            M.