1 2 Previous Next 10 Replies Latest reply on Mar 27, 2013 5:40 PM by Ruben Ramos

    UEFI Boot

    Romain Wilbert

      Hi !

       

      The BIOS options let me think that UEFI boot is handled by the DC3217IYE NUC.

       

      So I tried to install windows in UEFI mode, after unticking the "legacy boot" checkbox, and  following instructions here : UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with

       

      But when I boot the NUC with the usb device plugged, it says that it doesn't find any bootable device.

       

      Any idea ?

        • 1. Re: UEFI Boot
          joe_intel

          This is rare as I got Windows 8 installed with UEFI enabled and Legacy boot enabled or disabled in model DC3217IYE and BIOS version 0036. However, I did not create any special partition for the small drive I was using.

           

          Please note Windows 8 will not boot when using a different UEFI/Legacy boot settings than the ones used during the Operating System installation; in other words, it is not possible to boot if either option is changed after installation.

           

          If this is not the case then please verify the boot order in BIOS or with F10; otherwise provide the partition type, drive capacity and BIOS version.

           

           

          Joe H.

          • 2. Re: UEFI Boot
            Ken

            good info.

             

            it seems like fixing this anomaly should be on the list for the next bios update.

             

            thanks

             

            ken

            • 3. Re: UEFI Boot
              joe_intel

              Let me rephrase it.

               

              Windows 8 was booting up with the Legacy boot option either enabled or disabled. Basically, the operating system will not boot if those settings are different from what they were initially during the installation, otherwise, it has to be reinstalled again with the desired settings or change them back to what they were before.

               

              Since this is an expected behavior there is no need (or way) to solve it via BIOS update.

               

              Regards,

              Joe H.

              • 4. Re: UEFI Boot
                Romain Wilbert

                I think I was not clear.

                 

                When I untick the legacy checkbox, I can't even boot on my usb key as it is not recognized, and there are not any bootable device when I press F10 key.

                 

                When I tick the legacy checkbox, I can boot from the usb key and install Windows, but not in UEFI mode.

                 

                I have the latest BIOS 0036, I use a FAT32 formatted 16gb usb key which is bootable with windows installation files on it.

                • 5. Re: UEFI Boot
                  joe_intel

                  We were able to replicate the issue with BIOS version 0036. By disabling Legacy boot we were only able to boot from Windows 8 using a USB drive but not from Windows 7 or a Linux* portable distribution. As you stated before, the drive does not appear as a bootable device. We got Windows 7 installer to boot with Legacy boot option enabled.

                   

                  Thanks for the feedback; we will pass this information to Engineering and let you know once we get an update.

                  • 6. Re: UEFI Boot
                    joe_intel

                    I verified with engineering this is an expected behavior. Legacy boot is there to support older operating systems without having to disable UEFI.

                     

                    I was able to install Windows 8 with UEFI enabled and Legacy boot option either enabled or disabled so the cause of the issue must be something else.

                    • 7. Re: UEFI Boot
                      Romain Wilbert

                      How do you manage to install Windows 8 without the legacy boot option enable ?

                       

                      I made a bootable usb key with Windows 8 installation files on it, but I am not able to boot with UEFI enabled & legacy boot disabled as no bootable device is found at startup.

                       

                      This happens with both FAT32 & NTFS formatted usb key.

                       

                      If I enable legacy boot, then I can boot from the usb key but Windows is not installed in UEFI mode.

                      • 8. Re: UEFI Boot
                        joe_intel

                        With Legacy boot option enabled I got 2 options from the USB Windows 8 installer:

                         

                        • UEFI: USB: KingstonDT… PART 0: OS Bootloader…
                        • USB: KingstonDT… PART 0: Boot Drive…

                         

                        With Legacy boot option disabled only one of them appeared. I believe is the first option (UEFI) if I remember correctly. If it does not boot from it formatting the SSD may help. Otherwise it could be related to the drive or the Windows installer.

                         

                        The USB installer I used was already created so I do not know what tool was used but you may try with this one:

                        http://www.microsoftstore.com/store/msstore/html/pbPage.Help_Win7_usbdvd_dwnTool

                        • 9. Re: UEFI Boot
                          Romain Wilbert

                          I can't see my usb key as an UEFI boot device. Still no bootable device when I disable legacy boot option.

                           

                          Is there any special spec or thing to do for the usb key to be recognized as an UEFI bootable device ?

                           

                          I use this usb key : Store 'n' Go� Car Audio USB Drive: Everyday USB Drives - USB Drives | Verbatim

                          • 10. Re: UEFI Boot
                            Ken

                            did you install a bootloader to your usb stick?

                             

                            i use Clover bootloader and with the right drivers in the right folders, it is seen as a UEFI device in my NUC.

                             

                            ken

                            • 11. Re: UEFI Boot
                              Romain Wilbert

                              Hi Ken,

                               

                              I don't understand why I would have to do this. Furthermore, I can't install any bootloader to my usb stick because when I create the bootable usb drive with Windows installation files, it does format the stick just before copying the files on it.

                              • 12. Re: UEFI Boot
                                Ken

                                romain--i am fairly new to UEFI booting, but i have successfully done it (loading "another" OS!) on an MSI 7-series mobo.  i started with a USB stick that is loaded with a UEFI bootloader.  i boots properly (UEFI) from the usb, and then i went on to install the booter to my HD and it, too boots UEFI.

                                 

                                when i use that USB stick on the NUC, choosing both UEFI and Legacy options, there are two entries for the USB stick on the right-hand side of the F2 menu--UEFI usb stick and   USB stick.

                                 

                                i just prepared a USB installer for win 7 professional using another PC which is running win 7.  i inserted that USB in the NUC, and with both UEFI and legacy options chosen, F2 shows only one boot choice:  USB installer.  there is not a second choice for UEFI: USB installer.

                                 

                                my assumption therefore is that the Win7 USB installer program (the "download" utility from MS that loads a windows .iso onto a usb stick) DOESN'T load the proper file(s) to enable UEFI booting.  while it may be a NUC problem, it likely isn't.  someone who knows more about UEFI booting can probably suggest a way to write the proper file(s) to the usb installer stick to enable UEFI booting.

                                 

                                my issue with the NUC bios is that it doesn't allow booting from a thunderbolt drive.  hopefully that is on the list of bios enhancements for the future.

                                ken

                                1 of 1 people found this helpful
                                • 13. Re: UEFI Boot
                                  Romain Wilbert

                                  Still can't boot in UEFI mode from the usb key. I followed this tutorial but still no bootable device when unticking legacy mode...

                                  UEFI Bootable USB Flash Drive - Create in Windows

                                  • 14. Re: UEFI Boot
                                    gmanny

                                    I'm having the same issue.

                                     

                                    The difference is, I'm using USB DVD drive with Windows 8 ISO from MSDN. This combination of disk and drive was is working perfectly with other UEFI-capable motherboards, but NUC just doesn't see it as UEFI device.

                                     

                                    I've loaded defaults and tried many different settings, but to no avail. I've noticed, that when I turn Legacy USB option off, USB drive disappears.

                                     

                                    I'm using the latest 0039 bios. NUC is the model DC3217BY with thunderbolt.

                                     

                                    When it will be fixed?

                                    1 2 Previous Next