4 Replies Latest reply on Jan 31, 2013 8:20 AM by markinzeroland

    Intel(R) ICH8R/ICH9R/ICH10R/DO/PCH SATA RAID Controller Driver Updates

    markinzeroland


      Hi,

       

      I recently set up a RAID1 partition on a Dell XPS420 with 64-Bit Windows 7 verion 6.1.7601.1.0.66304 with SP1. Ever since Windows Update has failed to work. The most common error in my WindowsUpdate.log file is "DtaStor FATAL: Failed to initialize datastore, error = 0xC8000247." The following is the Report.txt output created by the Intel Matrix Storage Console:

       

      System Information

      Kit Installed: 8.9.0.1023
      Kit Install History: 8.9.0.1023, Uninstall
      Shell Version: 8.9.0.1023

      OS Name: Microsoft Windows 7 Home Premium
      OS Version: 6.1.7601 Service Pack 1 Build 7601
      System Name: FAMILY-PC
      System Manufacturer: Dell Inc.
      System Model: 0TP406
      Processor: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
      BIOS Version/Date: Dell Inc. A07, 02/25/2009

      Language: ENU

       

      Intel(R) Matrix Storage Manager

      Intel RAID Controller: Intel(R) ICH8R/ICH9R/ICH10R/DO/PCH SATA RAID Controller
      Number of Serial ATA ports: 6

      RAID Option ROM Version: 7.6.1.1001
      Driver Version: 8.9.0.1023
      RAID Plug-In Version: 8.9.0.1023
      Language Resource Version of the RAID Plug-In: 8.9.0.1023
      Create Volume Wizard Version: 8.9.0.1023
      Language Resource Version of the Create Volume Wizard: 8.9.0.1023
      Create Volume from Existing Hard Drive Wizard Version: 8.9.0.1023
      Language Resource Version of the Create Volume from Existing Hard Drive Wizard: 8.9.0.1023
      Modify Volume Wizard Version: 8.9.0.1023
      Language Resource Version of the Modify Volume Wizard: 8.9.0.1023
      Delete Volume Wizard Version: 8.9.0.1023
      Language Resource Version of the Delete Volume Wizard: 8.9.0.1023
      ISDI Library Version: 8.9.0.1023
      Event Monitor User Notification Tool Version: 8.9.0.1023
      Language Resource Version of the Event Monitor User Notification Tool: 8.9.0.1023
      Event Monitor Version: 8.9.0.1023

      Array_0000
      Status: No active migrations
      Hard Drive Data Cache Enabled: Yes
      Size: 1863 GB
      Free Space: 0 GB
      Number of Hard Drives: 2
      Hard Drive Member 1: ST1000DM003-9YN162
      Hard Drive Member 2: ST1000DM003-9YN162
      Number of Volumes: 1
      Volume Member 1: Volume_0000

      Volume_0000
      Status: Normal
      System Volume: Yes
      Volume Write-Back Cache Enabled: No
      RAID Level: RAID 1 (mirroring)
      Size: 931.5 GB
      Physical Sector Size: 3072 Bytes
      Logical Sector Size: 512 Bytes
      Number of Hard Drives: 2
      Hard Drive Member 1: ST1000DM003-9YN162
      Hard Drive Member 2: ST1000DM003-9YN162
      Parent Array: Array_0000

       

      My understanding is that this is a known bug and that updated drivers could fix the problem but I'm having trouble finding the right ones. Any help locating them would be appreciated.

       

      Regards,

       

      Mark