2 Replies Latest reply on Jun 21, 2009 12:21 PM by maddogcr

    iflash - looking for "undocumented" command line switch

    jtandrews3

      I have a motherboard from the now out of business company VPR Matrix, of Best Buy.  I have an issue that needs a BIOS update, at least, according to Windows.  Occasionally, the PC will just restart, unprovoked.  Oh, I have a D845PEBT2.

       

      Since VPR Matrix is out of business, they don't provide BIOS updates beyond version P04.  I want Intel's P10.  I need to find a way to force the update by changing the BIOS ID from 31T to 86A.

       

      I tried the /@ command line switch on iflash, but it didn't work.

      I also tried taking the CMOS battery out, unplugging power, disconnecting the BIOS jumper, waiting, and had the BIOS update on a floppy in the drive when I powered it back up.

       

      They have their BIOS as secure as Fort Knox (as if there really was any gold there).  They made it nearly impossible to change the BIOS from the VPR branded Intel motherboard back to just Intel.

       

      Are there any undocumented iflash.exe command line switches I can use?  Or is there another utility that I can use to flash the BIOS?

       

      Thanks,

      JT

        • 1. Re: iflash - looking for "undocumented" command line switch
          maddogcr

          I just turned my VPR Matrix bios into Intel! I did much research as you may have. My problem was, on a large drive, out of nowhere I got the "cannot read Disk" error. The Intel Bios fixed this. Here is how I did it:

          1. Go to Intel website and download the achived bios. 2. Make a floppy disk for version 1 (achive says ver 8 but the download gives you all previous versions)

          3. Turn off computer and disconnect every external device (Mouse, keyboard. Monitor. power etc. There is no monitor function when doing recovery method). 4 Open computer and remove bios jumper for bios recovery. 5. Insert floppy disk that you made with version 1 on it ( I tried this method with version 10 and it would not work!) 6. Plug in power only and boot off the disk (bios should be set to boot off floppy before you do any of this), the system will force a bios recovery to the intel bios. When the flash is complete you will hear 2 beeps which means your recovery was sucessful. 7. replace the jumper, reconnect all devices and boot into bios by pressing F2. You will see the intel version 1 has installed. 8. Now make a floppy with the intel version 10 and boot off it like a normal flash. 9. verify that version 10 is installed and enjoy your INTEL Bios!

           

               A day after I had sucess, I remembered your post with no replys and it was fairly recent. So I found your post, created an account so I could help you and others with this old VPR Matrix problem. My HD booted right to windows instead of "cannot read disk" and is much faster than before.

          GOOD LUCK!

          • 2. Re: iflash - looking for "undocumented" command line switch
            maddogcr

            IMPORTANT!! After reviewing the updated bios, I realized that it now has SATA Raid but the boards I have flashed this way come with IDE Raid. So If you use the IDE Raid this may not be a good thing to do. This is where I got info that helped me flash my board. A different model board but a good guideline.http://www.techsupportforum.com/hardware-support/motherboards-bios-cpu/225653-flash-gateway-bios-intel-version.html