3 Replies Latest reply on May 10, 2009 9:16 AM by rbailin

    DG45ID Won't Boot After Bios Upgrade (77 to 93)

    JPH

      I have just wasted most of my Saturday on this one, so I thought I would share it and hopefully save some people some time!

      1) Built a PC based on DG45ID board, Intel Core2 Quad CPU Q8200, 2*Samsung HD642JJ HDDs and 2 Sony DVD RW 2*Corsair "Gb RAM

      2) Installed Vista Ultimate - totally hassle free (I have always used Xp before this)

      3) Installed all driver updates from Express CD (All out of date - earlier Express CDs would check via internet (if poss) and offer latest drivers - much better idea!)

      4) Played around with it quite impressed - realised Bios was quite old and decided to upgrade it.

      5) Used the Express Bios - saw the warning not to use this method upgrading from 79 - but it appeared to work fine, although it seems to take soooo long I thought it had hung.

      6) Rebooted and it said "Boot Failure, press any key to continue"

      7) After much messing I found that the system would boot from the HDD IF I left the Vista install disk in the CD drive and let it time out from the "Press any key to boot from CD/DVD" message.

      8) Tried all fixes I could find on the net. All to no avail. Tnen I changed the boot order in the BIOS from the original

           CD/DVD drive

           Floppy Drive (WHY is this here if the board doesn't support floppy drives? For the ZIP drive floppy emulation?)

           Hard Disc Drive

      to

           Hard Disk Drive

           CD/DVD drive

           Floppy Drive.

      and this fixed it!!

       

      It looks to me like the new Bios cannot handle RAID 1 HDDs booting after 2 empty SATA CD Drives.

      Hard Drives are in SATA Ports 1 and 2 and the CD?DVD drives are in ports 3 & 4. (The SATA port positions/numbers on the case label supplied with the board are wrong)

       

      Also, with the RAID enabled and configured the "Drives" section of the Bios reports a SINGLE hard drive Volume in SATA port 1, (even though the drives are in 1 and 2) and the Sony CD Drives in Ports 2 & 3 (P3: Sony DVD RW DRU-860S P4: Sony DVD RW DRU-860S) and a non existant DVD in port 4 (Sony DVD RW D ATAPI)

       

      I hope this helps other people to save a bit of time and some Intel people to get this put right.

       

      JPH

        • 1. Re: DG45ID Won't Boot After Bios Upgrade (77 to 93)
          Aryan2411

          Hi there,

           

          Thank for the post.

           

          I will explain to you why you have received this error message "Boot Failure, press any key to continue".

           

          It is not a problem at all, it is normal behaviour.

           

          When you are doing a BIOS Update by any method (Recovery, Iflash, ISO, Express), the bios is restored to default if done succesfully.

           

          The error message "Boot Failure, press any key to continue" indicates that there is no boot device, it cannot find a bootable media to load the system.

           

          What happened?
          ===============
          When the bios is restored to defaults, some settings like:
          Advanced >> Drive Configuration >> Configure SATA as will be reset to IDE. (if it was raid or ahci, it will be reset to IDE)

           

          Boot >> Boot Device Priority >> settings will be reset to defaults.
          CD/DVD Rom Drive
          Floppy Drive
          Hard Drive

           

          So since the boot drive priority has changed, it is looking for a bootable media on the cd drive which is first on the list.


          Of course, if you insert a bootable vista cd, it will boot onto the drive.

           

          If nothing found, it will look if there is any bootable media in the floppy drive (Note: Usb Floppy drive still are available - this is why it is in the bios settings)

           

          If nothing found again, it will look on the drive.Then it displays the error message.

           

          This is why after upgrading a bios, if you had a raid on the drives, make sure to reconfigure the settings in the bios.
          Configure SATA as RAID
          Change the Boot Device Priority.

          Check your raid configuration using the Ctrl + I to go onto the raid bios.

          Check on the BIOS release notes: http://downloadmirror.intel.com/17547/eng/ID_0093_ReleaseNotes.pdf

           

          Hope this helps a bit.

           

          Thanks again for the post.

           

          Regards,
          Aryan.

          • 2. Re: DG45ID Won't Boot After Bios Upgrade (77 to 93)
            JPH

            Hi Aryan,

             

            Whilst I appreciate your post and your effort to assist, what you say is, although correct, not the issue.  Unfortunately I have been away all week and only just seen your reply. I will go through the problems again - please read all of it:-

             

            1) I built the PC and set the bios for RAID1 Mirrored

             

            2) Installed Vista SP1 and Drivers - so far so good.

             

            3) Updated bios

             

            4) Reset bios from default IDE to RAID ( I fully understand it hasn't got a cat in hells chance of booting if set to IDE)

             

            5) DOES NOT BOOT WITH STANDARD BOOT ORDER CD/DVD Rom Drive, Floppy Drive, Hard Drive

            I agree it cannot see a boot device - but it SHOULD

             

            6) If you put the Vista CD in one of the CD drivers and restart then it sees the bootable CD and asks you to press any key if you want to boot from it. If you ignore it,  it then times out and BOOTS FROM THE HARD DRIVE.  Why can it only boot from the hard drive if you have a bootable CD in the CD Drive??

             

            7) I changed the boot order to Hard Drive, CD/DVD Rom Drive, Floppy Drive and it boots onto the hard drive faultlessly.

             

            8) The bios is incorrectly reporting the devices on the SATA ports (And the SATA port numbers on the board don't sgree with the sticker and neither agree with the bios (Is this normal?)

             

            9) The raid volume (two physical disks, physically wired to Sata Ports 1 & 2) is reported in the bios as being attached to only SATA Port 1.

             

            10) The 2 CD drives are wired to SATA ports 3 & 4 - yet the Bios reports them as being on ports 2 & 3 (Thus OVERLAPPING with the HDDS)

             

            11) The bios only PARTIALLY shows the name of the CD on Port 4.

             

            12) I would be willing to wager a sum of money that there is a problem with the bios and would appreciate it if you would actually check what I am reporting to you as a problem.

             

            Sorry if I seem tetchy, but I spent time resolving this issue, time reporting it to you and as a degree qualified engineer who has been building PCs for industrial applications based on Intel manufactured motherboards since 386 days I get cross when I don't think my point is being taken seriously. Sloppyness like the SATA port numbers not agreeing between the board/documentation and bios can easily be avoided.

            • 3. Re: DG45ID Won't Boot After Bios Upgrade (77 to 93)
              rbailin

              It's normal when using RAID1 (or other RAIDs for that matter) for the RAID volume to appear in place of whatever hard drives comprise it.

              All RAID controllers, not just Intel's, present the RAID array to the system BIOS instead of the individual drives. There's no way to access

              the individual drives in the RAID except thru the RAID BIOS.

               

              This is why you see Raid1 as the first (and only) drive on the drive configuration screen. Further, if you have any other SATA drives

              (HD or CD/DVD), they are remapped from their original port to the lowest available port on the drive configuation screen. If you have

              multiple additional drives, this could get confusing, but it's normal.

               

              Bob