1 Reply Latest reply on Jan 20, 2013 5:19 PM by Imanol

    DP965LT skips certain boot devices

    Imanol

      Hi, I've bought this motherboard, the DP965LT because my old one died.

       

      It's great, I love it, but i've found an issue, it skips certain devices during boot even though they are detected by the BIOS, if I go to BIOS setup they are listed correctly, and selecting them manually using F10 leads to the same result: The motherboard ignores the drive and proceeds with booting the rest of devices.

       

      The devices from which the motherboard refuses to boot are a 320 GB WD HDD and a 16 GB Kingston DataTraveler3 USB flash drive.

       

      I've tried:

       

      • Removing all the other devices except the one I'm trying to boot from (obviously)
      • Trying SATA mode Legacy and Native (Both IDE and AHCI) (Only for the WD drive)
      • Trying different bootloaders (even though the same bootloaders work from other devices)
      • Booting the same devices in other computers (both boot OK from other computers)
      • Updating BIOS to latest version (Now it has BIOS version 1761, which is the latest)ip

       

      None of that works and I don't know what to do or try next.

       

      I can boot the drives if I install grub on another hard drive and boot it from there, but don't like this workaround (though I could go with that since I have 3 HDD's and at least one of them works with grub)

       

      Any suggestions? Thanks for your attention.

        • 1. Re: DP965LT skips certain boot devices
          Imanol

          OK, I've solved it, I feel pretty stupid though:

           

          Both the drive and the USB key were missing a primary bootable partition, they had primary partitions of course, but were missing the bootable flag.

           

          Even though all my other systems boot both the USB and the HDD without having a partition marked as bootable, I really don't care as I can boot them somehow.

           

          I hope someone finds this useful or something.