5 Replies Latest reply on Mar 18, 2013 7:05 PM by Schrand

    NUC Wake-on-LAN problem

    Schrand

      Hi,

       

      The NUC is sold as being able to use Wake-on-LAN from S5.

      However, it looks like Wake-on-LAN is not working on my NUC, at least not from S5.

      My config:

      • DC3217IYE - version G80097-101 - batch CNG62BO103 - date of manufacture 24NOV2012
      • mSATA: Crucial m4 128GB
      • RAM: 2x4GB Corsair Vengeance DDR3 CMSX8GX3M2A1600C9
      • No wireless adapter
      • BIOS: version 36 (latest available today)
      • Switch: DLink DGS1005D (but tried two different switches as well)
      • OS: Windows 8 Pro 64bit fully patched
      • Intel INV install 9.3.0.1026_PV
      • LAN drivers Intel PROWin v17.4 (e1c63x64.sys v12.2.45.0)
      • Connected to a Philips 32PFL7675H TV via the HDMI port closest to the USB connections (other HDMI port not used).

       

      Whatever setting I try in both the BIOS and LAN adapter properties under Windows, wake-on-LAN will not work.

      Also loading BIOS setup defaults did not help.

      Immediately after shutting down the NUC the ethernet connector lights go off on the LAN connector and switch (and these should of course stay on for Wake-on-LAN to work).

       

      Note that while working under Windows 8 I do not have the LAN drop or performance issues already reported in this community.

       

      Is there anybody with a working Wake-on-LAN on a NUC?

        • 1. Re: NUC Wake-on-LAN problem
          Kyle McDaniel

          No issues reported on my DC3217IYE NUC. Running a headless NUC for a web server. All traffic passing through a Dell powerconnect 2724, using Jimmy's Magic Packet to wake up all my boxes. Win7x64 driver version: 12.2.45.0

          1 of 1 people found this helpful
          • 2. Re: NUC Wake-on-LAN problem
            Mariusz

            Hi,

            My NUC have also problem with Wake-on-LAN.

            In BIOS Onboard LAN MAC Address is displayed as FF:FF:FF:FF:FF:FF

            PLS Help!!!

            • 3. Re: NUC Wake-on-LAN problem
              Schrand

              It might be that I have found the cause of my Wake-on-LAN problem: apparently Wake-on-LAN from S5 (system powered off completely) is not supported anymore in Windows 8 

              See: Wake-on-LAN behavior in Windows 8

              It states: "Network adapters are explicitly not armed for Wake-On-LAN in both the classic shutdown (S5) and hybrid shutdown (S4) cases because users expect zero power consumption and battery drain in the shutdown state."

              So, apparently Windows 8 is only aimed at home usage, and not at professional usage? Very strange...

              But my solution now is to leave the NUC in standby (S3). Wake-on-LAN works OK in that case from Windows 8.

              • 4. Re: NUC Wake-on-LAN problem
                Schrand

                While using the solution as described above (putting the NUC in S3) WOL indeed is working,  but I have another problem: the wireless keyboard (Logitech diNovo) that I am using with the NUC stops working when the system comes out of S3; I have to disconnect and reconnect the USB bluetooth receiver or reboot the system to get it working again. So in the end this was not an acceptable solution.

                 

                Some more testing learned me that the WOL from S5 not working problem in Windows 8 is related to the new Windows 8 fast startup feature (hybrid shutdown).

                And it appeared that there is another problem with Windows 8 and the fast startup feature: startup and shutdown scripts are not properly run as well when it is enabled.

                The fast startup feature is enabled by default in Windows 8, but the good news is that when the Windows 8 fast startup feature is disabled both WOL and the scripts are working OK with my NUC.

                And the startup and shutdown times are only a few seconds more for my NUC than when the fast startup option is enabled.

                So in the end it looks like it is best to disable fast startup in Windows 8 in an environment where WOL and startup/shutdown scripts are required.