0 Replies Latest reply on Jan 18, 2013 5:09 AM by Fernando Luiz Chaves

    S1200BTLR with Digium X100P PCI Card

    Fernando Luiz Chaves



      I'm mounting a VoIP Server with Asterisk in CentOS 6 and two Digium hardware cards:

      - 1 AEX800 PCI-Express x1 for 8 FXS (8 analog phone output)

      - 1 X100P PCI Card with 1 FXO (1 phone line input)


      The AEX800 PCI-e works fine, but I'm in trouble with the X100P PCI.


      When loading the "wcfxo" (the DAHDI kernel module for X100P), causes a Kernel Panic.

      This is surely a S1200BTLR specific issue, since I've used this card in a BUNCH of other computers without trouble.


      What I have tryed:

      - Another brand-new X100P. Same thing.

      - In desktop computers: M4A88T-M, GA-945GCM-S2C, Striker II Formula, and others everything works fine.

      - Disabling/Enabling things in BIOS setup, such as VT-d, Turbo boost, and others. Same thing.

      - Reporting to DAHDI drivers developers. WON'T FIX: "...This doesn't look like it's one of ours." See  https://issues.asterisk.org/jira/browse/DAHLIN-311



      S1200BTLR + 1270v2 + 4x KVR1333D3E9S/4G + 750W PSU


      My kernel crash dump:

      S1200BTLR with X100P kernel crash - Pastebin.com


      Just to complement, the following Linux OS have been tested without sucess:

      Archlinux with kernel 3.5 32-bit, CentOS 6.3 64-bit, Ubuntu 12.10 32-bit, Fedora 17 64-bit.


      There are any known chipset incompatibility with certain PCI devices in this board?