6 Replies Latest reply on Jan 24, 2013 8:56 PM by lemurian

    DZ77BH-55K - brand new MB - Bios upgrade Question

    lemurian

      Hello,

       

      I just bought a brand new Intel® Desktop Board DZ77BH-55K for a new build, and I see its manufacture date is back in April so it must be an older bios?...and because of all the bios updates since then, I assume I should upgrade my bios too?..since there was so many things fixed since April.

       

      I've read so many customers having flashed their bios only to end up breaking it and having to return the MB - please I don't want that to happen and I want to do it right the first time!  I don't know what they did wrong, or was it the fault of the engineers?...I don't know.

       

      I have not even installed the MB yet, it's never been used, and so my question is:

       

      What Is The Best, Safest, Most Productive Way To Upgrade The Bios of a brand new MB that has never been used, iow, should I install the OS first and then do it, or before the install - I'll do it whatever whichever way is best.  I don't want to break this board!

       

      Technician suggestions please.

       

      Thank you very much.

        • 1. Re: DZ77BH-55K - brand new MB - Bios upgrade Question
          Dan_Intel

          Hello lemurian,

           

          These are our recommendations:

           

          1. We only recommend updating the motherboard BIOS if your system is experiencing issues. If your system is running fine there is no need to update the BIOS.

           

          2. In case you need to update the BIOS, we recommend using the recovery update BIOS which is the safest method to follow:

           

          Desktop Boards — BIOS update instructions

           

          3. We also recommend updating the BIOS gradually if there are many BIOS versions in between the original version on the board and the latest one.

          1 of 1 people found this helpful
          • 2. Re: DZ77BH-55K - brand new MB - Bios upgrade Question
            lemurian

            Thanks for the reply Dan, I will post back later with a few more questions please.

            • 3. Re: DZ77BH-55K - brand new MB - Bios upgrade Question
              lemurian

              Okay I will use the update recovery BIOS method then.

              I have a few more questions please:

               

              1.  As to your #3 to updating the BIOS gradually on this DZ77BH-55K,

              This board has many bios updates available...

              ...how gradually should I do it if these are my options listed below:

              0057  -  2/8/2012  (bios that came with the board)

              0070  -  4/16/2012

              0083   - 7/26//2012

              0085  -  8/9//2012

              0091  -  9/21//2012

              0093  -  10/26//2012

              0094  -  11/1//2012

              0096  -  12/19//2012

              0097  -  12/28//2012

              I was thinking to go to 0085, and then to 0093, and then to 0097...

              ...is that a good spread?  ..or would you choose something different?

               

              2.  I have two memory sticks (2x4GB) are Corsair 1600, is it okay if I leave them in the blue slots or would it be better to move them to the black slots while I flash?

               

              3.  should I use the back USB2 ports to flash instead of the blue USB3 ports?

               

              4.  I will have nothing inserted in any PCI slots, and will use the onboard i7-3770K graphics.

               

              .... these last three questions I read that it mattered, and is why I asked to be sure.

               

              I'm being very careful because I want to succeed in flashing this bios current, and I will follow all good advice to make sure I have the best chance of success, and I appreciate the good advice very much.

               

              Thank You

              • 4. Re: DZ77BH-55K - brand new MB - Bios upgrade Question
                Dan_Intel

                Hi lemurian,

                 

                Here are the answers to your questions:

                 

                1. Yes that BIOS update path should work just fine (0085, 0093, and 0097).

                2. You can leave the memory in the blue slots.

                3. Any of the ports disregarding if they are USB2 or USB3 will work fine and should be detected properly during the update.

                 

                You are very welcome.


                1 of 1 people found this helpful
                • 5. Re: DZ77BH-55K - brand new MB - Bios upgrade Question
                  Shaun

                  Flash 0085 first, then you can go right to the latest 0097

                  I always use the windows based installer, never had an issue!

                  • 6. Re: DZ77BH-55K - brand new MB - Bios upgrade Question
                    lemurian

                    Hello Dan, and thank you for coming back to my post again.


                    Well I have some very good news.


                    The next day after I had posted my previous post but before you answered it today, I had decided to just go ahead a do it, and the bottom line is that it all worked just fine in less than two minutes.

                    . . . . . . .


                    My setup at flash time was, and since I had the K series MB with the i7 K processor I already had working video, and so there was no other PCI slots occupied yet, and I left the (2x4) GB RAM in the blue slots, and booted with a new Win7 install but with no motherboard driver updates installed yet or anything else, just a fresh install default. On purpose also I never changed any bios settings within the original .0057 bios and left it set default from the factory; but I did make note of all settings (actually I snapped pictures of every setting just for reference)

                     

                    I used the method you linked for Recovery BIOS Update and using the USB method.  I used a USB 2 port on the back panel since the front panel USB 3 ports were not working, yet.

                     

                    ~Put a single BH0097.BIO file on an empty USB stick with it plugged into a back USB 2 back panel port.

                     

                    ~Shut off the computer


                    ~Removed the BIOS Configuration Jumper


                    ~Turned on the computer not having to press any buttons or do anything! 
                    ...and within seconds watched on the monitor as a series of information was being listed as the process continued, just like it shows on that links screenshot of the monitor. I even used my camera to record the process just for reference, but it was just like the screenshot shows on that link.


                    ~Within a minute it was done, every listing said success, and so I turned off the computer, put the jumper back in and booted her up, and everything was fine...and then rebooting back into the bios checking out the new visual bios gui was nice, but was also pleased I could put it back into classic mode if I wanted. And so afterall it was just a simple bios flash success for me, ymmv.


                    The only thing to mention just for tidbit sake, is that I noticed before the flash the bios under the tab of Configuration> Chipset DATA Mode - the default 0057 bios had it set to AHCI, but after the flash it was changed to SATA, and in one instance that change caused the computer not to boot and go into a repair screen, however once set back to ACHI it then booted fine.  I say in one instance only because I had more than one board and did them all, all of then went fine except for that one instance but was easily corrected and so just thought I'd mention this in case it helped someone else. And even a lesser significance is that I noticed the 0057 under the tab of Boot> UEFI Boot - it was first listed as disabled, but the 0097 set it enabled.


                    Oh, and one thing I did do different though if you haven't noticed the clue yet from the name of my .BIO file above, that what I did was to flash straight from .0057 right up to the latest .0097 ...thankfully that worked just fine for me. ymmv.  I read a few others did it that way too, but I'm sure you had valid reasons for advising me to go in steps though and I respect those...just curious about that, did someone else have problems and doing it in steps worked better for them?


                    ps, the front panel USB 3 ports on this board were non-functional until I specifically installed the Renesas Electronics USB 3.0 Driver, that's why I used the rear ports for the flash. Actually the LAN and other things didn't work either, until after I installed all the MB drivers - but that was to be expected.


                    Thank you for your support Dan, I appreciate it.