5 Replies Latest reply on Dec 7, 2010 9:55 AM by

    [Linux,S5000PSLSAS board] HDD problem

    Lego_12239

      Hi, everybody.

       

      I have Debian 4.0r4a installation on a S5000PSLSAS motherboard powered server with SAS1064E controller:

       

      ~$ lspci | grep LSI
      04:00.0 SCSI storage controller: LSI Logic / Symbios Logic SAS1064E PCI-Express Fusi
      on-MPT SAS (rev 02)

       

      ~$ uname -a
      Linux ftp 2.6.28.7-aufs #10 Fri Mar 6 19:34:56 UTC 2009 i686 GNU/Linux

       

      There are six sata hard disks connected through SAS HDD Hub box to the controller on the motherboard
      by two sata cables. Everything work all right, but dmesg shows many lines like
      this:

       

      [ 1876.212880] mptscsih: ioc0: attempting task abort! (sc=f6ff1c80)
      [ 1876.212953] sd 8:0:5:0: [sdh] CDB: Write(10): 2a 00 17 42 ee 0f 00 04 00 00
      [ 1876.213635] mptscsih: ioc0: task abort: SUCCESS (sc=f6ff1c80)
      [ 1876.213973] mptscsih: ioc0: attempting task abort! (sc=d1fc18c0)
      [ 1876.214046] sd 8:0:5:0: [sdh] CDB: Read(10): 28 00 17 10 c0 3f 00 00 08 00
      [ 1876.214727] mptscsih: ioc0: task abort: SUCCESS (sc=d1fc18c0)
      [ 1876.215081] mptscsih: ioc0: attempting target reset! (sc=d1fc1ec0)
      [ 1876.215154] sd 8:0:5:0: [sdh] CDB: Write(10): 2a 00 17 42 b1 ff 00 04 00 00
      [ 1877.735588] mptscsih: ioc0: target reset: SUCCESS (sc=d1fc1ec0)

       

      sdh is a sata Western Digital disk, model WD10EADS.

       

      Can anybody help me identify a problem?

       

      Thanks.

        • 1. Re: [Linux,S5000PSLSAS board] HDD problem
          herbert_intel

          Could be some sort of compatiblity problem with the SAS HUB and the drive.

          does the problem only happen with this sdh drive? have you by any change tried to swap the position of one of the other drives around just to see if it follows the drive?


          These motherbaords provide a firmware update utility for the onboard sas controller. this can be downloaded from here.

          Its an update done via EFI but its pretty straight forwards (just make sure you run the correct nsh script. i think it should be slsasupd.nsh for the s5000pslsas board).

           

          OJ

          1 of 1 people found this helpful
          • 2. Re: [Linux,S5000PSLSAS board] HDD problem
            Lego_12239

            Earlier I saw similar dmesg messages for other drives in the box. So, I didn't try to swap drives.

             

            Now, after I have read the lkml archive, I think that this is a firmware issue. I will try to update firmware as soon as possible.

             

            I know how I can update firmware, but I don't know how I can backup the old one. Do you have any experience of negative results of update?

             

            Thank you for reply :-)!

            • 3. Re: [Linux,S5000PSLSAS board] HDD problem
              herbert_intel

              Never had a problem with it. I've updated a few of these boards.

              THe only thing to look out for is that this firmware update script will try to update ALL hardware revision of the SAS controller but the update will only update your specific revision. you may see some error messages sayng that the controller doesn't match and whatnot but it'll be fine.

               

              OJ

              1 of 1 people found this helpful
              • 4. Re: [Linux,S5000PSLSAS board] HDD problem
                Lego_12239

                Many thanks for this information! It sets my mind at rest :-).

                • 5. Re: [Linux,S5000PSLSAS board] HDD problem

                  Hello!

                  I have exactly the same problem, except for hdd's are  WDC WD2500AAKS. Tried with different kernels, latest one was 2.6.36.1.

                  With some other hdd's this does not happen. Also swapped hdd's order in expansion bay, but nothing changes.

                  With SAS hdd's also work fine.