10 Replies Latest reply: Nov 21, 2013 6:38 AM by blueocjiro RSS

Problems with Intel Centrino Wireless-N + WiMAX 6150 device

Edward Boning Community Member
Currently Being Moderated

Hello,

 

I have an Asus U56E laptop running Windows 7 that I purchased last year. It is equipped with an Intel Centrino Wireless-N + WiMax 6150 wireless device. Recently I've begun to lose connection to my wireless router at random intervals while other computers on the network remain connected. The connection will report that it has limited connectivity. After disconnecting from the access point, the wireless device will not show any available connections. When I try to disable and re-enable the device in the network adapter settings or the device manager, the process hangs up indefinitely. On occasional boots, the device will show up in the device manager with a status of "This device cannot start (Code 10)". Also of note, the device seems to appear twice in the device manager, once as a generic "Network Controller" and once as "Intel Centrino Wireless N + WiMAX 6150". When I run driver installations, it is the former device which the drivers install as the Intel Centrino Wireless-N 6150.

 

So far I have tried reinstalling the device drivers using the latest drivers from the Intel site, as well as the drivers hosted by Asus on the page for my laptop. I've done this multiple times with no discernible results. I have also adjusted the Power Management setting to disallow windows from disabling the device to save power. I have also tried disabling 802.11n mode in the driver settings.

 

Any suggestions or solutions that worked on similar problems? I'm beginning to think the device may be broken and in need of replacement.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points