1 2 3 Previous Next 36 Replies Latest reply on Mar 3, 2015 2:27 AM by Mretep

    Intel RAID 5 kicked 2 of my drives out! Help please!

    cdickinson66

      I have an ASUS P5Q motherboard with onboard Intel RAID chipset.

      I have 4 1.5TB drives that I succesfully made into a RAID5 configuration and populated with data.

      After installing a new video card and rebooting the Intel Storage Matrix kicked out 2 of the 4 drives on my RAID and they show up below as non-raid members. While the RAID shows 2 drives missing! The boot drive is on a separte IDE bus so the only other drives connected are the 4 sata drives that I am talking about.

       

      How can I get these guys back onto the RAID5?

      The software does allow me to do anything. This is very important data to me and I donot have an extra 4.5 TB to image the drives onto for recovery.

      The drives are all new and work perfectly, I have not touched them since so I know the data is all still there. Also they are still plugged into the same ports on the Motherboard so order is kept good.

       

      Please help

       

      -Charles

        • 1. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
          cdickinson66

          Anyone have any suggestions to this problem? I can't be the only one who woke up one day to this happening automaticly without any reason.

           

          I got this response from Intel

           

          The problem is if the RAID structure is being reported as "Failed". Technically your data is still there, but if the RAID 5 volume status is “failed” we do not have tools to recover it.

          Since the hard drives appear to be working fine, try the following steps to see if we can change the RAID status from “Failed” to “Degraded”.

          - Turn off the computer.
          - Connect each hard drive to a different SATA port.
          - Turn on the computer and verify if the RAID status changes.

           

          This isn't really a solution, and doesn't really make any sense. If I mix up the order of the drives then none will be reconized.

          It seems like there must be a way to rebuild the structure of the array. I mean the recovery software can all do it so why isn't this feature built in to the Intel Software Matrix Manager. The main problem with the recovery software is that I would need an additional 4.5TB of empty space to recover an image to.

           

          Intel are you out there? Can you help with your own software?

           

          Thanks

           

          Charles

          • 2. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
            Elizabeth

            Hi, Charles.

             

            You're right. That suggestion won't really have an impact on your issue. If a RAID drive turned into a non-RAID drive (meaning something happened to the data on the drive that marked it as a member of a RAID volume), I don't know of any way to turn it into a RAID drive again without re-creating the array.

             

            We've gotten a few similar reports in Intel Support of drives going from RAID to non-RAID but, no matter what we try, we have never managed to recreate the issue here so we can investigate. It's very frustrating for us - and I can only imagine how you feel. We don't have recovery software that I can suggest to you.

             

            I have been thinking about this issue and pondering something .. I'm wondering what would happen if I created a RAID 5 volume, marked all the drives as non-RAID, and then created that same RAID 5 volume again using the OROM. I believe that both of those actions only adds/removes the RAID data at the end of the drive (volume type, size ..), nothing else. If that's true, and if the data on the drives was the same before/after, could I still access my data?

             

            I'll see if I can set up a system to test this out on Monday and let you know what happens. Not sure I'd recommend that you try it -- unless you have a spare system to try it out on. And maybe someone else has tried this idea before and can comment.

             

            ,,elizabeth

            • 3. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
              cdickinson66

              Thanks Elizabeth,

               

              Did you have a chance to try and reproduce the error today? Any progess?

               

              -Charles

              • 4. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                Elizabeth

                Hi, Charles.

                 

                I just tried my idea. Did not work. Don't try it.

                 

                The only thing I can suggest - and you may have tried this already - is to power down your system, unplug those drives, give it 30 minutes or so, plug them back in, power on your system, and see if the drives are recognized again. I remembered that someone reported a similar issue last year - and when they did that, the drives showed up as RAID drives again.

                 

                But I don't know of any way to force the driver to recognize the drives as part of the RAID volume.

                • 5. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                  donatello

                  What make/model drives are you using in the RAID array?  I'm not saying your drives are the problem, but I recently asked a question about HDDs and whether or not they have TLER/ERC/CCTL and how the drives that do have this function react with Intel's bios RAID.  You could try posting over at ARS in the Other Hardware section to see if anyone there can help with a solution.

                  • 6. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                    cdickinson66

                    I am using Seagate 1.5 TB drives. Not sure the model numbers but I will look them up and list them if you like.

                     

                    -Charles

                    • 7. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                      donatello

                      Please list the model number as I'll be able to determine whether or not they have TLER / ERC / CCTL...can't remember which one Seagate uses.  Thanks.

                      • 8. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                        adgriffi

                        Not sure if you're still looking for a solution to this... but I had the same problem and got it resolved:

                         

                        Ok, so when I went to bed everything was fine. This morning, I move the mouse, and the screen doesn't come back on. So, I use the power button to shut off the system. Turn it back on, and still nothing. I repeat this a bunch of times, reseat the video card, etc. Nothing.

                         

                        Time to reset the CMOS settings. After doing this, finally the monitor comes on -- but it loads into the EZ-FLASH recovery bios system telling me my bios is corrupted and do I want to try to recover. Why yes, I do! After going through that process, my computer appears to be working again -- but Windows tells me it failed to recover from hibernation. Maybe this is what caused the whole problem in the first place?

                         

                        Now onto the more serious problem. I have a separate drive for the OS, so Windows loads -- but the disk manager in Windows tells me my RAID 5 drive is not initialized, even though it DOES tell me the size of it properly. Hmm.

                         

                        Reboot, go into BIOS settings, realizing that due to BIOS being reset the motherboard has the SATA setting as IDE instead of RAID. So I switch it to RAID, save, exit, reboot. This time the Intel Matrix Storage reports to me that the RAID 5 is in a FAILED state. I have 4 drives in the RAID -- and now TWO show as members, and TWO show as "non-Raid". Not good. Not good at all.

                         

                        Why does the Intel Matrix Storage think that two of the drives are no longer members of the RAID array?? And how can I add them back in without destroying everything?? I mean, all the data is still there. None of that has changed.

                         

                        In searching around, I found this: http://forums.extremeoverclocking.com/showpost.php?p=3329132

                         

                        Any idea if it will work?

                         

                        Is there a better solution? Can I take the drives somewhere to have the data recovered? Why can't the Intel driver just rebuild the partition data without destroying the actual data?

                         

                        What is the next step I should take?

                         

                        Please help!

                         

                        UPDATE:

                        I followed the steps in the post from extreme overclocking above and it all worked!!

                         

                        1) Go into the Intel Matrix Storage Manager in BIOS.

                         

                        2) Mark all the drives in the RAID as "non-Raid." This warns you that all your data will be lost, but really is simply re-writing the partition table, which is ALREADY messed up anyhow...

                         

                        3) Re-Create the RAID using the SAME settings as the original RAID that you are trying to recover. Disks must be in the same order as before, and the strip size must be the same as before. Note: Having the disks in the wrong order will not destroy your data, it will just mean that step (4) will not work... If (4) doesn't work, you will need to repeat steps 1-3 until you have the disks in the proper order...

                         

                        4) Once the RAID has been re-created, get TestDisk from http://www.cgsecurity.org/

                         

                        5) Follow the Step-By-Step directions for TestDisk: http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

                         

                        6) If all goes well, you will simply have to reboot and all will be better!

                         

                        NOTE: My OS drive was seperate from my RAID drive, so I didn't have to mess with the MBR -- I could still boot into Windows just fine, it's just that my RAID wasn't there. IF your OS is on your RAID drive, I would suggest using the DOS version of TestDisk, and if your computer won't boot after fixing the RAID you should use your Windows Install DVD (or whatever MBR fixer your prefer) to repair the MBR.

                         

                        Good luck! Oh... and BACKUP YOUR DATA!!! :-)

                        • 9. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                          Elizabeth

                          adgriffi:

                           

                          This is fantastic! Thank you so much for sharing this information with the community.

                          • 10. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                            cdickinson66

                            Ok Thanks!

                             

                            I will try this procedure later on tonight and report back.

                             

                            -Charles

                            • 11. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                              adgriffi

                              Yeah, I hope it works for you! I know for me it worked because none of the data on the drives was actually bad... just the meta-data defining the RAID and the partion table.

                               

                              If the drives themselves are bad, it may require more extensive repair operations...

                               

                              Good luck!

                              • 12. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                                ErikL

                                Wow!  What timing!  Last Sunday after rebooting from a blackout, my PC became very unstable after restart.  Nothing would run, I couldn't even press START (Win XP MCE 2005).  I didn't have the Windows Recovery Console installed from the XP CD, so I put in the XP MCE disk 1 and the Intel RAID Install floppy, and tried to run it from there.  I suspect this is what removed the RAID metadata from one of the two drives.  I thought I lost it all (I hadn't backed up in over 6 months), but this fixed it!

                                 

                                One more thing deserves mentioning:  be sure to use DiskTools from an OS that understands Intel's RAID system.  I tried at first to use it from a Linux system restore CD, and it refused to restore the partition table on the first drive as it said the drive wasn't 640GB (obviously it wasn't, but the two together were!).

                                 

                                I went out and bought a new HD to re-install the OS (with the two RAID drives detached), then re-attached the RAID drives (picking them in the right order the first time was lucky), deleted and rebuilt the RAID with the BIOS utility (ignoring Intel's warning all data would be lost) then ran DiskTools from Windows letting it restore the partition table it found, then rebooted.  During the reboot, Windows repaired many issues with the file system, but the RAID 0 set was then seen again!  I also bought a UPS system so blackouts won't corrupt my system in the future.

                                 

                                Okay, now for my rant:

                                 

                                Intel needs to take the time to build a restore CD (or better yet, a utility to backup RAID metadata to a bootable USB key)!  DiskTool was written by one person.  You can't tell me Intel can't afford to have a small team of programmers work on this for a month.  Just saying "back up your data, and rebuild everything when this happens" is just not acceptable from a company the size of Intel -- especially when the fix is so simple!

                                • 13. Re: Intel RAID 5 kicked 2 of my drives out! Help please!

                                  Hey it worked!

                                   

                                  Thanks so much for posted this solution. This is a big developpment in  Raid recovery!

                                  Yes Intel, please program this into the storage manager! It should be trival to implement this.

                                   

                                  Thnaks Again, I will try to help spread the word.

                                   

                                  -Charles

                                  • 14. Re: Intel RAID 5 kicked 2 of my drives out! Help please!
                                    mdovey

                                    This has just happened to me two. In my case, I'd not been doing anything unusual such as adding hardware. However, on starting the computer it failed to boot listing two disks as not being part of the raid.

                                     

                                    Booting off an external disk, and examining the disks no longer in the RAID it looks as if something (the RAID driver/controller) has zeroed out the initial sector of the disk (which is presumedly where the controller stores information about the disks membership of the RAID volume). Presumedly if there is some technical information about the structure of the RAID information stored there, it would be fairly easy to rewrite this data to recover the disks?

                                     

                                    Given that this has happened to a few people now, I hope Intel can address the problem - or at the very least provide a means of repairing, backing up and restoring the RAID information stored on the disks via the BIOS utility (as a workaround).

                                     

                                    My problem is further complicated by the fact that I had two RAID volume sets on the same 4 disks (a bootable 102Gb RAID 10, and a 2.7TB RAID5) - mainly because the RAID controller didn't allow any volume larger than 2TB to be bootable. I don't know (yet) if the approach outlined above also works in this scenario.

                                     

                                    Matthew

                                    1 2 3 Previous Next