9 Replies Latest reply on Dec 26, 2012 6:48 AM by rbfowler9

    S2400SC2 and P4308XXMHGC fans at 100% all the time

    rbfowler9

      My server has an Intel S2400SC2 Motherboard in an Intel P408XXMHGC chassis with 2 Intel E5-2430 Xeon CPUs with 8x Intel certified KVR1333D3D4R9S/8GI Kingston RAM modules with a single SATA hard drive, and whatever configuration I set on the BIOS regarding power profile (performance/power) and acoustic management, I get the 5 SYSFAN fans running at 100% all the time. I've updated to the latest firmware

      01.06.0002, updated FRU/SDR and even then I can't get to slow those fans down. Temperatures are all within limits on Intel ASC, any suggestion on why I'm having fans at full speed?

        • 1. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
          edwardzh

          First check if the fans are connected to the correct fan headers. Since you have redundant cooling, you should connect System Fan headers 2, 3, 4 and 5. Also make sure the 5-pin PMBus cable is connected. If then fans are still running at 100%, check SEL for errors.

          1 of 1 people found this helpful
          • 2. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
            rbfowler9

            Hi Edward,

             

            Checked what you said, PMBus is correctly connected, and fans 1 to 5 are connected to System Fan headers 1 to 5, respectively. Only System Fan 6 header is left unconnected.

             

            Last time, I updated the f/w with package S2400SC_BIOS01060002_ME020105107_BMC0116r4010_FRUSDR0108.zip, which installed System BIOS - 01.06.0002, ME Firmware - 02.01.05.107, BMC Firmware - 01.16.r4010, FRUSDR - 1.08. I chose to update both FRU and SDR data (option 3), entered chassi S/N and P/N, then rebooted to my previously-installed Windows 7 Ultimate 64bit.

             

            Upon accessing ASC, it informs me that P1 and P2 VRD HOT have been tripped, but that seems clearly mistaken as the processors heat sinks are cool to touch. It reports no memory and fan errors, however fan speeds are all to the 8000-rpm range. Processors' temperature do not exceed 35ºC.

             

            I noticed that both PSUs rear fan are also running at full throttle. Is it some software or firmware update that I'm missing, or maybe do I have a corrupted BMC?

             

            Thanks,

            Cláudio

            • 3. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
              rbfowler9

              Well, additional information. BIOS is configured as follows:

               

              Under System Acoustic and Performance Configuration:

              Set Throttle Mode = AUTO

              Altitude = 300m or less (we're at sea level)

              Set Fan Profile = ACOUSTIC

              PWM Offset = 0

              Quiet Fan Idle Mode = DISABLED


              Under Power and Performance:

              CPU Power & Performance Policy = POWER


              Lately I've downloaded the UEFI SEL Viewer, and I found out that something really uncommon is happening to the redundant fan array, and I suspect that's why the chassis fans are always at 100%, but still doesn't explain why the PSUs fan are also at 100%. It seems that Fan 4 keeps connecting and disconnecting ad eternum, raising SEL event 0x41 (Fan 4 Present) upon disconnection, which in turn raises event 0xC (Fan Redundancy), only to a few milliseconds later have another event 0x41 raised, and finally another event 0xC resuming the fan redundancy operation.

               

              Here's a link to a saved log: Dropbox - fan4-5.sel - Simplify your life

               

              After that, I reviewed and re-checked all fan and PSU connections, everything is firmly attached and connected. System fans are also individually spinning perfectly.

               

              Any further tips?

               

              Thanks,

              Cláudio

              • 4. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
                edwardzh

                Swap fans, or connect Sys Fan 4 and 5 to other fan headers and see if the issue goes with the fan.

                • 5. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
                  rbfowler9

                  Swapped fans with other "good" fans like 1 and 2, and the issue persists. The fans themselves appear to be working correctly. I'm wondering if the chassi hot-swap fan backplate isn't the culprit. I have assembled another system exactly equal to this last week and haven't had any of these issues.

                   

                  Is there any way I can test the board to make sure at least it is OK? If I run FRUSDR with just fans 1-2-3 connected it will detect only these fans, will it then consider "normal" usage if only these 3 fans are connected, or it will keep boosting the fans because the full set of 5 is not completely present?

                  • 6. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
                    edwardzh

                    Try to swap the fan headers, i.e. connect fans 4&5 to fan header 1&2.

                    • 7. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
                      rbfowler9

                      Well, swapping the fan headers didn't do any good. Physical fan #4 connected to fan header 1 works flawlessy, and any other physical fan connected to fan headers 4 or 5 keeps getting connected and disconnected immediately.

                       

                      Ultimately, I had to RMA the board. Since then, no fan disconnection issues so far.

                      • 8. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
                        edwardzh

                        OK so it's a single board failure. Thanks for sharing the result.

                        • 9. Re: S2400SC2 and P4308XXMHGC fans at 100% all the time
                          rbfowler9

                          Exactly. Thanks for the help! =)