2 Replies Latest reply on Dec 23, 2012 7:39 PM by saltgrass

    3 Gb/s instead of 6 Gb/s transfer rate with Intel 520 SSD

    Simon P

      Hello,

       

      I have an Intel 520 80Gb SSD drive.

       

      If I look at advanced info in the Intel Rapid Storage Technology program, it says my transfer rate is 3 Gb/s, and I confirmed this using ATTO disk benchmark, as I'm getting read rates capped at 250Mb/s.

       

      I'm running Windows 7 64-bit on an Asus P8Z68-VPro motherboard, and Intel i5 2500k.

       

      I have installed all chipset and sata drivers, as well as the latest BIOS and the latest firmware to the SSD (using Intel SSD Toolbox).

      I'm also 100% sure that the drive is connected to the correct SATA-port, it is listed as connected to the first SATA3-port in the bios.

      AHCI mode is turned on in BIOS.

       

      I can't find anything that causes the slower rate, and have come here looking for help

       

      Thank you

        • 1. Re: 3 Gb/s instead of 6 Gb/s transfer rate with Intel 520 SSD
          parsec

          First, the 520 SSD is not sold in an 80GB capacity, 60GB,120GB, 180GB, 240GB, and 480GB only.

           

          IRST is usually very accurate determining the SATA transfer rate, as it will correctly show that a SATA 6Gb/s SSD, when connected to a SATA II port, is operating at 3Gb/s. My 520's all show 6Gb/s, with the latest or earlier version of IRST, when connected to the Intel SATA 6Gb/s ports.

           

          On your board, the two Intel SATA 6Gb/s are the gray ports, and the four SATA 3Gb/s ports are blue. You don't have your 520 connected to your boards Marvell ports, as they would not appear in the IRST UI.

           

          So, was that a typo about your SSD, and are you certain you are connected to the gray Intel SATA III ports?

          • 2. Re: 3 Gb/s instead of 6 Gb/s transfer rate with Intel 520 SSD
            saltgrass

            That board has 4 sets of 2 ports.  The first set, closest to the processor are the Marvell E1/2 ports.  The next set is the Intel 6 GB ports and the last 2 sets are the 3 GB ports.  Which is about the same as parsec mentions.

             

            So you would need to connect the drive to a connector next to the navy blue ones, or second set from the processor.  It sounds like you have the correct port since it is the first port shown on that bios page.

             

            But transfer speeds can be deceiving.  The other day I transferred a file from a SATA III SSD to another SATA III SSD and got a 409 MB/s transfer rate.  When transferring to or from a SATA II drive, and a SATA III drive, I will get around 125-95 MB/s.  And there are different types of numbers associated with different types of operations.  Where are you getting the 250 Mb/s read speed and what type of operation are you doing?