7 Replies Latest reply on Mar 18, 2013 4:12 PM by Victor_Intel

    DH77EB bios setup not loading after update

    okeribok

      I updated the bios on my DH77EB from 0053 to 0097, because I was getting SMBios not found errors. After the update (F7 style) the BIOS setup application would not load, instead showing a black area with the white text "loading BIOS setup application...". Because of that, I downgraded the BIOS to 0096 by means of the motherboard jumper. Then reset the CMOS, then downgraded to 0093, but still not BIOS setup.

           Anybody have any tips?

        • 1. Re: DH77EB bios setup not loading after update
          scan80269

          What CPU are you using with your DH77EB?  I recently attempted to update the BIOS on a couple of DH77EB boards from 0053 to 0097, and both boards could not boot afterwards.  I had a Core i7-3770K CPU installed, which I finally discovered was related to the boards failing after what appeared to be successful updates.

           

          Flashing from 0053 directly to 0097 seems to bring about so many changes as to make it risky.  It may be better if you can flash back to 0053, to see if the BIOS setup works again, then gradually flash forward with incremental BIOS revisions.  Another tip: after completing a BIOS flash, disconnect the board from the power supply, pull the 3V coin battery from the board and wait several minutes before reversing the steps.

           

          I am only guessing here, but I suspect the differences in Intel ME firmware revisions accompanying the different BIOS releases may have to do with board not behaving properly after a BIOS update.

           

          My two DH77EB boards that won't boot after flashing to 0097 BIOS had to be restored by extraordinary means that I won't go into here.

          1 of 1 people found this helpful
          • 2. Re: DH77EB bios setup not loading after update
            okeribok

            I am using a vanilla, non-K 3770. I managed to go to 0071 and decided to stay there for the moment. Though it might be worth the trouble to go one step higher and trying the battery-trick.

            So I guess I am lucky that my board boots at all after all the flashing I did! I did 12 flashes in total, ending up with going step by step from 0053 to 0071.

             

            One issue I am looking to solve by updating the Bios is that I can only boot from the msata ssd by explicitly selecting it in the boot menu, not by setting the boot order in setup. Another is that I am getting SMBios not found when using UEFI boot.

            • 3. Re: DH77EB bios setup not loading after update
              poit57

              I have 2 computers using this motherboard. I updated both to BIOS version 0099 a few weeks ago and haven't noticed any issues. Last night I replaced my  OCZ Agility 3 SSD in my HTPC with an mSATA drive because the case is too small and I just had the previous drive stuck to the inside of the case with double-stick tape.

               

              All went well with the imaging, but when I tried to enter bios to make sure my boot order is set up properly, my computer reboots every time I press F2. I can pull up the boot menu with F10 no problem. My computer boots to the correct drive, but I'm still concerned that I cannot enter BIOS setup to make any changes. I did not have this issue last week on my other computer when I entered the setup to change from AHCI to RAID.

              • 4. Re: DH77EB bios setup not loading after update
                Victor_Intel

                Currently the issue is under investigation, if you need to get in to BIOS you can do so by moving the BIOS jumper from pins 1-2 to 2-3 and get in.

                 

                Flashing the BIOS via recovery method to the same version also helped in some cases.

                • 5. Re: DH77EB bios setup not loading after update
                  Dmitry

                  Today I tried to update the BIOS from 0053 to 0099.

                  I have a problem. computer does not start: it runs, but after 3 seconds overloaded.

                   

                   

                  How do I solve this problem?

                  • 6. Re: DH77EB bios setup not loading after update
                    Giancarlo Calderón

                    I have exactly the same problem, but my mainboard is DZ77BH-55K. It just keeps restarting after 2 seconds

                    • 7. Re: DH77EB bios setup not loading after update
                      Victor_Intel

                      Hello,

                       

                      It seems like most of the cases are for people jumping from very old BIOS to the latest versions and using the express method.

                       

                      I recommend you to try using the recovery update or the F7 method and not to jump that many versions in a row. Some important changes are made in some of the updates that might cause a conflict with some configurations.

                       

                      Regards