8 Replies Latest reply on Jul 2, 2013 1:42 PM by Jerry C

    Advanced tab on 82579v driver not present

    telecore

      I recently upgraded my Windows 7 Pro 64 bit DVR PC to a DZ75ML-45K motherboard with a core i3 3220 cpu.  I bought this specifically, because of the on-board Intel Network chip.  When I install the latest driver for the 82579v network adapter, the "Advanced" tab becomes unavailable.  Is there any way to force this to be available?  (It is available when I use the older driver on the motherboard CD).

       

      I specifically need to turn off Interrupt moderation, set the IM rate to zero, and max out TX/RX buffers.  I need to adjust settings on this tab because I am receiving and sending a bunch of HDTV streams over the LAN between multiple Silicondust HDHR and HDHR Prime devices and several Media Extenders.  Before upgrading, I had to install an Intel Gigabit CT PCIe LAN adapter and modify the Advanced settings to get everything streaming glitch-free on an AMD based system (instead of using the on-board Realtek network chip).

        • 1. Re: Advanced tab on 82579v driver not present
          mark_h_@intel

          I am surprised that the advanced tab is unavailable, and I am not sure as to why. But I do have some suggestions that can sometimes clear up strange and unexplained issues.

          1. Download and run the utility at http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22026
          2. Download the latest software for you desktop board from http://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=22108. Don't run the software until after step 3.
          3. In Windows Control Panel uninstall Intel Network Connections software. Remove all components including the driver.
          4. You will need to rescan for hardware changes in the Windows device manager (or reboot) after uninstalling the driver.
          5. Install the latest software you downloaded in step 2.

          I hope this helps.

           

          Mark H

          • 2. Re: Advanced tab on 82579v driver not present
            telecore

            Thanks - I will try that when I get a block of free time (taking the machine down prevents TV viewing in my house).  Your link to the driver is the same one that I was installing.

             

            I have a related question as well - should the on-board 82579v perform as well as the Intel Gigabit CT PCIe Adapter?  Things are working mostly well, but when the DVR is recording a bunch of shows simultaneously, there are some minor occasional digital glitches.  Previously, everything was flawless with the Gigabit CT card in the old system and I know that the current CPU performance is higher than the previous CPU.

            • 3. Re: Advanced tab on 82579v driver not present
              mark_h_@intel

              If the Intel Gigabit CT Desktop adapter from your old system is available, I would give it a try. In theory your built-in gigabit network connection should be sufficient. However, you might find that in your setup the add-in adapter might work better for you (or not). If you have the adapter, a test is probably worth running to find out which works best.

               

              After doing a Google search for silicondust 82579 I found at least one other instance of someone having trouble using the 82579V, so trying the other adapter is probably a good idea. (I don't know what the real issue was in the other thread I saw. I only know that maybe using a different adapter might help.)

               

              Mark H

              • 4. Re: Advanced tab on 82579v driver not present
                Jerry C

                Mark,

                 

                I'm experiencing similar difficulties with the latest 82579V driver, dated 2/21/2013, version 12.6.45.0.  These properties are listed for the network adapter properties.  The version that was listed in the Programs and Features control panel is 18.x.  I only see the generic Microsoft dialog boxes, not the Intel dialog boxes with all the additional options.

                 

                I have since reverted to 17.4.95.0 (viewed in Programs and Features control panel).  The Intel options are all displayed normally.

                 

                I followed all the steps you advised telecore to do.  Is there something else I can try?

                 

                I am running Windows 7 Ultimate x64.

                 

                Thanks!

                • 5. Re: Advanced tab on 82579v driver not present
                  mark_h_@intel

                  Hi Jerry,

                  Are you missing the "Link Speed" tab, but you can see the "advanced" tab on the adapter properties

                   

                  I'm not sure which board you have, but I can direct you to the latest generic drivers:

                  http://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=18713.

                   

                  When you run the download package, make sure you install PROSet (and ANS) depending on what properties tabs you want to add on. You only need Advanced Network Services for configuring VLANs and teams, but PROSet is handy for the help files and diagnostics that you get by adding it.

                   

                  You could try doing an uninstall on 17.4.95.0 before loading version 18.3.x.x. On the other hand, if 17.4 is working well for you , you might want to just stick with that version.

                   

                  I just installed 18.3 on the laptop I am using now. I have PROSet installed and I get the "Link Speed" tab that is added by PROSet. My device is the 82579LM, which is very similar to yours. The installation package should be working unless some other software (security?) is interfering.

                   

                  Mark H

                  • 6. Re: Advanced tab on 82579v driver not present
                    Jerry C

                    I tried uninstalling 17.4.95.0 and reinstalling 18.3.x.x and got the same result.

                     

                    Here is the dialog I am seeing: http://imgur.com/8UcY7kR  As you can see, there are only a few options available.  I have tried checking both PROSet and ANS, and just checking PROSet.

                    • 7. Re: Advanced tab on 82579v driver not present
                      mark_h_@intel

                      Hi Jerry,

                      If you uncheck PROSet so you only install the base driver, do you get an advanced tab?

                      • 8. Re: Advanced tab on 82579v driver not present
                        Jerry C

                        Hi Mark,

                         

                        Yes, that does give an advanced tab.  I suppose most of the options are there but the dialog isn't as informative as I get with the 17.4 driver.  Still, it is progress.

                         

                        Here is a screenshot: http://imgur.com/V34hHTq

                         

                        Is there anything I can do to produce the full-featured dialog box?