1 Reply Latest reply on Dec 5, 2012 9:23 AM by john_s@intel

    Intel Raid Problem: All of the disks from your previous configuration are gone

    MonkY

      Hello everyone!

       

      My Raid Controller Intel RS2BL080 died on me about a week ago. It was simply refusing to boot saying there is no HDD detected and wanted me to power off each time (with no option to enter the configuration utility). I have sent the card to RMA and in a week or so i received another one (after looking at serial numbers and codes, the one i received seems like an older board, maybe even a refurbished one).

       

      Anyway, i have installed the controller i just received, and after booting for the first time, it detected my Virtual Drive (i had 6 x 2TB drives in RAID 5). I booted into the OS, checked my files and i was really happy to see my 10TB of data are still there and OK. But then... my Intel Raid Controller proved me how wrong i was!

       

      I powered down the system and closed the computer case (considering it was a job well done). Powering on the system though... i get this message: "All of the disks from your previous configuration are gone. If this is an unexpected message, then please power off your system and check your cables to ensure all disks are present. Press any key to continue, or press "C" to load the configuration utility."

       

      I have checked and rechecked all the cables. I even moved the RS2BL080 card into another PCI Express slot (just to be sure). It detects all my drives correctly, but there is no RAID 5 (or virtual drive).

       

      I have tried to enter the configuration utility (and then RAID Web Console 2) but there is no Virtual Drive and all my 6 drives are seen as Unconfigured Good. I have also tried to import a Foreign Configuration (as stated in Intel manual), but all i received was "No foreign configuration is found". I can also see in logs the only warning beeing "Controller ID:  0   Previous configuration completely missing at boot".

       

      I have decided to update the firmware, hoping that the updated one will work better and detect my old configuration. It didn't help at all...

       

      What else can i do now? I am afraid the "new" Intel RAID card just made me lose all my data... and that would definitely kill me and my job.


      Please help!

      Thank you in advance!

        • 1. Re: Intel Raid Problem: All of the disks from your previous configuration are gone
          john_s@intel

          MonkY,

           

          In normal operation there are two configuration copies in a RAID controller/array system. One on the controller and one on the disks. Obviously the configuration, both of them, in your instance have been lost. I can't say why, but without a configuration found that seems to be the case.

           

          If you previously saved your raid configuration to a file, you could restore the configuration from that. If you don't have a configuration file, you could try recreating the RAID 5 with THE EXACT same parameters, and NOT DO an initialization. If you do an initialization, all data on the disks will be lost. That may be able to recover the configuration/array.

           

          Beyond that, you  would have to restore from your backup.

           

          Regards,

          John