1 2 Previous Next 18 Replies Latest reply on Apr 13, 2014 12:10 AM by gunslingerfry

    Cant enable intel smart response technology acceleration

    Nicol

      I just bought a new computer with a 2TO SATA disk with Windows 8 on it and a 32gb SSD drive. With the Intel utility that came installed, there is a possibily to use the SSD drive as cache to accelerate your main hard drive. However,  when I go to the acceleration tab, it prompts me for which SSD I want to use (I only have one), ask me how much of it I want to use for caching (the whole thing), ask which physical disk I want to accelerate (C:), and asks which mode to enable (I've tried both).

       

      Every time it pops up an error and says that an unexpected error has occured while tryign to enable acceleration and to restart my computer and try again. I've tried again and again, and get the same error every single time

       

      I updated the firmware on the SSD, ensured that I had the latest iSRT installed, as well as checked my bios settings.

       

      Please help, I have looked all over online and haven't found any clues.

       

      Thanks

        • 2. Re: Cant enable intel smart response technology acceleration
          saltgrass

          I will be trying to set up such a system next week, so I have been doing some research.  There are several requirements to use Smart Response.  Have you complied with those, like have RAID set in the SATA controller?

           

          Just a note, if you are not currently using RAID, I certainly would not advise changing it, you might loose your system.

           

          The requirements seem to require a 77 chipset of certain types although a video seems to suggest a Z68 would work.

           

          You say the IRST shows 2 SSDs.  Was it partitioned previously, and the partition needs to be as large as your installed memory amount.

           

          Next week I may have better guidance.  Right now I am still trying to see if there is any difference between Smart Response and Rapid Start.

           

          Edit:  I do have a Bios option to enable Intel Rapid Start...

          • 3. Re: Cant enable intel smart response technology acceleration
            Nicol


            Yes, I am using RAID in my Bios.

            I looked at the characteristics of my motherboard and Smart Response is compatible with it.

             

            IRST shows 1 SSD, not 2.

            I have 16GB of memory installed, the disk is 32GB. That's the way my computer came from factory.

             

            From what I read, Rapid Start and Smart Response is 2 differents things. Rapid Start will accelerate your boot time, but thats it.

            • 4. Re: Cant enable intel smart response technology acceleration
              saltgrass

              I agree about the Smart and Rapid differences.

               

              The Rapid Storage utility has quite a bit of info in the help section, including a troubleshooting area.

               

              Do the drives look normal in Disk Management?  Do you have any reason to believe the SSD is defective?

               

              If no one else responds, I will be back after I get my system set up...if I can get it set up..

              • 5. Re: Cant enable intel smart response technology acceleration
                Nicol

                I looked all over for this, even on Intel's help section.

                I found one post on another forum with a guy who had the same problem earlier this year but I havent had a response from him.

                Everything seems ok in disk management and I don't think the drive is defective.

                • 6. Re: Cant enable intel smart response technology acceleration
                  Nicol

                  Most people having problems with the acceleration feature had the acceleration tab greyed out and could not activate it.

                  • 7. Re: Cant enable intel smart response technology acceleration
                    saltgrass

                    I just got my SSD and set up the system.  I will go through my process to see if you notice any differences.

                     

                    SanDisk 32 GB "ReadyCache" SSD

                     

                    Booted and open Disk Management.  The drive was shown as RAW, so I initialized it to GPT (UEFI system).

                     

                    Open the Rapid Storage utility, which took quite a while to come up. The Accelerate button was now visible and I selected "Enable Acceleration".  Used, as you did, full capacity, Primary Hard Drive and Enhanced.  There may be a difference here since I did not use just c: but the entire drive.  I assume that is what is means by Physical Drive.

                     

                    Hit OK and after some drive activity, the system showed "Enhanced Mode Enabled".  The SSD disappeared from Disk Management and Diskpart.  In the Rapid Storage utility it shows as Volume_0000, Type: RAID 0.

                     

                    Since I have now gone through the process, I will be better equipped to answer questions.

                    • 8. Re: Cant enable intel smart response technology acceleration
                      Nicol

                      Ok, two things.

                       

                      - what do you mean by initializing the disk to GPT (UEFI system) ?

                      - you said you did not use just c: but the entire drive. Do you have a couple of partitions of the drive ?

                      • 9. Re: Cant enable intel smart response technology acceleration
                        saltgrass

                        The configuration of the drive does not seem to be important.  The process will reconfigure it.  So setting it to GPT for a UEFI install is not necessary.

                         

                        I only have the option to select an entire hard drive to accelerate.  Yes, there are 2 partitions on my primary (OS) drive, but I cannot select just C: .  This is probably the same thing you are seeing.  I don't suppose you are seeing an option to Disassociate the SSD in the Rapid Response window?  If the SSD had be set up previously, it may still be configured for the other system, but this is just a remote possibllity.

                         

                        The process seems fairly straight forward.  Since it does not appear to be working that way for you, possibly a firmware update for the SSD may help.   There are probably some SSD drives that might be incompatible for some reason.

                         

                        Because the data transfer speeds were being reduced to such a great extent, I am no longer using the Smart Response Technology.  My testing seems to indicate the transfer speeds for file transfers will drop about 90% in Windows 8 for large files (> 7 GB).  Windows 7 seemed to be OK for me.

                         

                        Edit:  I have discovered the reason for the decrease in transfer speeds was the SSD I was using.  Replacing it with a faster, but still SATA III, drive allowed the transfer speeds to function normally.

                         

                        But I have now used 2 different SSDs for SRT and both could be set up and seemed to function correctly.

                        • 10. Re: Cant enable intel smart response technology acceleration
                          ajb

                          how is your partition table? have a look at Re: No Acceleration with RST, Problem found

                          I was able to enable acceleration after deleting a second NTFS primary partition

                          • 11. Re: Cant enable intel smart response technology acceleration
                            Nicol

                            As you can see in the screenshot below, I have 5 partitions of my primary 2 Go disk. This is the way it came from the factory and I have not changed anything.

                            My first partition is a 600 Mo Backup Partition; then a 260 Mo EFI System partition. My C: 150 Go partition where my OS is installed and a D: Data 1600 Go partition. Finally there is a 15 Go Backup Partition.

                            I can not delete or modify or assign a letter to any of the backup partitions.

                            Do you think this is the cause of my problem ?

                            According to Sandisk, I have the latest driver for my SSD Drive.

                             

                            screenshot.jpg

                            • 12. Re: Cant enable intel smart response technology acceleration
                              ajb

                              I would try the following: Backup all your files of the Data (D:) partition to another disk or to C: and delete it or boot Linux to toggle the second NTFS partition to another non-NTFS partition type like 83 (Linux). Then reboot and try to accelerate the system partition - if you can accelerate it, it's nearly the same case as mine except that I don't use the GPT but the MBR partition scheme.

                              • 13. Re: Cant enable intel smart response technology acceleration
                                GzyOnline

                                Lenovo U310 Touch, 500GB+24GB SSD ..Haven't seen an "Accelerate" option with my Intel Rapid Storage Technology so I went into BIOS, my SATA settings were set to AHCI, so I changed it to RAID, a few seconds later I scrolled down to your post that said "i would not advise to changing it".... luckily it didn't fry my system!! Any idea how I can get the Accelerate option? Thanks!!!

                                • 14. Re: Cant enable intel smart response technology acceleration
                                  saltgrass

                                  It is really not me that says that, but some OEMs.  Probably it would always be better to install a system with the correct controller.  But I have changed my systems on some occasions without problems.

                                   

                                  Did you find a place to show you how to change them in Windows 7?

                                   

                                  If the SSD was already in the system, was it being used for something else, like Rapid Start?  Does it show up in the Intel Rapid Storage Technology as being available...?  Some options may be in the Bios for such things.

                                  1 2 Previous Next