6 Replies Latest reply on Jul 1, 2014 10:48 AM by joe_intel

    Unable to use OpenCL on HD4000


      I have a Core i7 3770K running Windows 8 Pro 64-bit. I have the latest drivers (2875, released 10/22/2012) and the latest OpenCL SDK. My only display is connected to the motherboard via native HDMI 1.4.


      The motherboard is an Asus P8Z77-V. I have 32 GB of system memory. I also have an AMD Radeon HD7970 connected by PCI Express 3.0, with no displays plugged into the Radeon, and the AMD Catalyst 12.10 drivers installed.


      My problem is that, no matter whether the program is 32-bit or 64-bit, hand-written or third-party, I cannot for the life of me get the Intel OpenCL drivers to run on the HD4000 on-board GPU, no matter what I try. The Radeon OpenCL works fine when the Catalyst drivers are installed.


      I have tried with LucidLogix Virtu MVP software both installed, and uninstalled.

      I have tried with the Multi-Monitor Support function in the BIOS enabled, and disabled.

      I have tried with the Radeon physically removed from the system and the Catalyst drivers completely removed.

      I have tried uninstalling and reinstalling all Intel and AMD software on my system.

      I have tried 32-bit programs, and I have tried 64-bit programs.

      I have tried with a display connected to the AMD Radeon, and without.

      I have tried with a display connected to the motherboard's DVI port, and without.

      I have tried with a display connected to the motherboard's HDMI port, and without.

      I have tried completely reinstalling Windows 8 Pro.

      I have tried with no custom drivers whatsoever, just whatever comes stock with the Windows 8 operating system.

      I have tried with supported programs such as GPU Caps Viewer, and with a hand-written OpenCL program written in C.

      I have tried with Intel Virtualization Technology enabled, and disabled, in the BIOS.

      I have tried using the default Khronos OpenCL ICD Loader, and with the one that can be built from the open source Mesa project. I even recompiled the Khronos OpenCL ICD from source code using Visual Studio 2012, and enabled the trace statements to see what it was doing, and it picked up the OpenCL ICD correctly.


      The only thing I haven't tried is throwing my computer out the window and replacing it with an AMD CPU. Should I try that next? Or what am I missing that will allow me to use HD4000 OpenCL on Windows 8 Pro?