11 Replies Latest reply on Feb 3, 2013 3:33 AM by Wracky Branched to a new discussion.

    DZ77GA-70K Keyboard problems (PS/2 and USB)

    Wracky

      Hi everyone, and thanks for reading.

       

      Since BIOS 0.39, I've been having some different keyboard issues with my DZ77GA-70K

      Every time I read the patch notes for the new versions, I get my hopes up, hoping the issues would be resolved, but the problems only seem to get worse.

       

      I own a Filco Majestouch keyboard, which I would have connected to PS/2. The board worked fine (except in safe mode), both on USB and PS/2 mode under bios 0035. With the upgrade to 0039, which was supposed to addres the problem with PS/2 keyboards in safe mode, the keyboard stopped working all together on PS/2, so I switched to USB.

       

      I've tried 0045 as wel. PS/2 still wouldn't work. Now recently, I have updated to 0059.

      On 0059 I've noticed that not only is the PS/2 still not working, the USB is now also having troubles. Simple Post now takes around 10 seconds longer when the keyboard is connected. The LEDs for num, caps, and scroll lock, all light up, the screen stays black, and it takes a while before the boot-screen shows, upon which the keyboard starts working. However if I reboot my PC, or simply turn it off and on again, the keyboard stays unresponsive until far into the windows boot process (leds stay on, not able to enter the BIOS). I have to unplug and replug my keyboard to get it to enter the BIOS again.

       

      Is there anything I can do to fix this? or is this an issue with the BIOS and do I need to wait for more updates?

      Downgrading back to 0035 is not an option for me, because of other issues (LAN to name one)

       

      Kind regards,

      Wracky

        • 1. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
          manuelh

          Try the latest 0060 BIOS update, it fixed the USB issues for me.

          • 2. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
            Wracky

            Thanks for your reply!

             

            Where do I find the 0060 Bios ?

            If I go to the download center for the DZ77GA-70K, and select BIOS as download type, it only shows the files for BIOS up to 0059.

             

            Thanks!

            • 4. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
              Wracky

              Thanks for the reply.

               

              So after clicking your link I went to the download center again, and lo and behold: 11 bios updates including 0060. Don't know why I didn't see it before. (it showed only 10 updates)

               

              Unfortunately, the problems persist with 0060, and nothing has changed. Thanks for the help though.

              • 5. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                manuelh

                Have you updated the the following latest versions (Chipset Drivers, Management Engine, USB 3.0) :

                 

                Download Center

                 

                Download Center

                 

                Download Center

                • 6. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                  Wracky

                  Thanks for the links.

                   

                  I've updated the drivers you mentioned, and I'm sorry to say that that didn't help.

                   

                  Perhaps it's worth mentioning, that when I switch my Keyboard to a different USB port, it will work ONCE in the BIOS after a reboot. However, if I switch it to USB 3.0 (It's currently attached to 2.0) it seems to work once, but the PC completely freezes at the Startup bios screen after I exit the BIOS (which makes it worse, really)

                   

                  Is this a compatibility issue between the DZ77GA-70K and my Filco Majestouch ? If so, is it going to get resolved in a future update? Currently it seems like very update makes it a bit worse ;-)

                   

                  Thanks for reading.

                  • 7. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                    Wracky

                    I just tried Bios 0061, which has the same problem.

                    It seems to me like my problem might be related to thisone: Re: DZ77GA-70K USB regression in BIOS 53

                     

                    As mentioned my keyboard worked fine on 0045. I didn't try 0049 like rbmorse did, but I reckon something went wrong between 0045 and 0059, or perhaps, like rbmorse indicated, between 0049 and 0053.

                     

                    I'll keep checking the upcoming updates, and I really hope this can be fixed sometime in the future.

                     

                    Thanks for reading.

                    • 8. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                      rbmorse

                      I have some whack in 0061, too.  USB keyboard/Mouse work in USB 3 ports, but if connected to one of the USB 2 ports the machines stalls at the splash screen, before the boot option prompts appear. Will stay like that overnight, if I let it.

                       

                      I just thought of something while typing this.  I have the Logitech dongle for the wireless mouse/trackpad attached to the keyboard's built-in USB hub.  I wonder if that's what keeping the BIOS from initializing when the keyboard is attached to the USB 2 port.  An experiment is in order...

                      • 9. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                        Wracky

                        Hi rbmorse, and thanks for replying!

                         

                        I also have the splash screen problem you describe, with the difference that for me, it doesn't matter if the keyboard is connected to the USB 2.0 or the USB 3.0. When it does that, I have to unpower the machine, and re-plug the keyboard a few times (switch it to other ports) before the system will boot again.

                         

                        This is almost never a problem with a cold boot, and almost always a problem after exiting the BIOS.

                         

                        I am starting to get incentivised to downgrade the bios to 0035 if possible, when at least keyboard (even PS/2 mode) was working correctly for me, as it feels like problems are getting worse with every upgrade.

                         

                        You mentioned you have a USB hub connected. I have one too. It's in the monitor. However nothing is connected at this time. I use it occasionally for an external hard drive. I could try and unplug that, to see if it makes any difference.

                         

                        In the mean time: Intel? Any word on this?

                         

                        Thanks for reading.

                        • 10. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                          m6bigdog

                          Wracky,

                          I have a DZ77GA-70K with i7-3770-k processor with the 0061 BIOS installed.

                           

                          I too have a new Filco Keyboard and I experienced PS/2 and USB issues when I installed the keyboard.

                          Initially, I could never get the PS/2 port to recognize the Filco keyboard with the supplied USB adapter.

                           

                          I got the PS/2 port working with my Filco by using a StarTech PS22USB adapter.  Ditched the passive USB to PS/2 adapter that was supplied with the keyboard.

                           

                          While I was working out the PS/2 issues the BIOS/BOOT would occasionally halt with a POST code of 92 with the Filco keyboard connected directly to the rear panel USB hub. Like you I had to allow the system to BOOT to a point then I would plug the keyboard into the USB port to get around the BIOS halt. I discovered this was due to a D-Link USB2.0 4-port extender that was also attached to the rear panel high-current USB2.0 hub.  The BIOS boots normally with the D-Link USB port extender disconnected.

                          The D-Link USB extender did not cause a problem with an older PS/2 keyboard connected thru a Belkin PS/2 to USB adapter to the same USB2.0 port.

                           

                          I anticipate that there are issues with the current BIOS that are actually causing the PS/2 and USB keyboard issues however until that is resolved, I suggest either disconnecting any external USB Hub extenders to see if that solves the USB keyboard BOOT/BIOS recognition issues or using the PS22USB adapter and moving the keyboard to the PS/2 port.

                          • 11. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                            Cam Platts

                            Same issues here with the USB ports. During bootup I notice the USB ports reset (disconnecting attached devices) thereby rendering my USB keyboard/mouse inoperable until Windows has completely loaded.  I have the current release of bios and MOBO drivers. This 'disconnect' of all USB devices does not happen on my DZ77SL-50K motherboard.

                            • 12. Re: DZ77GA-70K Keyboard problems (PS/2 and USB)
                              Wracky

                              Hi m6bigdog,

                               

                              Thanks for the reply.

                              Someone else suggested earlier that other USB peripherals might cause these USB issues. I've disconnected all USB devices except the mouse (which is a Logitech G9 in case anyone cares) and the filco (since it no longer works on PS/2) . Doesn't make a difference for me.

                               

                              The best part? The Filco worked perfectly, USB and PS/2 mode, on BIOS 039. I was thinking about reverting to that one if possible, however I also had some network issues with that at the time. Perhaps I could revert back to 049. PS/2 didn't work then, but at least my USB worked properly.

                               

                              The biggest point here is, that it really looks like Intel broke it, and, 11 versions later, it just got worse.

                              I am thinking about calling up RMA of the company where I bought the bord, and see if I can get a different one through warranty, since this one simply doesn't do what it says on the tin. In more ways than one!

                               

                              I understand hardware compatibility problems, but I cannot get over the fact that it used to work!

                              I'm not spending 80 bucks on a USB to PS/2 converter when this board should be completely capable of supporting this my setup.

                               

                              Thanks all for your replies. Its good and sad at the same time to read I'm not the only one having troubles.

                              I just hope Intel would step up and take responsibility.