6 Replies Latest reply on May 28, 2013 6:30 PM by AllanGamer

    Windows 8 - Hibernation/Wake-on-Lan Issues - Intel 82579V NIC

    fr3lncr

      I've spent some time searching for an solution to my problem but I can't find it on my own so hopefully someone will have some advice.

       

      Essentially, I've been trying to configure my PC so that I can keep it in Hibernation mode when I'm not using it.  The reason I want to keep it in Hibernation mode and not just power it off is that my PC is also my server so I need it to power up when I'm streaming my shows to the TV or access files on my laptop.

       

      The problem is that when it goes into hibernation mode (either manually or automatically) the PC keeps waking itself up when I'm not around or doing anything (i.e. nothing else on the network 'should' be trying to access the PC).

       

      I've run 'powercfg' and it is saying it's the Network card that it waking it up but I'm getting no more info than that.

       

      Here's the system info:

       

      OS: Windows 8 Enterprise

      Motherboard: Asus P8Z77-V Pro

      NIC: Intel 82579V Gigabit Network Card (w latest driver version 12.2.45.0 installed)

      Router: dLink DIR-825

       

      What I've done so far:

      • According to Microsoft, Windows 8 has changed their power profiles so that Wake-On-Lan can only work in either Sleep or Hibernation mode (not power off) so it is set to go to Sleep after 30 minutes and Hibernate after 60 minutes (http://support.microsoft.com/kb/2776718).
      • Made sure nothing else would wake up the computer like small movements from the mouse.  So, the power management settings for my Logitech keyboard and mouse have been changed to not wake the PC.  Powercfg now lists only the NIC as being able to wake the PC.
      • There doesn't seem to be any settings in the BIOS for the motherboard that would affect the computer waking up.  The 'APM' (Advanced Power Management) settings are all pretty much disabled for Wake form PCI/Wake from PCIE.
      • I've cleaned up the scheduled tasks in Windows 8 to disable anything that may be waking it up.
      • There seems to be nothing in my router that I can set for Wake-On-Lan.
      • Windows 8 File Backup is turned on.
      • Windows 8 Event viewer is only stating that the wake source is the LAN.  Example:
        • The system has returned from a low power state.
          Sleep Time: 2012-11-18T19:32:27.037670400Z
          Wake Time: 2012-11-18T19:35:43.846373900Z
          Wake Source: Device -Intel(R) 82579V Gigabit Network Connection

       

      So, I've been trying to figure out what is waking it up.  The other devices on my network are:

      • Epson 835 printer (I can't see that needing the PC and it's turned off)
      • HTPC running XBMC (The PC is still turning on when this is kept off but it does wake up the PC when I turn it on).
      • Denon network receiver (Technically, my PC is set to stream audio to the Denon but I don't know how to check to see if that is the cause)
      • A couple of PlayBooks but neither of them are running anything to grab files from the PC.

       

      I'm really at my wits end since I'm trying to find a power friendly way to keep my computer ready without having to keep it on full time.  I'm trying to narrow down the source so I plan on posting here, the Asus forums and Windows forums.

       

      Thanks in advance for any support you may have.

       

      Cheers.

        • 1. Re: Windows 8 - Hibernation/Wake-on-Lan Issues - Intel 82579V NIC
          Mendota Kelly

          This is what worked for me. There should be an option on your card in Device Manager to only allow the network card to be woke up with only a "magic packet". Select that option. A search on the web will lead you to sites that offer freeware to create the packet. This is not as mysterious as it sounds. Basically the magic packet uses the actual hardware address of the card to send a signal to the card to wake it up.

          This is the only way to keep the card from constantly waking itself and the computer. I don't have the name of the program I use right at hand, but I can post it later on today.

          • 2. Re: Windows 8 - Hibernation/Wake-on-Lan Issues - Intel 82579V NIC
            fr3lncr

            Thanks for the help.  Unfortunately magic packet is already checked and it doesn't help.  I've pretty much tried checking and unchecking all the power management options to no avail.  At this point, I think I'll just give up and go back to Windows 7 just to remove the operating system from the equation. 

            • 3. Re: Windows 8 - Hibernation/Wake-on-Lan Issues - Intel 82579V NIC
              Mendota Kelly

              Have you tried turning off scheduled tasks all together? I am running Windows 8 pro, not Enterprise so that could be a factor. I would try calling Microsoft. The support is free at this point, might as well take advantage. Sometimes real time trouble shooting is the best way to go. I was once on the phone for two hours, but they stayed with it and worked out the problem.

              • 4. Re: Windows 8 - Hibernation/Wake-on-Lan Issues - Intel 82579V NIC
                fr3lncr

                Hello,

                 

                Yes, disabling all the scheduled tasks was one of the things I tried but it didn't help.  I guess I can close this request as I've gone ahead and moved back to Windows 7.  So far, my computer isn't waking up on its own which leads me to believe that there is either an issue with Windows 8 that needs to be sorted out, or ASUS or Intel need to update some of their drivers. 

                 

                I'll try Windows 8 again in a year and see how it goes as hopefully there will be better drivers and more patches but at this point there aren't any benefits for me to stick with it.

                 

                Thanks again for your help.

                 

                Cheers.

                • 5. Re: Windows 8 - Hibernation/Wake-on-Lan Issues - Intel 82579V NIC
                  Alex

                  Have you tried un-checking "Wake on Pattern Match" ? It's the next option under Wake on Magic Packet.

                   

                  This stopped spontaneous wakes for me.

                   

                  Thanks,

                  Alex.

                  • 6. Re: Windows 8 - Hibernation/Wake-on-Lan Issues - Intel 82579V NIC
                    AllanGamer

                    Hi, I'm having this issue too. My motherboard is from ASUS, model Sabertooth Z77.

                    What I've notice is when I try to change anything on NIC properties page, the dialog hangs, no error is presented and the only option I have is to kill the task on task manager.

                    So I chose the option to update only the drivers, without installing other Intel (useless..) features.

                    Now I can change the settings fine, but I need the WOL feature and the PC keeps waking up a few minutes after going to stand by.

                    I did a simple test and REMOVED the network cable (Cat6) and the PC woke up again... This way I can be sure there is nothing else on my network (ASUS RT66 router) sending any kind of signal the NIC could interpret as a wake up signal.

                    So definitely is an issue with the Intel driver, as I had uninstalled it and was using the default Windows 8 driver without issues. But from time to time the Windows Update updates the NIC driver again...

                    If I disable WOL the problem is "fixed", but I need WOL to turn my PC on remotely when needed.

                     

                    Regards.